DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense) 

In vielen Netzen von Unitymedia sind Internet und Telefonie bereits verfügbar.
Forumsregeln
  • Kunden aus Hessen und Nordrhein-Westfalen können über die Rufnummer 0221 / 466 191 00 Hilfe bei allen Problemen in Anspruch nehmen.
  • Kunden aus Baden-Württemberg können über die Rufnummer 0711 / 54 888 150 Hilfe bei allen Problemen in Anspruch nehmen.
Wechseler
Übergeordneter Verstärkerpunkt
Beiträge: 546
Registriert: 06.02.2018, 03:54

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von Wechseler » 12.04.2018, 16:47

Zitat aus dem OpenWrt-Wiki:
Dual-Stack Lite tunnel (ds-lite IPv4 in IPv6)

ds-lite is a transitioning-mechanism which is used by ISPs to support legacy IPv4-connectivity over a native IPv6 connection.

In Chaos Calmer and later the configuration is usually auto-detected and manual configuration is not needed, simply installing the ds-lite package (and rebooting) is usually enough.
Also wenn es nicht funktioniert, würde ich empfehlen, das IPv4-WAN-Interface ("wan") komplett auf "Unmanaged" zu setzen und den Router mit installiertem ds-lite-Paket neu zu starten.
Bild
Hardware: Technicolor TC4400 / Zyxel Speedlink 5501 | Linksys WRT1200AC (OpenWrt 17.04) | Gigaset C430 IP | Cisco SPA112

MaXX
Kabelneuling
Beiträge: 45
Registriert: 21.01.2018, 22:22
Wohnort: Baden Württemberg

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von MaXX » 12.04.2018, 16:52

der-tim hat geschrieben:
12.04.2018, 16:40
Also, wenn es JP hilft kann ich das noch machen :super:

Aber hatte nicht hier jemand bereits probiert sich mit nem anderen AFTR als zugeteilt zu unterhalten? Das hat doch eh nicht geklappt, oder?
Marcus: kannst du mit dem AFTR den ich gepostet habe surfen?
Tim: Den kann ich nichtmal anpingen und noctarius
konnte mit meinem auch nichts anfangen. Ich denke
zumindest UM NRW und UM BW haben verschiedene
die man auch nicht untereinander erreichen kann.

Grüße
Marcus
Baden-Württemberg
Unitymedia 2play Fly 400 - DUAL STACK
APU2C4 mit OpenWrt NAPSHOT @ Technicolor TC4400

Bild-Bild

xauser
Kabelneuling
Beiträge: 19
Registriert: 16.11.2017, 22:50

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von xauser » 12.04.2018, 19:26

Ich habe es jetzt geschafft mit einer pfSense hinter einer Connect Box per IPv6 Tunnel zum AFTR den IPv4 Traffic zu routen. Schön ist das nicht, pfSense schafft es nach dem Reboot nicht alles richtig aufzubauen. Ich muss erst den Tunnel erneut speichern damit ich die remote Tunnel IP pingen kann und ich muss das Gateway erneut speichern damit ich externe IPv4 Adressen pingen kann. Dazu kommt noch dass meine Leitung super langsam ist :(

noctarius
Kabelexperte
Beiträge: 138
Registriert: 10.01.2016, 19:39

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von noctarius » 12.04.2018, 22:08

Das Problem habe ich ja auch in opnsense. Die Dependencies von Tunnel zu Interface funzt nicht komplett. Wie einer der opnsense Devs meinte "the paper is all there, we just need some more glue" ;-)

So wie ich es verstanden habe, ist der komplette GIF / GRE Part derzeit nicht für dynamische IPs ausgelegt. Ergo bin ich dabei (für opnsense) den ganzen Kram zusammen zupatchen :D
UM NRW - 3-Play 400 - DualStack - TC4400, VLAN, opnsense, Fritzbox 7390 (für Telefon :zwinker:) - arbeite weiter an dem opnsense DS-Lite Patch :D

xauser
Kabelneuling
Beiträge: 19
Registriert: 16.11.2017, 22:50

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von xauser » 13.04.2018, 07:55

Wird mein pfSense Tunnel schneller wenn ich von der Connect Box zum TC4400 wechsel? Die Connect Box hat ja ebenfalls einen Tunnel zum AFTR offen. Evt. bekommt nur der erste Tunnel full speed?

noctarius
Kabelexperte
Beiträge: 138
Registriert: 10.01.2016, 19:39

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von noctarius » 13.04.2018, 07:59

Meine Vermutung ist es eher, dass du erst dann Full-Speed für deinen eigenen Tunnel bekommst, wenn du eine Custom-Config hast (also kein Unitymedia Gerät mehr benutzt). Aber es sind nur Spekulationen. Abgesehen davon, mein Tunnel ist jetzt schneller als bei den Versuchen vor der TC4400 Freischaltung.
UM NRW - 3-Play 400 - DualStack - TC4400, VLAN, opnsense, Fritzbox 7390 (für Telefon :zwinker:) - arbeite weiter an dem opnsense DS-Lite Patch :D

Benutzeravatar
JPDribbler
Übergeordneter Verstärkerpunkt
Beiträge: 655
Registriert: 26.02.2009, 17:20

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von JPDribbler » 13.04.2018, 09:46

Wechseler hat geschrieben:
12.04.2018, 16:47
Also wenn es nicht funktioniert, würde ich empfehlen, das IPv4-WAN-Interface ("wan") komplett auf "Unmanaged" zu setzen und den Router mit installiertem ds-lite-Paket neu zu starten.
Danke für den Tipp, werde ich testen.
Bug in Intels Puma-6-Chip
Bild

2Play 400 /40 - DS-Lite - DUAL STACK @ ARRIS CMTS mit TC4400-GEN Rev:3.6.0 FW:SR70.12.20 + WRT1900ACS v2 (LEDE SWRT SNAPSHOT r6796-56ae9f9b0b - Kernel 4.14.37)
cust-own_400000_40000_ds_sip_wifi-on.bin

Benutzeravatar
JPDribbler
Übergeordneter Verstärkerpunkt
Beiträge: 655
Registriert: 26.02.2009, 17:20

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von JPDribbler » 13.04.2018, 17:51

Mit dem r7800 und einem snapshot (hymnan build) bekomme ich nicht einmal via DHCPv6 eine Verbindung :(
Firmware Version OpenWrt SNAPSHOT r6655-3612d90351 / LuCI Master (git-18.100.55627-b2eceb0)
Kernel Version 4.9.91

Ich teste weiter...
Bug in Intels Puma-6-Chip
Bild

2Play 400 /40 - DS-Lite - DUAL STACK @ ARRIS CMTS mit TC4400-GEN Rev:3.6.0 FW:SR70.12.20 + WRT1900ACS v2 (LEDE SWRT SNAPSHOT r6796-56ae9f9b0b - Kernel 4.14.37)
cust-own_400000_40000_ds_sip_wifi-on.bin

Benutzeravatar
der-tim
Kabelexperte
Beiträge: 141
Registriert: 05.02.2018, 14:02

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von der-tim » 13.04.2018, 18:25

JPDribbler hat geschrieben:
13.04.2018, 17:51
Mit dem r7800 und einem snapshot (hymnan build) bekomme ich nicht einmal via DHCPv6 eine Verbindung :(
Firmware Version OpenWrt SNAPSHOT r6655-3612d90351 / LuCI Master (git-18.100.55627-b2eceb0)
Kernel Version 4.9.91

Ich teste weiter...
Das selbe Symptom habe ich ja auch auf dem wrt3200er! Vielleicht liegt da tatsächlich der Hund begraben.

Edit: wenn du auf dem Snapshot jetzt odhcp6c von 17.01.4 installierst (opkg install --force-downgrade odhcp6c...) dann kriegst du wenigstens eine IPv6, aber keine v4, wetten? Wieso hab ich bis jetzt aber nicht gerafft. Habs heute auch noch mal mit der Snapshot gespielt, aber leider kein Erfolg.
Technicolor TC4400, Linksys WRT3200ACM, 2play Comfort 120, Power Upload, Dual Stack :pcfreak:
Bild

Benutzeravatar
JPDribbler
Übergeordneter Verstärkerpunkt
Beiträge: 655
Registriert: 26.02.2009, 17:20

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von JPDribbler » 14.04.2018, 09:40

der-tim hat geschrieben:
13.04.2018, 18:25
JPDribbler hat geschrieben:
13.04.2018, 17:51
Mit dem r7800 und einem snapshot (hymnan build) bekomme ich nicht einmal via DHCPv6 eine Verbindung :(
Firmware Version OpenWrt SNAPSHOT r6655-3612d90351 / LuCI Master (git-18.100.55627-b2eceb0)
Kernel Version 4.9.91

Ich teste weiter...
Das selbe Symptom habe ich ja auch auf dem wrt3200er! Vielleicht liegt da tatsächlich der Hund begraben.

Edit: wenn du auf dem Snapshot jetzt odhcp6c von 17.01.4 installierst (opkg install --force-downgrade odhcp6c...) dann kriegst du wenigstens eine IPv6, aber keine v4, wetten? Wieso hab ich bis jetzt aber nicht gerafft. Habs heute auch noch mal mit der Snapshot gespielt, aber leider kein Erfolg.
Mein Test war nicht korrekt, Unitymedia hat mein Modem einfach wieder deaktiviert. Musste gestern erstmal wieder mit einer Hausfrau an der Unitymedia Hotline tanzen.... Bei mir ging nichts mehr, no-service.bin auf dem tc4400 und meiner Connect box. Irgendein Prozess ist nicht durchgelaufen und alles wurde deaktiviert, die Frau im Haus ist begeistert! :hammer: Seit heute morgen geht es wieder. Die mussten das Problem sogar an den 2nd Level weitergeben... :wut:

Ich teste erneut.... Auch mit dem downgrade
Bug in Intels Puma-6-Chip
Bild

2Play 400 /40 - DS-Lite - DUAL STACK @ ARRIS CMTS mit TC4400-GEN Rev:3.6.0 FW:SR70.12.20 + WRT1900ACS v2 (LEDE SWRT SNAPSHOT r6796-56ae9f9b0b - Kernel 4.14.37)
cust-own_400000_40000_ds_sip_wifi-on.bin

Benutzeravatar
JPDribbler
Übergeordneter Verstärkerpunkt
Beiträge: 655
Registriert: 26.02.2009, 17:20

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von JPDribbler » 14.04.2018, 14:43

der-tim hat geschrieben:
13.04.2018, 18:25
JPDribbler hat geschrieben:
13.04.2018, 17:51
Mit dem r7800 und einem snapshot (hymnan build) bekomme ich nicht einmal via DHCPv6 eine Verbindung :(
Firmware Version OpenWrt SNAPSHOT r6655-3612d90351 / LuCI Master (git-18.100.55627-b2eceb0)
Kernel Version 4.9.91

Ich teste weiter...
Das selbe Symptom habe ich ja auch auf dem wrt3200er! Vielleicht liegt da tatsächlich der Hund begraben.

Edit: wenn du auf dem Snapshot jetzt odhcp6c von 17.01.4 installierst (opkg install --force-downgrade odhcp6c...) dann kriegst du wenigstens eine IPv6, aber keine v4, wetten? Wieso hab ich bis jetzt aber nicht gerafft. Habs heute auch noch mal mit der Snapshot gespielt, aber leider kein Erfolg.
Okay, geht trotzdem nicht. Genau wie du es beschrieben hast...
Bug in Intels Puma-6-Chip
Bild

2Play 400 /40 - DS-Lite - DUAL STACK @ ARRIS CMTS mit TC4400-GEN Rev:3.6.0 FW:SR70.12.20 + WRT1900ACS v2 (LEDE SWRT SNAPSHOT r6796-56ae9f9b0b - Kernel 4.14.37)
cust-own_400000_40000_ds_sip_wifi-on.bin

Benutzeravatar
der-tim
Kabelexperte
Beiträge: 141
Registriert: 05.02.2018, 14:02

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von der-tim » 14.04.2018, 16:35

Wenn wir jetzt noch wissen würden welche Erkenntnis wir daraus schließen können :kratz:
Technicolor TC4400, Linksys WRT3200ACM, 2play Comfort 120, Power Upload, Dual Stack :pcfreak:
Bild

Benutzeravatar
der-tim
Kabelexperte
Beiträge: 141
Registriert: 05.02.2018, 14:02

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von der-tim » 14.04.2018, 17:47

Hab gerade noch mal die letzte offizielle Snapshot probiert, das find ich nun auch wieder interessant.
Mit der kriege ich auf Anhieb ohne weiteres eine funktionierende v6 Verbindung am Wan Interface (auf dem Router) aber die reicht er nicht an die Clienten im Netzwerk durch. Ich kann also Pakete vom v6 openwrt Server via opkg direkt installieren (z.B. ds-lite), aber sonst geht danach nichts weiter.

Demnach funktioniert odhcp6c so wie es soll, aber dnsmasq kommt nicht klar? Im Log steht zu all dem nichts.
So rein optisch (egal ob shell oder luci) macht es ja den Anschein dass auch ein ds-lite Tunnel aufgebaut ist (nach einem reboot ohne weitere Konfiguration versteht sich), aber faktisch kriegt nicht mal der Router eine Verbindung zum v4 Internet hin. Wie passt das zusammen?
Technicolor TC4400, Linksys WRT3200ACM, 2play Comfort 120, Power Upload, Dual Stack :pcfreak:
Bild

#DiRK
Kabelexperte
Beiträge: 123
Registriert: 27.09.2013, 20:15
Wohnort: UM NRW // 120-6 IPv6 + DS-Lite // TC4400 + Linksys WRT1900ACS mit OpenWrt (LEDE)

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von #DiRK » 14.04.2018, 19:30

Was sagt den "ifconfig"?

Wechseler
Übergeordneter Verstärkerpunkt
Beiträge: 546
Registriert: 06.02.2018, 03:54

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von Wechseler » 14.04.2018, 20:12

der-tim hat geschrieben:
14.04.2018, 17:47
Hab gerade noch mal die letzte offizielle Snapshot probiert, das find ich nun auch wieder interessant.
Mit der kriege ich auf Anhieb ohne weiteres eine funktionierende v6 Verbindung am Wan Interface (auf dem Router) aber die reicht er nicht an die Clienten im Netzwerk durch. Ich kann also Pakete vom v6 openwrt Server via opkg direkt installieren (z.B. ds-lite), aber sonst geht danach nichts weiter.
Mach mal einen Screenshot von http://192.168.1.1/cgi-bin/luci/admin/network/network
Bild
Hardware: Technicolor TC4400 / Zyxel Speedlink 5501 | Linksys WRT1200AC (OpenWrt 17.04) | Gigaset C430 IP | Cisco SPA112

Benutzeravatar
der-tim
Kabelexperte
Beiträge: 141
Registriert: 05.02.2018, 14:02

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von der-tim » 15.04.2018, 16:31

br-lan Link encap:Ethernet HWaddr 62:38:E0:C5:45:B0
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::6038:e0ff:fec5:45b0/64 Scope:Link
inet6 addr: 2a02:xxx:xxxx:xxxx::1/64 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:5098 errors:0 dropped:0 overruns:0 frame:0
TX packets:11016 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:621925 (607.3 KiB) TX bytes:5445277 (5.1 MiB)

ds-wan Link encap:UNSPEC HWaddr 2A-02-09-08-13-00-00-0C-00-00-00-00-00-00-00-00
inet addr:192.0.0.2 P-t-P:192.0.0.1 Mask:255.255.255.255
inet6 addr: fe80::88a:bbff:fe63:bae9/64 Scope:Link
UP POINTOPOINT RUNNING NOARP MTU:1280 Metric:1
RX packets:100 errors:0 dropped:0 overruns:0 frame:0
TX packets:793 errors:5 dropped:5 overruns:0 carrier:5
collisions:0 txqueuelen:1000
RX bytes:5799 (5.6 KiB) TX bytes:44923 (43.8 KiB)

eth0 Link encap:Ethernet HWaddr 62:38:E0:C5:45:B0
inet6 addr: fe80::6038:e0ff:fec5:45b0/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:5249 errors:0 dropped:0 overruns:0 frame:0
TX packets:12430 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:532
RX bytes:728733 (711.6 KiB) TX bytes:5595212 (5.3 MiB)
Interrupt:37

eth0.1 Link encap:Ethernet HWaddr 62:38:E0:C5:45:B0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:5141 errors:0 dropped:0 overruns:0 frame:0
TX packets:11246 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:626589 (611.9 KiB) TX bytes:5457237 (5.2 MiB)

eth1 Link encap:Ethernet HWaddr 60:38:E0:C5:45:B0
inet6 addr: fe80::6238:e0ff:fec5:45b0/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:28397 errors:0 dropped:0 overruns:0 frame:0
TX packets:5490 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:532
RX bytes:6201071 (5.9 MiB) TX bytes:685638 (669.5 KiB)
Interrupt:36

eth1.2 Link encap:Ethernet HWaddr 60:38:E0:C5:45:B0
inet6 addr: 2a02:xxx:xxxx:xxxx:xxxx:xxxx:5e1f/128 Scope:Global
inet6 addr: fe80::6238:e0ff:fec5:45b0/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:27282 errors:0 dropped:0 overruns:0 frame:0
TX packets:5451 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:5623025 (5.3 MiB) TX bytes:660600 (645.1 KiB)

ip6tnl0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
NOARP MTU:1452 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:14806 errors:0 dropped:0 overruns:0 frame:0
TX packets:14806 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1556849 (1.4 MiB) TX bytes:1556849 (1.4 MiB)

mlan0 Link encap:Ethernet HWaddr 60:38:E0:C5:45:B3
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr 60:38:E0:C5:45:B2
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wlan1 Link encap:Ethernet HWaddr 60:38:E0:C5:45:B1
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Das ist die Ifconfig.
Ich hab hier etwas mehr geschrieben: https://forum.openwrt.org/viewtopic.php ... 05#p375705
Technicolor TC4400, Linksys WRT3200ACM, 2play Comfort 120, Power Upload, Dual Stack :pcfreak:
Bild

pokemon20021
Kabelneuling
Beiträge: 34
Registriert: 17.12.2017, 19:00

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von pokemon20021 » 15.04.2018, 16:54

der-tim hat geschrieben:
15.04.2018, 16:31

Code: Alles auswählen

eth1.2 Link encap:Ethernet HWaddr 60:38:E0:C5:45:B0
inet6 addr: 2a02:xxx:xxxx:xxxx:xxxx:xxxx:5e1f/128 Scope:Global
inet6 addr: fe80::6238:e0ff:fec5:45b0/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:27282 errors:0 dropped:0 overruns:0 frame:0
TX packets:5451 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:5623025 (5.3 MiB) TX bytes:660600 (645.1 KiB)
könntest Du Bitte folgende Befehlsoutputs posten, so dass man mehr sieht:

Code: Alles auswählen

brctl show
swconfig dev switch0 show
netstat -rn
cat /etc/config/network
cat /etc/config/firewall
ip rule show
ip route list table 1-250
uci -n show network
Zuletzt geändert von pokemon20021 am 15.04.2018, 17:10, insgesamt 1-mal geändert.

Benutzeravatar
der-tim
Kabelexperte
Beiträge: 141
Registriert: 05.02.2018, 14:02

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von der-tim » 15.04.2018, 17:09

Klar, bitte schön:

Code: Alles auswählen

[email protected]:~# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          7fff.6238e0c545b0       yes             eth0.1
[email protected]:~# swconfig dev switch0 show
Global attributes:
        enable_vlan: 1
Port 0:
        mask: 0x0000: (0)
        qmode: 3
        pvid: 1
        link: port:0 link:down
Port 1:
        mask: 0x0000: (1)
        qmode: 3
        pvid: 1
        link: port:1 link:up speed:1000baseT full-duplex
Port 2:
        mask: 0x0000: (2)
        qmode: 3
        pvid: 1
        link: port:2 link:up speed:1000baseT full-duplex
Port 3:
        mask: 0x0000: (3)
        qmode: 3
        pvid: 1
        link: port:3 link:down
Port 4:
        mask: 0x0000: (4)
        qmode: 3
        pvid: 2
        link: port:4 link:up speed:1000baseT full-duplex
Port 5:
        mask: 0x0000: (5)
        qmode: 3
        pvid: 0
        link: port:5 link:up speed:1000baseT full-duplex
Port 6:
        mask: 0x0000: (6)
        qmode: 3
        pvid: 0
        link: port:6 link:up speed:1000baseT full-duplex
VLAN 1:
        port_based: 0
        vid: 1
        ports: 0 1 2 3 5t
VLAN 2:
        port_based: 0
        vid: 2
        ports: 4 6t
[email protected]:~# netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         0.0.0.0         0.0.0.0         U         0 0          0 ds-wan
192.0.0.1       0.0.0.0         255.255.255.255 UH        0 0          0 ds-wan
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 br-lan
[email protected]:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option stp '1'
        option ip6assign '64'

config interface 'wan'
        option proto 'dslite'
        option peeraddr '2a02:908::13:4000'

config interface 'wan6'
        option ifname 'eth1.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

Edit: ups, gleich steht da noch etwas mehr, moment :D

Nachtrag:

Code: Alles auswählen

[email protected]:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

[email protected]:~# ip rule show
0:      from all lookup local
32766:  from all lookup main
32767:  from all lookup default
[email protected]:~# ip route list table 1-250
[email protected]:~#
Technicolor TC4400, Linksys WRT3200ACM, 2play Comfort 120, Power Upload, Dual Stack :pcfreak:
Bild

pokemon20021
Kabelneuling
Beiträge: 34
Registriert: 17.12.2017, 19:00

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von pokemon20021 » 15.04.2018, 17:34

der-tim hat geschrieben:
15.04.2018, 17:09
[email protected]:~# swconfig dev switch0 show
SNIP
Port 4:
mask: 0x0000: (4)
qmode: 3
pvid: 2
link: port:4 link:up speed:1000baseT full-duplex
Port 5:
mask: 0x0000: (5)
qmode: 3
pvid: 0
link: port:5 link:up speed:1000baseT full-duplex
Port 6:
mask: 0x0000: (6)
qmode: 3
pvid: 0
link: port:6 link:up speed:1000baseT full-duplex
VLAN 1:
port_based: 0
vid: 1
ports: 0 1 2 3 5t
VLAN 2:
port_based: 0
vid: 2
ports: 4 6t

[email protected]:~# cat /etc/config/network
SNIP
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 5t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '4 6t'
könntest es sein, dass das VLAN_2 auch über CPU "5t" den Traffic schicken sollte;
einfach mal in Datei /etc/config/network den Trunk (rot markiert) auf "5t" anpassen und testen.

Bitte auch folgende Befehle eingeben und Output posten:

Code: Alles auswählen

iptables -L -vn
iptables -t nat -L -vn
ip link

Benutzeravatar
der-tim
Kabelexperte
Beiträge: 141
Registriert: 05.02.2018, 14:02

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von der-tim » 15.04.2018, 22:48

Code: Alles auswählen

[email protected]:~# iptables -L -vn
Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination                                              
 4219  452K ACCEPT     all  --  lo     *       0.0.0.0/0            0.0.0.0/0                                                         /* !fw3 */
  691 89082 input_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0                                                         /* !fw3: Custom input rule chain */
  523 49686 ACCEPT     all  --  *      *       0.0.0.0/0            0.0.0.0/0                                                         ctstate RELATED,ESTABLISHED /* !fw3 */
   22  1144 syn_flood  tcp  --  *      *       0.0.0.0/0            0.0.0.0/0                                                         tcp flags:0x17/0x02 /* !fw3 */
  151 33512 zone_lan_input  all  --  br-lan *       0.0.0.0/0            0.0.0.0                                             /0            /* !fw3 */
    0     0 zone_wan_input  all  --  ds-wan *       0.0.0.0/0            0.0.0.0                                             /0            /* !fw3 */
   17  5884 zone_wan_input  all  --  eth1.2 *       0.0.0.0/0            0.0.0.0                                             /0            /* !fw3 */

Chain FORWARD (policy DROP 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination                                              
   75  4674 forwarding_rule  all  --  *      *       0.0.0.0/0            0.0.0.                                             0/0            /* !fw3: Custom forwarding rule chain */
    0     0 ACCEPT     all  --  *      *       0.0.0.0/0            0.0.0.0/0                                                         ctstate RELATED,ESTABLISHED /* !fw3 */
   32  1652 zone_lan_forward  all  --  br-lan *       0.0.0.0/0            0.0.0                                             .0/0            /* !fw3 */
   43  3022 zone_wan_forward  all  --  ds-wan *       0.0.0.0/0            0.0.0                                             .0/0            /* !fw3 */
    0     0 zone_wan_forward  all  --  eth1.2 *       0.0.0.0/0            0.0.0                                             .0/0            /* !fw3 */
   43  3022 reject     all  --  *      *       0.0.0.0/0            0.0.0.0/0                                                         /* !fw3 */

Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination                                              
 4219  452K ACCEPT     all  --  *      lo      0.0.0.0/0            0.0.0.0/0                                                         /* !fw3 */
  653  245K output_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0                                                         /* !fw3: Custom output rule chain */
  605  241K ACCEPT     all  --  *      *       0.0.0.0/0            0.0.0.0/0                                                         ctstate RELATED,ESTABLISHED /* !fw3 */
    4  1053 zone_lan_output  all  --  *      br-lan  0.0.0.0/0            0.0.0.                                             0/0            /* !fw3 */
   44  2823 zone_wan_output  all  --  *      ds-wan  0.0.0.0/0            0.0.0.                                             0/0            /* !fw3 */
    0     0 zone_wan_output  all  --  *      eth1.2  0.0.0.0/0            0.0.0.                                             0/0            /* !fw3 */

Chain forwarding_lan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination                                              

Chain forwarding_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination                                              

Chain forwarding_wan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination                                              

Chain input_lan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination                                              

Chain input_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination                                              

Chain input_wan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination                                              

Chain output_lan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination                                              

Chain output_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination                                              

Chain output_wan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination                                              

Chain reject (5 references)
 pkts bytes target     prot opt in     out     source               destination                                              
   43  3022 REJECT     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0                                                         /* !fw3 */ reject-with tcp-reset
    9  2772 REJECT     all  --  *      *       0.0.0.0/0            0.0.0.0/0                                                         /* !fw3 */ reject-with icmp-port-unreachable

Chain syn_flood (1 references)
 pkts bytes target     prot opt in     out     source               destination                                              
   22  1144 RETURN     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0                                                         tcp flags:0x17/0x02 limit: avg 25/sec burst 50 /* !fw3 */
    0     0 DROP       all  --  *      *       0.0.0.0/0            0.0.0.0/0                                                         /* !fw3 */

Chain zone_lan_dest_ACCEPT (4 references)
 pkts bytes target     prot opt in     out     source               destination                                              
    4  1053 ACCEPT     all  --  *      br-lan  0.0.0.0/0            0.0.0.0/0                                                         /* !fw3 */

Chain zone_lan_forward (1 references)
 pkts bytes target     prot opt in     out     source               destination                                              
   32  1652 forwarding_lan_rule  all  --  *      *       0.0.0.0/0            0.                                             0.0.0/0            /* !fw3: Custom lan forwarding rule chain */
   32  1652 zone_wan_dest_ACCEPT  all  --  *      *       0.0.0.0/0            0                                             .0.0.0/0            /* !fw3: Zone lan to wan forwarding policy */
    0     0 ACCEPT     all  --  *      *       0.0.0.0/0            0.0.0.0/0                                                         ctstate DNAT /* !fw3: Accept port forwards */
    0     0 zone_lan_dest_ACCEPT  all  --  *      *       0.0.0.0/0            0                                             .0.0.0/0            /* !fw3 */

Chain zone_lan_input (1 references)
 pkts bytes target     prot opt in     out     source               destination                                              
  151 33512 input_lan_rule  all  --  *      *       0.0.0.0/0            0.0.0.0                                             /0            /* !fw3: Custom lan input rule chain */
    0     0 ACCEPT     all  --  *      *       0.0.0.0/0            0.0.0.0/0                                                         ctstate DNAT /* !fw3: Accept port redirections */
  151 33512 zone_lan_src_ACCEPT  all  --  *      *       0.0.0.0/0            0.                                             0.0.0/0            /* !fw3 */

Chain zone_lan_output (1 references)
 pkts bytes target     prot opt in     out     source               destination                                              
    4  1053 output_lan_rule  all  --  *      *       0.0.0.0/0            0.0.0.                                             0/0            /* !fw3: Custom lan output rule chain */
    4  1053 zone_lan_dest_ACCEPT  all  --  *      *       0.0.0.0/0            0                                             .0.0.0/0            /* !fw3 */

Chain zone_lan_src_ACCEPT (1 references)
 pkts bytes target     prot opt in     out     source               destination                                              
  151 33512 ACCEPT     all  --  br-lan *       0.0.0.0/0            0.0.0.0/0                                                         ctstate NEW,UNTRACKED /* !fw3 */

Chain zone_wan_dest_ACCEPT (2 references)
 pkts bytes target     prot opt in     out     source               destination                                              
   76  4475 ACCEPT     all  --  *      ds-wan  0.0.0.0/0            0.0.0.0/0                                                         /* !fw3 */
    0     0 ACCEPT     all  --  *      eth1.2  0.0.0.0/0            0.0.0.0/0                                                         /* !fw3 */

Chain zone_wan_dest_REJECT (1 references)
 pkts bytes target     prot opt in     out     source               destination                                              
    0     0 reject     all  --  *      ds-wan  0.0.0.0/0            0.0.0.0/0                                                         /* !fw3 */
    0     0 reject     all  --  *      eth1.2  0.0.0.0/0            0.0.0.0/0                                                         /* !fw3 */

Chain zone_wan_forward (2 references)
 pkts bytes target     prot opt in     out     source               destination                                              
   43  3022 forwarding_wan_rule  all  --  *      *       0.0.0.0/0            0.                                             0.0.0/0            /* !fw3: Custom wan forwarding rule chain */
    0     0 zone_lan_dest_ACCEPT  esp  --  *      *       0.0.0.0/0            0                                             .0.0.0/0            /* !fw3: Allow-IPSec-ESP */
    0     0 zone_lan_dest_ACCEPT  udp  --  *      *       0.0.0.0/0            0                                             .0.0.0/0            udp dpt:500 /* !fw3: Allow-ISAKMP */
    0     0 ACCEPT     all  --  *      *       0.0.0.0/0            0.0.0.0/0                                                         ctstate DNAT /* !fw3: Accept port forwards */
   43  3022 zone_wan_dest_REJECT  all  --  *      *       0.0.0.0/0            0                                             .0.0.0/0            /* !fw3 */

Chain zone_wan_input (2 references)
 pkts bytes target     prot opt in     out     source               destination                                              
   17  5884 input_wan_rule  all  --  *      *       0.0.0.0/0            0.0.0.0                                             /0            /* !fw3: Custom wan input rule chain */
    8  3112 ACCEPT     udp  --  *      *       0.0.0.0/0            0.0.0.0/0                                                         udp dpt:68 /* !fw3: Allow-DHCP-Renew */
    0     0 ACCEPT     icmp --  *      *       0.0.0.0/0            0.0.0.0/0                                                         icmptype 8 /* !fw3: Allow-Ping */
    0     0 ACCEPT     2    --  *      *       0.0.0.0/0            0.0.0.0/0                                                         /* !fw3: Allow-IGMP */
    0     0 ACCEPT     all  --  *      *       0.0.0.0/0            0.0.0.0/0                                                         ctstate DNAT /* !fw3: Accept port redirections */
    9  2772 zone_wan_src_REJECT  all  --  *      *       0.0.0.0/0            0.                                             0.0.0/0            /* !fw3 */

Chain zone_wan_output (2 references)
 pkts bytes target     prot opt in     out     source               destination                                              
   44  2823 output_wan_rule  all  --  *      *       0.0.0.0/0            0.0.0.                                             0/0            /* !fw3: Custom wan output rule chain */
   44  2823 zone_wan_dest_ACCEPT  all  --  *      *       0.0.0.0/0            0                                             .0.0.0/0            /* !fw3 */

Chain zone_wan_src_REJECT (1 references)
 pkts bytes target     prot opt in     out     source               destination                                              
    0     0 reject     all  --  ds-wan *       0.0.0.0/0            0.0.0.0/0                                                         /* !fw3 */
    9  2772 reject     all  --  eth1.2 *       0.0.0.0/0            0.0.0.0/0                                                         /* !fw3 */
[email protected]:~# iptables -t nat -L -vn
Chain PREROUTING (policy ACCEPT 162 packets, 29744 bytes)
 pkts bytes target     prot opt in     out     source               destination
  162 29744 prerouting_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom prerouting rule chain */
  130 26321 zone_lan_prerouting  all  --  br-lan *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */
   31  3034 zone_wan_prerouting  all  --  ds-wan *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */
    1   389 zone_wan_prerouting  all  --  eth1.2 *       0.0.0.0/0            0.0.0.0/0            /* !fw3 */

Chain INPUT (policy ACCEPT 35 packets, 3411 bytes)
 pkts bytes target     prot opt in     out     source               destination

Chain OUTPUT (policy ACCEPT 2171 packets, 163K bytes)
 pkts bytes target     prot opt in     out     source               destination

Chain POSTROUTING (policy ACCEPT 2143 packets, 161K bytes)
 pkts bytes target     prot opt in     out     source               destination
 2213  165K postrouting_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom postrouting rule chain */
   70  3867 ACCEPT     all  --  *      ds-wan  0.0.0.0/0            0.0.0.0/0            /* !fw3: ubus:wan[dslite] nat 0 */
    3   704 zone_lan_postrouting  all  --  *      br-lan  0.0.0.0/0            0.0.0.0/0            /* !fw3 */
    0     0 zone_wan_postrouting  all  --  *      ds-wan  0.0.0.0/0            0.0.0.0/0            /* !fw3 */
    0     0 zone_wan_postrouting  all  --  *      eth1.2  0.0.0.0/0            0.0.0.0/0            /* !fw3 */

Chain postrouting_lan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain postrouting_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain postrouting_wan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain prerouting_lan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain prerouting_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain prerouting_wan_rule (1 references)
 pkts bytes target     prot opt in     out     source               destination

Chain zone_lan_postrouting (1 references)
 pkts bytes target     prot opt in     out     source               destination
    3   704 postrouting_lan_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom lan postrouting rule chain */

Chain zone_lan_prerouting (1 references)
 pkts bytes target     prot opt in     out     source               destination
  130 26321 prerouting_lan_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom lan prerouting rule chain */

Chain zone_wan_postrouting (2 references)
 pkts bytes target     prot opt in     out     source               destination
    0     0 postrouting_wan_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom wan postrouting rule chain */

Chain zone_wan_prerouting (2 references)
 pkts bytes target     prot opt in     out     source               destination
   32  3423 prerouting_wan_rule  all  --  *      *       0.0.0.0/0            0.0.0.0/0            /* !fw3: Custom wan prerouting rule chain */
[email protected]:~# ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 532
    link/ether 60:38:e0:c5:45:b0 brd ff:ff:ff:ff:ff:ff
3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 532
    link/ether 62:38:e0:c5:45:b0 brd ff:ff:ff:ff:ff:ff
5: [email protected]: <NOARP> mtu 1452 qdisc noop state DOWN qlen 1000
    link/tunnel6 00:00:00:00:00:00:00:00:00:00:00:00:00:00:00:00 brd 00:00:00:00:00:00:00:00:00:00:00:00:00:00:00:00
6: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 60:38:e0:c5:45:b2 brd ff:ff:ff:ff:ff:ff
7: wlan1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 60:38:e0:c5:45:b1 brd ff:ff:ff:ff:ff:ff
8: mlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 60:38:e0:c5:45:b3 brd ff:ff:ff:ff:ff:ff
9: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 62:38:e0:c5:45:b0 brd ff:ff:ff:ff:ff:ff
10: [email protected]: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 62:38:e0:c5:45:b0 brd ff:ff:ff:ff:ff:ff
11: [email protected]: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 60:38:e0:c5:45:b0 brd ff:ff:ff:ff:ff:ff
12: [email protected]: <POINTOPOINT,NOARP,UP,LOWER_UP> mtu 1280 qdisc noqueue state UNKNOWN qlen 1000
    link/tunnel6 2a:02:xx:xx:xx:xx:00:0c:xx:6d:80:2d:8e:3b:5e:1f peer 2a:xx:xx:xx:xx:00:00:00:00:00:00:00:00:13:40:00
Was die switch config angeht hab ich erst mal verglichen, und tatsächlich ist das anders konfiguriert als bei 17.01.4:
CPU (eth0) Port 1 untagged Port 2 off
CPU (eth1) Port 1 off Port 2 untagged

Der Rest ist gleich. Habe das mal geändert, was keinen Effekt gebracht hat..
Technicolor TC4400, Linksys WRT3200ACM, 2play Comfort 120, Power Upload, Dual Stack :pcfreak:
Bild

Benutzeravatar
der-tim
Kabelexperte
Beiträge: 141
Registriert: 05.02.2018, 14:02

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von der-tim » 17.04.2018, 09:57

https://bugs.openwrt.org/index.php?do=d ... &pagenum=2

Das ist der Bugreport den ich gerade erstellt habe. Man kann ihn hochvoten damit die devs da schneller reingucken :super: Macht das ruhig mal alle :winken:
Technicolor TC4400, Linksys WRT3200ACM, 2play Comfort 120, Power Upload, Dual Stack :pcfreak:
Bild

Benutzeravatar
JPDribbler
Übergeordneter Verstärkerpunkt
Beiträge: 655
Registriert: 26.02.2009, 17:20

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von JPDribbler » 17.04.2018, 11:01

der-tim hat geschrieben:
17.04.2018, 09:57
https://bugs.openwrt.org/index.php?do=d ... &pagenum=2

Das ist der Bugreport den ich gerade erstellt habe. Man kann ihn hochvoten damit die devs da schneller reingucken :super: Macht das ruhig mal alle :winken:
Vielen Dank für deinen Einsatz. Ich hoffe, dass das gefixt wird, die alte LEDE Version ist ein Graus was WLAN betrifft beim WRT1900... Upvote ist raus.
Bug in Intels Puma-6-Chip
Bild

2Play 400 /40 - DS-Lite - DUAL STACK @ ARRIS CMTS mit TC4400-GEN Rev:3.6.0 FW:SR70.12.20 + WRT1900ACS v2 (LEDE SWRT SNAPSHOT r6796-56ae9f9b0b - Kernel 4.14.37)
cust-own_400000_40000_ds_sip_wifi-on.bin

Benutzeravatar
der-tim
Kabelexperte
Beiträge: 141
Registriert: 05.02.2018, 14:02

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von der-tim » 17.04.2018, 22:58

Kein Ding!
Eine Antwort haben wir schon mal :super:
Technicolor TC4400, Linksys WRT3200ACM, 2play Comfort 120, Power Upload, Dual Stack :pcfreak:
Bild

noctarius
Kabelexperte
Beiträge: 138
Registriert: 10.01.2016, 19:39

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von noctarius » 18.04.2018, 11:56

So heute ein wenig Zeit gehabt und ich habe ein erstes Script (momentan definitiv nicht "Production Ready") um einen DS-Lite Tunnel automatisch aufzubauen, die Route richtig zu setzen und auf entsprechende DHCPv6 Responses zu reagieren (in opnsense). Der AFTR kommt noch nicht aus der Response, da die Raw-Options in der aktuellen Version opnsense noch nicht integriert sind. Weiterhin musste ich ein PHP Script minimal patchen um mein neues Shellscript automatisch mit ausführen zu lassen, wenn ein DHCPv6 Response kommt.

Was leider noch nicht schön ist. Das Ganze muss jetzt noch im UI hinterlegbar sein (meine Idee ist es bei WAN-IPv4 einfach DS-Lite auszuwählen, ähnlich wie bei openwrt) und dass dann entsprechend der Gateway und das GIF-Interface auch in opnsense erscheinen. Derzeit zeigt opnsense die Dinger nach der Erstellung halt noch nicht an :-(

PS: Tunnel => Full Speed, ergo bleibe ich bei der Vermutung, dass DS-Lite Kunden ohne custom-xyz.bin, auf weiteren Tunneln gedrosselt sind (vermutlich anhand der MAC Adresse des lokalen Tunnel-Endpoints). Sobald man die custom bekommt, hat UM dann vermutlich keine echt MAC mehr die sie zuordnen können (oder wollen).
UM NRW - 3-Play 400 - DualStack - TC4400, VLAN, opnsense, Fritzbox 7390 (für Telefon :zwinker:) - arbeite weiter an dem opnsense DS-Lite Patch :D

Maurice
erfahrener Kabelkunde
Beiträge: 61
Registriert: 01.02.2018, 14:16
Wohnort: BW

Re: DS-Lite via Linux / BSD (bspw. OpenWRT oder pfSense)

Beitrag von Maurice » 18.04.2018, 12:59

Mal ein großes Lob, dass Du dich da so engagierst!
Fahre auch OPNsense, allerdings noch in umgekehrter Konstellation (IPv4 nativ, IPv6 via 6in4). Falls eines nicht allzu fernen Tages die große Zwangsumstellung kommt und man dann in der OPNsense einfach DS-Lite anknipsen kann gebe ich einen aus! :super:

(Leider ist die dhcpd6- und radvd-Konfiguration auch noch eine ganz schöne Baustelle (vor allem bei dynamischem Präfix), aber das ist ein ganz anderes Thema. Kann nur besser werden.)
BW - Arris CMTS - Cisco EPC3212 - OPNsense
generic_150000_10000_ipv4_ncs_wifi-on.bin

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste