Raspberry Pi als Webserver an der Fritz!Box 6490

In vielen Netzen von Unitymedia sind Internet und Telefonie bereits verfügbar.
Forumsregeln
  • Kunden aus Hessen und Nordrhein-Westfalen können über die Rufnummer 0221 / 466 191 00 Hilfe bei allen Problemen in Anspruch nehmen.
  • Kunden aus Baden-Württemberg können über die Rufnummer 0711 / 54 888 150 Hilfe bei allen Problemen in Anspruch nehmen.
johnripper
Glasfaserstrecke
Beiträge: 1286
Registriert: 06.02.2014, 19:29
Wohnort: Kabelbw-Land

Re: Raspberry Pi als Webserver an der Fritz!Box 6490

Beitrag von johnripper » 13.07.2016, 18:05

GoaSkin hat geschrieben:
rivella hat geschrieben:@GoaSkin
@johnripper
http://[fe80::8x:9xf:fex3:8x2]:80 habe ich schon probiert. Klappt nicht. Jetzt klappt aber auch nicht mehr der Aufruf über 192.168.178.28 :( Wahrscheinlich wegen der Umstellung auf IPv6.

:kratz:
Soweit, so korrekt. Die FE80-Adressen sind so genannte Link-Local Adressen, auf die man über Router hinweg überhaupt nicht und im selben Subnet nur eingeschränkt zugreifen kann. Von außen erreichbar sein sollte die globale IPv6-Adresse, die bei Unitymedia in der Regel mit 2a02:908: beginnt.
Ich bin davon ausgegangen, dass man die fe80 Adresse natürlich über einen Rechner im selben (Sub)Netz aufruft. Das ist das was ich zuerst probieren würde.
Da der Aufruf von 192.168.178.28 angeblich mit einen Rechner mal erfolgreich war, nahm ich an, dass offensichtlich ist, dass es sich um eine lokale Adresse handelt.

Ansonsten nochmal zur Klarstellung: Mit dem eigenen PC im selben (Sub)netz versuchen den Webserver bzw. dessen Inhalt über die fe80* Adresse zu erreichen. Erst wenn das solide funktioniert würde ich den Rest angehen (Firewall, Portforwading bei IPv4, Virtual Hosts usw).
Office & Internet 150 @ Fritz!Box 6490, OS 6.50

rivella
Kabelneuling
Beiträge: 17
Registriert: 22.01.2013, 21:18

Re: Raspberry Pi als Webserver an der Fritz!Box 6490

Beitrag von rivella » 15.07.2016, 12:30

Ich kriegs nicht hin, den RPi über die fe80* Adresse im lokalen Netz zu erreichen. Die 192.168.* Adresse läuft dagegen einwandfrei (ich habe in der nginx-Konfig noch zusätzlich "listen :80;" gesetzt).

Die RPi Konfiguration für IPv6 scheint auch zu stimmen. Ich habe auch keine Firewall auf dem RPi laufen. :wein:

Falls noch jemand eine Idee hat, dann her damit.

GoaSkin
Glasfaserstrecke
Beiträge: 1200
Registriert: 12.12.2009, 16:25

Re: Raspberry Pi als Webserver an der Fritz!Box 6490

Beitrag von GoaSkin » 15.07.2016, 13:16

Um eine FE80-Adresse im lokalen Subnet zu erreichen, ist es erforderlich, beim Aufruf den lokalen Interface-Namen mit anzugeben, über das die Adresse erreichbar ist.

Unter Linux: http://[fe80::8x:9xf:fex3:8x2]:80%eth0

Unter Windows ipconfig /all ausführen und die Nummer des geeigneten Interfaces ablesen, dann z.B.:

http://[fe80::8x:9xf:fex3:8x2]:80%2
Es gibt drei Fleischsorten: Beef, Chicken und Veggie. Von welchem Tier die kommen? Von garkeinem, sondern aus der Packung.

MartinDJR
Übergeordneter Verstärkerpunkt
Beiträge: 647
Registriert: 22.12.2015, 15:53

Re: Raspberry Pi als Webserver an der Fritz!Box 6490

Beitrag von MartinDJR » 15.07.2016, 13:24

rivella hat geschrieben:Ich kriegs nicht hin, den RPi über die fe80* Adresse im lokalen Netz zu erreichen. Die 192.168.* Adresse läuft dagegen einwandfrei
Du musst auch noch beachten, dass die fe80*-Adressen (link-lokal) eine noch kürzere Reichweite haben als die 192.168.*-Adressen:

Wenn du z.B. von einem WLAN-Rechner aus auf ein Gerät mit Ethernetkabel zugreifen willst (und umgekehrt), wird das bei 192.168.* funktionieren, bei fe80* hingegen nicht.
GoaSkin hat geschrieben: http://[fe80::8x:9xf:fex3:8x2]:80%eth0
http://[fe80::8x:9xf:fex3:8x2]:80%2
Meiner Meinung nach müsste das Interface noch in die Klammer:

http://[fe80::8x:9xf:fex3:8x2%2]:80

Einige Browser (z.B. sehr alte FireFox-Versionen) erlauben die Angabe eines Interfaces übrigens gar nicht, was dann zur Folge hat, dass fe80*-Adressen überhaupt nicht eingegeben werden können.

rivella
Kabelneuling
Beiträge: 17
Registriert: 22.01.2013, 21:18

Re: Raspberry Pi als Webserver an der Fritz!Box 6490

Beitrag von rivella » 15.07.2016, 13:55

@GoaSkin
Klappt leider nicht :(
Hier mal die /etc/network/interfaces

Code: Alles auswählen

auto lo
iface lo inet loopback

auto eth0

# dhcp configuration
iface eth0 inet dhcp
Setze ich in der letzten Zeile "inet6", bekomme ich gar keine Verbindung mehr. Derzeit klappt die Verbindung im Netzwerk mittels "ssh 192.168.178.28 ..." problemlos. Die Website (nginx) erreiche ich aber nur über http://192.168..., nicht aber über "http://[fe80::8x:9xf:fex3:8x2]:80%eth0" oder "http://[fe80::8x:9xf:fex3:8x2%eth0]:80"

tq1199
Glasfaserstrecke
Beiträge: 1816
Registriert: 07.02.2014, 09:05

Re: Raspberry Pi als Webserver an der Fritz!Box 6490

Beitrag von tq1199 » 15.07.2016, 14:07

rivella hat geschrieben: Hier mal die /etc/network/interfaces

Code: Alles auswählen

auto lo
iface lo inet loopback

auto eth0

# dhcp configuration
iface eth0 inet dhcp
Versuch mal mit raspbian-jessie und dem dhcpcd-daemon (d. h. die NICs nicht mit der interfaces-Datei konfigurieren) auf deinem PI, dann sollte das mit dem IPv6 auch funktionieren.

EDIT:

Wie ist auf deinem PI, z. Zt. die Ausgabe von:

Code: Alles auswählen

nc -6zv <IPv6-Adresse-der-FritzBox> 53
ping6 -c 3 -W 2 <IPv6-Adresse-der-FritzBox>
host -t AAAA $(hostname) 192.168.178.1
?
Office Internet & Phone 50, AVM FRITZ!Box 6360 Cable (kbw) - FRITZ!OS 06.52 - , an Arris-CMTS, zusätzlich eine feste (statische, nicht per DHCP) IPv4-Adresse für meinen Server, am Bridge-Anschluss (kein Bridge-Modus, FB6360-cable wird ohne feste IPv4-Adresse als Router verwendet.)
Konfigurationsdatei der FritzBox: b2b-staticip1_50000_5000_ipv4_sip_wifi-on.bin
NTP_Provider_Interface_Spec_Unitymedia

AVM - IPv6 technical note

johnripper
Glasfaserstrecke
Beiträge: 1286
Registriert: 06.02.2014, 19:29
Wohnort: Kabelbw-Land

Re: Raspberry Pi als Webserver an der Fritz!Box 6490

Beitrag von johnripper » 15.07.2016, 14:45

GoaSkin hat geschrieben:Um eine FE80-Adresse im lokalen Subnet zu erreichen, ist es erforderlich, beim Aufruf den lokalen Interface-Namen mit anzugeben, über das die Adresse erreichbar ist.

Unter Linux: http://[fe80::8x:9xf:fex3:8x2]:80%eth0

Unter Windows ipconfig /all ausführen und die Nummer des geeigneten Interfaces ablesen, dann z.B.:

http://[fe80::8x:9xf:fex3:8x2]:80%2
Also ich erreiche hier einen ISS auf einem Windows Server 2012 R2 ohne das Interface über IE und FF ohne Probleme. Mit dem Interface bekomme ich keine Antwort, ungültige Seite usw.

Das ganze funktioniert lokal (Bild ganz hinten) und auf einem Client im selben Netzwerk (Fenster im Vordergrund):

Siehe:
Bild

Sogar über einen anderen Port (hier 8530):
Bild
(Der Inhalt der Seite ist nicht relevant, es geht nur darum, dass sie ausgeliefert wird).
Office & Internet 150 @ Fritz!Box 6490, OS 6.50

rivella
Kabelneuling
Beiträge: 17
Registriert: 22.01.2013, 21:18

Re: Raspberry Pi als Webserver an der Fritz!Box 6490

Beitrag von rivella » 15.07.2016, 14:58

@tq1199

ping6 liefert

Code: Alles auswählen

--- ... ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 0.927/2.641/6.054/2.413 ms
Also alles gut.

"nc -6" liefert "nc: invalid option -- '6'" :)

Als DHCP-Server habe ich mal den ISC-DHCPD genommen mit der Konfiguration:

Code: Alles auswählen

authoritative;
default-lease-time 86400;
max-lease-time 86400;
subnet 192.168.178.0 netmask 255.255.255.0 {
   range 192.168.178.201 192.168.178.250;
   option routers 192.168.178.1;
   option domain-name-servers 192.168.178.1;
   option domain-name "local";
}

In der /etc/default/isc-dhcp-server habe ich

Code: Alles auswählen

INTERFACES="eth0"
gesetzt.

Resultat: Verbindung via ssh und http über 192.168.. läuft, Verbindung über fe80::... in allen Varianten läuft nicht.

Und nochwas:

Code: Alles auswählen

# host -t AAAA $(hostname) 192.168.178.1
Using domain server:
Name: 192.168.178.1
Address: 192.168.178.1#53
Aliases: 

bananapi.fritz.box has IPv6 address 2a02:908:df28:3b80:8x:9xf:fex3:8x2

tq1199
Glasfaserstrecke
Beiträge: 1816
Registriert: 07.02.2014, 09:05

Re: Raspberry Pi als Webserver an der Fritz!Box 6490

Beitrag von tq1199 » 15.07.2016, 15:08

rivella hat geschrieben:@tq1199
"nc -6" liefert "nc: invalid option -- '6'" :)

bananapi.fritz.box has IPv6 address 2a02:908:df28:3b80:8x:9xf:fex3:8x2
[/code]
Hast Du den BananaPI, mit welchem Betriebssystem? Denn nc in raspbian-jessie kennt die Option "-6":

Code: Alles auswählen

 -6      Forces nc to use IPv6 addresses only.
Office Internet & Phone 50, AVM FRITZ!Box 6360 Cable (kbw) - FRITZ!OS 06.52 - , an Arris-CMTS, zusätzlich eine feste (statische, nicht per DHCP) IPv4-Adresse für meinen Server, am Bridge-Anschluss (kein Bridge-Modus, FB6360-cable wird ohne feste IPv4-Adresse als Router verwendet.)
Konfigurationsdatei der FritzBox: b2b-staticip1_50000_5000_ipv4_sip_wifi-on.bin
NTP_Provider_Interface_Spec_Unitymedia

AVM - IPv6 technical note

johnripper
Glasfaserstrecke
Beiträge: 1286
Registriert: 06.02.2014, 19:29
Wohnort: Kabelbw-Land

Re: Raspberry Pi als Webserver an der Fritz!Box 6490

Beitrag von johnripper » 15.07.2016, 15:30

rivella hat geschrieben: Resultat: Verbindung via ssh und http über 192.168.. läuft, Verbindung über fe80::... in allen Varianten läuft nicht.
Geht denn eine SSH Verbindung via IPv6?

Ich tippe auf eine fehlerhafte Konfig des Webservers. Wenn ich es richtig verstanden habe, dann läuft Nginx. Hast du mal einen Apache Server probiert?
Office & Internet 150 @ Fritz!Box 6490, OS 6.50

rivella
Kabelneuling
Beiträge: 17
Registriert: 22.01.2013, 21:18

Re: Raspberry Pi als Webserver an der Fritz!Box 6490

Beitrag von rivella » 15.07.2016, 16:36

@tq1199

Code: Alles auswählen

# uname -a                                                                                                        :(
Linux bananapi 3.4.112-bananian #6 SMP PREEMPT Fri May 13 18:21:01 UTC 2016 armv7l GNU/Linux

# cat /etc/os-release                                                                                             :(
PRETTY_NAME="Debian GNU/Linux 8 (jessie)"
NAME="Debian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=debian
HOME_URL="http://www.debian.org/"
SUPPORT_URL="http://www.debian.org/support"
BUG_REPORT_URL="https://bugs.debian.org/"
@johnripper
SSH via IPv6 klappt nicht :( nginx ist für IPv6 konfiguriert:

Code: Alles auswählen

nginx -V                                                                                                          :(
nginx version: nginx/1.6.2
TLS SNI support enabled
configure arguments: ... --with-ipv6 ...
Weshalb ich _lokal_ nicht auf den Webserver und via SSH zugreifen kann, ist mir rätselhaft.

johnripper
Glasfaserstrecke
Beiträge: 1286
Registriert: 06.02.2014, 19:29
Wohnort: Kabelbw-Land

Re: Raspberry Pi als Webserver an der Fritz!Box 6490

Beitrag von johnripper » 15.07.2016, 17:50

rivella hat geschrieben: nginx ist für IPv6 konfiguriert:(
(...)
Weshalb ich _lokal_ nicht auf den Webserver und via SSH zugreifen kann, ist mir rätselhaft.
So war das meinerseits nicht gemeint. Ich wollte nur sagen, dass ich den Fehler in Richtung Webserver Config gesucht hätte. Da bin ich aber ganz ehrlich kein Experte, das können andere viel besser. Da aber SSH auch nicht weiß ich jetzt auch nicht mehr.

Ich würde aber nicht sehen, dass es ein Problem mit der Fritzbox oder ähnliches ist. Soll nicht heißen, dass du dich hier nicht gerne weiter beraten lassen kannst, aber vielleicht versuchst du es trotzdem eher mal in einem Raspberry Forum. Ich bin auf jeden Fall raus ..sorry :/
Office & Internet 150 @ Fritz!Box 6490, OS 6.50

rivella
Kabelneuling
Beiträge: 17
Registriert: 22.01.2013, 21:18

Re: Raspberry Pi als Webserver an der Fritz!Box 6490

Beitrag von rivella » 15.07.2016, 18:23

Vielen Dank für eure Hilfe und Geduld. Falls ich eine Lösung gefunden habe, poste ich sie hier.

Antworten

Wer ist online?

Mitglieder in diesem Forum: Leseratte10, sch4kal, Torsten1973 und 7 Gäste