IPv6-Nutzung geschützt durch privaten Router überhaupt machb

In vielen Netzen von Unitymedia sind Internet und Telefonie bereits verfügbar.
Forumsregeln
  • Kunden aus Hessen und Nordrhein-Westfalen können über die Rufnummer 0221 / 466 191 00 Hilfe bei allen Problemen in Anspruch nehmen.
  • Kunden aus Baden-Württemberg können über die Rufnummer 0711 / 54 888 150 Hilfe bei allen Problemen in Anspruch nehmen.
Ulimit
Kabelneuling
Beiträge: 24
Registriert: 31.05.2015, 11:22

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von Ulimit » 02.06.2015, 00:41

Wow, SpaceRat, vielen Dank schonmal! Muß ich allerdings erstmal etwas sacken lassen. Habe jetzt schonmal den neuesten Snapshot von OpenWrt Chaos Calmer auf meinen WR1043NDv1 gemacht und dnsmasq-full (statt default dnsmasq) installiert. Ich hatte zwar die Tage auch schonmal einen Snapshot vom 25. Mai drauf, aber war damit auch gescheitert, wie mit den normalen releases. Eine potentielle Lösung steckt wohl eher in den Parameterwüsten ...

LG

Ulimit
Kabelneuling
Beiträge: 24
Registriert: 31.05.2015, 11:22

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von Ulimit » 02.06.2015, 22:48

Angelehnt an Deine Konfigs, SpaceRat, habe ich mich jetzt durchgewurschtelt und nun ebenfalls ein funktionierendes Setup!
Hinter dem TC7200 habe ich nun einen WR1043NDv1 mit OpenWrt Chaos Calmer 15.05-rc1 (r45695) und dnsmasq-full. IPv4 und IPv6 "Schutz" auf dem TC7200 ist deaktiviert.

Da ich leichte Abwandlungen habe, hier meine essentiellen Konfigs:

Code: Alles auswählen

 /etc/config/network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd8b:5571:fed8::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '64'
        option delegate '0'

config interface 'wan'
        option ifname 'eth0.2'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'static'
        option netmask '255.255.255.0'
        option gateway '192.168.0.1'
        option dns '8.8.8.8 8.8.4.4'
        option ipaddr '192.168.0.10'

config interface 'wan6'
        option ifname 'eth0.2'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'dhcpv6'
        option peerdns '0'
        option dns '2001:4860:4860::8888 2001:4860:4860::8844'
        option reqprefix 'no'
        option reqaddress 'none'

config switch                       
        option name 'switch0'       
        option reset '1'                                      
        option enable_vlan '1'
                                    
config switch_vlan                                            
        option device 'switch0'
        option vlan '1'         
        option ports '1 2 3 4 5t'                             
                               
config switch_vlan              
        option device 'switch0'  
        option vlan '2'        
        option ports '0 5t'
-----------------------------------------

/etc/config/dhcp:

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option localise_queries '1'
        option rebind_protection '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option authoritative '1'
        option rebind_localhost '1'

config dhcp 'lan'
        option interface 'lan'
        option ra 'relay'
        option dhcpv6 'relay'
        option ndp 'relay'
        option start '100'
        option limit '150'
        option leasetime '12h'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

config dhcp 'wan6'
        option dhcpv6 'relay'
        option ra 'relay'
        option ndp 'relay'
        option master '1'
        option interface 'wan'
        option ignore '1'
        option ra_management '1'

---------------------------------------
Das Endergebnis von dem ganzen Aufriss sieht nun so aus, daß ich jetzt WAN- und LAN-seitig den gleichen globalen /64 Prefix auf dem OpenWrt-Router und auf dem dahinter angeschlossenen Test-PC habe. Will ich per IPv6 aus dem Internet auf den PC zugreifen, muß ich auf dem OpenWrt eine zusätzliche Firewall-Regel anlegen, die das zulässt. Ich habe das exemplarisch für SSH einmal gemacht und das hat funktioniert.

Ein paar der Abwandlungen sind:
Mein TC7200 hat LAN-seitig 192.168.0.1/24, daher habe ich meine statische Konfig auf dem OpenWrt entsprechend gewählt. -- Mit reqaddress 'none' statt 'try' bekomme ich ein /64 statt eines /128 vom TC7200.

Wichtige Knackpunkte, um die Routerkonfig halbwegs zu verstehen, sind aus meiner (beschränkten) Sicht folgende: Nicht nur auf der LAN-Seite ist DHCPv6 relay mode nötig ( wie ich zuerst dachte), sondern zusätzlich auch auf seiner WAN-Seite. Die verschiedenen Einstelloptionen in den Textfiles und ihre Repräsentanz in der GUI (luci) sind ziemlich verwirrend. Manche Deiner Optionen, SpaceRat, konnte man über die GUI glaube ich gar nicht erreichen. -- In der default-config von dnsmaq-full fehlten Einträge zum odhcpd, welche in der Konfig des "normalen" dnsmasq noch vorhanden waren. -- In der GUI tauchen die deaktivierten DHCPv4 - und aktivierten DHCPv6-Optionen unter 'Interfaces WAN' statt WAN6 auf. Alles wenig intuitiv und verwirrend, aber mit Anstrengung noch halbwegs nachzuvollziehen. Allerdings sind diese relay-modes wohl auch sehr ungebräuchlich, da ist die usability von luci zu verschmerzen.

Grundlegend scheint die Thread-Frage damit erstmal beantwortet zu sein.

Weiteres lässt sich irgendwann mal klären, wie eventuell sporadisch wechselnde Prefixe oder die Entfernung der Google-Server aus obigen Konfigs (falls man das vorzieht).

LG

PS: Diese schrägen /62 tauchen auf dem Client-PC mit obigen Konfigs nun auch nicht mehr auf. Ich vermute mal, das sind diese unerwünscht delegierten Prefixe, von denen Du schriebst.

Ulimit
Kabelneuling
Beiträge: 24
Registriert: 31.05.2015, 11:22

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von Ulimit » 04.06.2015, 19:33

Hello again,

ich habe nochmal ein wenig geschaut, welche Freiheitsgrade man in Richtung Hardware und Software mit dem Relay-Setup noch hat. Dazu habe ich mir jetzt noch einen TP-Link WR1043NDv2 geliehen. Dieser ist das Nachfolgemodell von v1 und hat neben dem schwarzblauen (statt weißen) Gehäuse nun zwei echte Ethernet-Interfaces (statt einem einzigen, welches nur virtuell durch zwei VLANs geteilt ist).

Installiert habe ich darauf diesmal den aktuellen Release Candidate (rc1) von OpenWrt Chaos Calmer, es muß also nicht unbedingt die bleeding-edge Entwicklerversion sein, wie beim letzten Mal. Auch muss man nicht zwingend das Paket dnsmasq-full installieren, es reicht bei mir für die Relay-Funktionalität auch die etwas abgespeckte Paketvariante dnsmasq-dhcpv6.

Minimal "abgeschliffen" habe ich noch die dhcp config, da folgende Option der default ist und daher nicht explizit eingetragen sein muß:

Code: Alles auswählen

option ra_management '1'
(natürlich macht das bewusste Eintragen aber schon Sinn, wenn man die absolute Kontrolle will)

Die relevanten Konfigs für network und dhcp des neuen Router-Modells WR1043NDv2 sehen bei mir jetzt so aus:

Code: Alles auswählen

etc/config/network:
 
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd3b:25c9:2d1c::/48'

config interface 'lan'
        option ifname 'eth1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '64'
        option delegate '0'

config interface 'wan'
        option ifname 'eth0'
        option _orig_ifname 'eth0'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.0.11'
        option netmask '255.255.255.0'
        option gateway '192.168.0.1'
        option dns '8.8.8.8 8.8.4.4'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'
        option reqaddress 'none'
        option reqprefix 'no'
        option peerdns '0'
        option dns '2001:4860:4860::8888 2001:4860:4860::8844'
[...]
---------------------------------------

etc/config/dhcp:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd3b:25c9:2d1c::/48'

config interface 'lan'
        option ifname 'eth1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '64'
        option delegate '0'

config interface 'wan'
        option ifname 'eth0'
        option _orig_ifname 'eth0'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.0.11'
        option netmask '255.255.255.0'
        option gateway '192.168.0.1'
        option dns '8.8.8.8 8.8.4.4'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'
        option reqaddress 'none'
        option reqprefix 'no'
        option peerdns '0'
        option dns '2001:4860:4860::8888 2001:4860:4860::8844'

config dhcp 'wan6'
        option interface 'wan'
        option ignore '1'     
        option ra 'relay'
        option dhcpv6 'relay'
        option ndp 'relay'   
        option master '1'
---------------------------------------------
Der vom TC7200 übergebene /64 Prefix ist übrigens seit meinem letzten Beitrag vor 2 Tagen noch der gleiche geblieben. Gibt es Erfahrungswerte, nach welcher Zeitspanne der sich ändert? Oder kann es einem "passieren", daß man einen konstanten IPv6-Prefix von Unitymedia bekommt?

LG

PS: @SpaceRat, Du hattest noch eine Option "list rebind_domain 'lan'" eingetragen -- ist das nur eine individuelle Geschichte in Deinem privaten Netzwerk oder steckt da mehr dahinter?

Benutzeravatar
SpaceRat
Glasfaserstrecke
Beiträge: 2467
Registriert: 08.05.2010, 01:30
Wohnort: Kreis Aachen
Kontaktdaten:

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von SpaceRat » 05.06.2015, 20:20

Ulimit hat geschrieben:Der vom TC7200 übergebene /64 Prefix ist übrigens seit meinem letzten Beitrag vor 2 Tagen noch der gleiche geblieben. Gibt es Erfahrungswerte, nach welcher Zeitspanne der sich ändert? Oder kann es einem "passieren", daß man einen konstanten IPv6-Prefix von Unitymedia bekommt?
Es gibt bestimmt Erfahrungswerte, Du wirst ja auch welche machen :)
Konstant ist es nicht, aber ich glaube es hält schon eine ganze Weile.

Die Änderungen sind auch nicht sofort zu erkennen, da minimal.
Nach dem bißchen Erfahrung daß ich mit IPv6-Adressvergabe bei UM habe würde ich sagen: Dein /56, /57 oder /58 rotiert langsam durch ein übergeordnetes /40 oder kleiner.
Ulimit hat geschrieben:PS: @SpaceRat, Du hattest noch eine Option "list rebind_domain 'lan'" eingetragen -- ist das nur eine individuelle Geschichte in Deinem privaten Netzwerk oder steckt da mehr dahinter?
Eine Rebind-Attacke ist das Versauen eines DNS-Servers mit lokalen IPs als Rückgabewert, d.h. für den externen Server Z würde eine lokale IP zurückgeliefert.
Das kann man dann per Cross-Site-Scripting u.ä. ausnutzen, damit ein Client in Deinem LAN einem externen Server X Daten von einem LAN-internen Server Y zuspielt, während der Client meint, auf besagten externen Server Z zuzugreifen.

Das wird verhindert, indem der DNS-Server/-Proxy im LAN keine internen IPs an Clients zurückmeldet.
Ich bin mir jetzt nicht ganz sicher ob dnsmasq das für seine LAN-Domäne (In dem Beispiel "lan") automatisch ausläßt (Da sind die internen IPs ja gewünscht) oder nicht. Daher der Eintrag des lokalen LANs "lan" in die Liste der rebind domains.
"lan" ist ja bei OpenWrt die Voreinstellung für das, was bei der Fritz!Box "box" bzw. "fritz.box" ist.

Was da übrigens auch noch mit rein muß sind sämtliche DynDNS-Hostnames, die Du so nutzt!

Beispiel:
Du legst einen DynDNS-Host www.ulimit.mooo.com für einen Web-Server in Deinem LAN an und aktualisierst diesen mit dessen aktueller IPv6, beim aktuellen Präfix 2001:db8:dead:beef::/64 z.B. 2001:db8:dead:beef:21:09ff:fe03:1234.
Wenn Du nun diesen Hostname www.ulimit.mooo.com auch aus Deinem LAN heraus aufrufen willst - das ist ja das Schöne an IPv6, daß es keine unterschiedlichen Adressen intern/extern mehr gibt, also alle Hosts weltweit und damit auch im eigenen LAN gültig sind - dann wird dnsmasq die zurückgemeldete IPv6 2001:db8:dead:beef:21:09ff:fe03:1234 je nach Einstellung ebenfalls als Rebind-Angriff werden, da sie im eigenen LAN liegt.
Receiver/TV:
  • Vu+ Duo² 4xS2+2xC / OpenATV 6.1@Samsung 50" Plasma
  • AX Quadbox HD2400 2xS2+2xC / OpenATV 6.1@Samsung 32" TFT
  • 2xVu+ Solo² / OpenATV 6.1
  • DVBSky S2-Twin PCIe@SyncMaster T240HD (PC)
  • TechniSat SkyStar HD2@17" (2.PC)
Pay-TV: Schwarzfunk, Redlight Elite Superchic, SCT 10, HD-, Sky
Fon: VF Komfort-Classic (ISDN), 2xFritz!Fon C4+Siedle DoorCom Analog@F!B 7390
Internet: UM 1play 100 / Cisco EPC3212+Linksys WRT1900ACS / IPv4 (UM) + IPv6 (HE)
Bild

Ulimit
Kabelneuling
Beiträge: 24
Registriert: 31.05.2015, 11:22

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von Ulimit » 05.06.2015, 23:04

SpaceRat hat geschrieben: Es gibt bestimmt Erfahrungswerte, Du wirst ja auch welche machen :)
Yep, ich kriege zufällig gerade einen neuen rein :) : mindestens 4 Tage ist das /64 jetzt unverändert. Was mich anfangs irritiert hatte, war das delegierte /62, aber dieser Prefix ist ja jetzt weg.
SpaceRat hat geschrieben: Konstant ist es nicht, aber ich glaube es hält schon eine ganze Weile.
Wer bietet mehr? ;)
SpaceRat hat geschrieben: Eine Rebind-Attacke ist das Versauen eines DNS-Servers mit lokalen IPs als Rückgabewert, d.h. für den externen Server Z würde eine lokale IP zurückgeliefert.
Das kann man dann per Cross-Site-Scripting u.ä. ausnutzen, damit ein Client in Deinem LAN einem externen Server X Daten von einem LAN-internen Server Y zuspielt, während der Client meint, auf besagten externen Server Z zuzugreifen.

Das wird verhindert, indem der DNS-Server/-Proxy im LAN keine internen IPs an Clients zurückmeldet.
Ich bin mir jetzt nicht ganz sicher ob dnsmasq das für seine LAN-Domäne (In dem Beispiel "lan") automatisch ausläßt (Da sind die internen IPs ja gewünscht) oder nicht. Daher der Eintrag des lokalen LANs "lan" in die Liste der rebind domains.
"lan" ist ja bei OpenWrt die Voreinstellung für das, was bei der Fritz!Box "box" bzw. "fritz.box" ist.

Was da übrigens auch noch mit rein muß sind sämtliche DynDNS-Hostnames, die Du so nutzt!

Beispiel:
Du legst einen DynDNS-Host http://www.ulimit.mooo.com für einen Web-Server in Deinem LAN an und aktualisierst diesen mit dessen aktueller IPv6, beim aktuellen Präfix 2001:db8:dead:beef::/64 z.B. 2001:db8:dead:beef:21:09ff:fe03:1234.
Wenn Du nun diesen Hostname http://www.ulimit.mooo.com auch aus Deinem LAN heraus aufrufen willst - das ist ja das Schöne an IPv6, daß es keine unterschiedlichen Adressen intern/extern mehr gibt, also alle Hosts weltweit und damit auch im eigenen LAN gültig sind - dann wird dnsmasq die zurückgemeldete IPv6 2001:db8:dead:beef:21:09ff:fe03:1234 je nach Einstellung ebenfalls als Rebind-Angriff werden, da sie im eigenen LAN liegt.
Sehr gute Erklärungen, vielen Dank, SpaceRat! In der GUI nennt sich die Option 'Domain whitelist' (hab's gerade erst gefunden) und ist kommentiert mit "List of domains to allow RFC1918 responses for". Da die Option per default leer ist, werden erstmal generell keine domains aufgelöst, wenn die gelieferte Adresse aus RFC1918 stammt. Demnach beträfe die Option eigentlich nur die IPv4-Adressen aus:
  • 10.0.0.0/8
    172.16.0.0/12
    192.168.0.0/16
... und keine IPv6-Adressen. Ich denke, ich werde das jetzt erstmal so lassen, und keine domain dort "whitelisten" (auch nicht 'lan'). Soltte ich deswegen dann irgendwann auf Probleme stossen, werde ich mich an Deine weisen Worte erinnern (hoffentlich ;) ) und entsprechend handeln.

LG

Benutzeravatar
SpaceRat
Glasfaserstrecke
Beiträge: 2467
Registriert: 08.05.2010, 01:30
Wohnort: Kreis Aachen
Kontaktdaten:

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von SpaceRat » 05.06.2015, 23:39

Ulimit hat geschrieben:Sehr gute Erklärungen, vielen Dank, SpaceRat! In der GUI nennt sich die Option 'Domain whitelist' (hab's gerade erst gefunden) und ist kommentiert mit "List of domains to allow RFC1918 responses for". Da die Option per default leer ist, werden erstmal generell keine domains aufgelöst, wenn die gelieferte Adresse aus RFC1918 stammt. Demnach beträfe die Option eigentlich nur die IPv4-Adressen aus:
Wenn das Wörtchen "wenn" nicht wäre ... oder in diesem Fall das Wörtchen "eigentlich".

Zumindest die Fritz!Box dehnt den Rebind-Schutz auch auf "IPv6-Adressen die aus dem eigenen LAN stammen" aus.

Und vom Prinzip her hat AVM damit auch Recht:
Angenommen Du hast einen Xampp-Server auf ::affe (Ich mach's mal mit möglichst kurzen Addis, wird mir zu lästig sonst), der auch nur aus dem LAN erreichbar sein soll, also keine Firewall-Regel kriegt. Du hast sogar den Server so abgesichert, daß er nur Anfragen aus dem LAN beantwortet ...

Nun surfst Du aber auf die Seite von jemandem der etwas von diesem Server wissen will, sagen wir auf www.seineseite.de.
Dann kann er dafür sorgen, daß Dein Webbrowser
- erst Deinen Xampp-Server befragt (Darf er ja, er - also der Rechner auf dem Dein Browser läuft - ist ja in Deinem LAN)
und
- die Daten dann per POST an den Web-Server sendet, den Du gerade besuchst,
nur indem er dafür sorgt, daß z.B. images.seineseite.de auf die IPv6 Deines Xampp-Servers aufgelöst wird.

Die Rebind-Problematik besteht also durchaus, auch wenn das Beispiel natürlich etwas konstruiert ist, denn wer sollte einen Web-Server aufsetzen, nur um Deinen Xampp-Server zu befragen, wieso solltest Du ausgerechnet seinen Server besuchen und woher weiß er die IPv6 Deines Xampp-Servers?

Wir können es aber auch deutlich weniger abwegig machen:
Angenommen Du hast einen Enigma2-Receiver, suchst Hilfe beim Einrichten für IPv6 im digital-eliteboard und postest - trottelig wie Du bist - irgendwo die IPv6 Deines Enigma2-Receivers, damit wäre der Punkt woher man die IPv6 hat schonmal geklärt.
Der User "HilfreicherDieb" erklärt Dir dieses jenes und welches und rät Dir, doch mal auf der Seite www.testcam.de irgendeinen Test zur Eingrenzung Deines Problems zu machen.
Irgendwo auf seiner Seite steckt ein Script, welches folgende Adresse nachladen will:

Code: Alles auswählen

http://test1.testcam.de/file?file=/etc/tuxbox/config/oscam/oscam.server
Kenner sehen gleich was er da vorhat, nämlich die Datei mit den CS-Servern von einer E2-Box herunterzuladen, augenscheinlich zwar nicht von Deiner sondern von der Box mit der Adresse test1.testcam.de ...
... aber was passiert wohl, wenn der DNS-Eintrag dafür auf die IPv6 zeigt, die Du vorher trottelig ins Forum gepackt hast?
Richtig, dann lädt Dein Browser eben diese Datei herunter. Ein weiteres Script auf www.testcam.de sorgt dann dafür, daß Du die Datei postwendend dorthin hochlädst ...

Das ist nicht ganz so trivial, aber offensichtlich ist die Menschheit so blöde, daß inzwischen ja sogar Spam-Mails verschickt werden, in denen sich unverhohlen ein Link mit dem Titel "Download Virus" befindet ...

Ergo:
Es macht schon Sinn, den Rebind-Schutz so zu interpretieren, daß auch das lokale IPv6-Subnetz davon erfaßt wird.

Ulimit hat geschrieben:keine domain dort "whitelisten" (auch nicht 'lan').
Das hingegen ist eigentlich schon sinnvoll (Wenn nicht lan oder was auch immer Du für Dein LAN eingestellt hast automatisch freigegeben werden).

Man will ja eigentlich schon, daß man im LAN nicht mit IPs hantieren muß, um auf Gerät X zuzugreifen.
Wenn ich auf meinen Receiver zugreife, dann soll der schon unter

Code: Alles auswählen

http://e2box/
oder wie auch immer er wirklich heißt im LAN erreichbar sein, da jedes Mal 192.168.99.5 eingeben zu müssen wäre ja irgendwie dämlich.
Receiver/TV:
  • Vu+ Duo² 4xS2+2xC / OpenATV 6.1@Samsung 50" Plasma
  • AX Quadbox HD2400 2xS2+2xC / OpenATV 6.1@Samsung 32" TFT
  • 2xVu+ Solo² / OpenATV 6.1
  • DVBSky S2-Twin PCIe@SyncMaster T240HD (PC)
  • TechniSat SkyStar HD2@17" (2.PC)
Pay-TV: Schwarzfunk, Redlight Elite Superchic, SCT 10, HD-, Sky
Fon: VF Komfort-Classic (ISDN), 2xFritz!Fon C4+Siedle DoorCom Analog@F!B 7390
Internet: UM 1play 100 / Cisco EPC3212+Linksys WRT1900ACS / IPv4 (UM) + IPv6 (HE)
Bild

Ulimit
Kabelneuling
Beiträge: 24
Registriert: 31.05.2015, 11:22

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von Ulimit » 06.06.2015, 10:48

SpaceRat hat geschrieben: Zumindest die Fritz!Box dehnt den Rebind-Schutz auch auf "IPv6-Adressen die aus dem eigenen LAN stammen" aus.
Um sich Gewissheit zu verschaffen, wird wohl ein echter Test am besten sein. Ich habe Zugriff auf einen externen Nameserver im Internet und könnte dort mal testweise einen Address-Record eintragen, der auf eine IPv6-Adresse in meinem Unitymedia-Netz zeigt. Wenn ich dann von meinem "geschützten" LAN aus auf einen gleichnamigen Webserver in meinem lokalen Netzwerk zugreifen will, dürfte ich für diesen Webserver ja keine Namensauflösung bekommen, wenn eine Rebind-Protection greift.

Das wäre allerdings auch irgendwie blöd, wenn ich meinen eigenen Webserver zuhause nicht genauso ansprechen könnte, wie jeder andere User es vom Internet aus könnte. - Sollte der Webserver jedoch lokal Webseiten über diese aufgelöste IPv6-Adresse ausliefern, dann bestünde eine Anfälligkeit für Rebind-Attacken (wenn ich Dich richtig verstehe).

Mein Test wird allerdings ein oder zwei Tage auf sich warten lassen, da ich eine sehr lange Time-To-Live auf dem DNS habe (bis also Änderungen aktualisiert sind).
SpaceRat hat geschrieben: (Wenn nicht lan oder was auch immer Du für Dein LAN eingestellt hast automatisch freigegeben werden).
Die lokale Domain muß man IMHO nicht nochmal extra "whitelisten". Trage ich z.B. den hostnamen 'alice' mit einer Adresse 192.168.1.50 (RFC1918) in die hosts auf dem OpenWrt-Router ein, kann ich den Namen alice oder auch alice.lan im LAN ohne Probleme auflösen. Maßgeblich sind dafür offenbar die zwei GUI-Optionen:
  • Local server /lan/
    Local domain lan

Ulimit
Kabelneuling
Beiträge: 24
Registriert: 31.05.2015, 11:22

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von Ulimit » 07.06.2015, 22:37

Ulimit hat geschrieben: Um sich Gewissheit zu verschaffen, wird wohl ein echter Test am besten sein.
Der Test zeigt, daß der lokale IPv6-Webserver seine Namesauflösung über den OpenWrt-Router aus dem Internet erhält. Der lokale Browser greift dann über die zurückgemeldete, globale IPv6-Adresse auf den lokalen Webserver zu.

Fruchtzwerg
Kabelexperte
Beiträge: 112
Registriert: 22.06.2015, 14:08

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von Fruchtzwerg » 22.06.2015, 22:43

Ulimit hat geschrieben: Es gibt zur näheren Erläuterung auch nicht einen einzelnen Modus "IPv6-Relay", sondern es sind midestens drei Optionen, die sich in diesem Zusammenhang einzeln einstellen lassen:

Router Advertisement-Service: relay mode
DHCPv6-Service: relay mode
NDP-Proxy: relay mode
Ich klinke mich hier mal ein, denn ich habe exakt das selbe Problem: ipv6/ds-lite und ein Heimserver, der von außen erreicht werden soll. Zwischen der FB6490 und dem Server hängt ein OpenWRT, der verschiedene Netze bei mir per VLAN trennt. Der WAN des OpenWRT ist dann die FB, und beide Router sind mit einer Funkbrücke verbunden, wobei der OpenWRT als Client im Netz der FB angemeldet ist.

Die OpenWRT-Version ist bei mir 14.07. Wo finde ich die erste der oben genannten 3 Optionen im Menü?

Ich muss gestehen, daß ich mit ip6 noch nicht so viel Erfahrung habe, wie ich gerne hätte. :( Darum wäre ich sehr dankbar, wenn jemand, der sich damit auskennt, eine Anleitung "für dummies" schreiben oder darauf verlinken würde, am besten mit Bildern, wie man das mit der Luci-Oberfläche hinbekommt, oder die entsprechenden Dateien aus /etc/config/ zusammenschreibt, und mit reichlich Kommentaren versieht, so daß man es auch als weniger geübter Netzwerker nachvollziehen kann.

Wichtig wären auch Dinge wie: wo kriege ich diese Netzwerk-ID her, die die FB beim Eintrag der Weiterleitung gerne hätte?

Ulimit
Kabelneuling
Beiträge: 24
Registriert: 31.05.2015, 11:22

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von Ulimit » 23.06.2015, 22:07

Fruchtzwerg hat geschrieben: Die OpenWRT-Version ist bei mir 14.07. Wo finde ich die erste der oben genannten 3 Optionen im Menü?
Zunächst würde ich von 14.07 auf Chaos Calmer (z.B.15.05-rc1) upgraden, gerade die IPv6-Optionen sind dort fortgeschrittener. (Einfach das OpenWrt-Image mit "sysupgrade" im Namen für Dein Router-Modell besorgen und in der GUI/luci drüberbügeln).

Die relay-Optionen beziehen sich auf DHCPv6 und müssen, wie ich schon schrieb, sowohl auf dem äußeren sowie dem inneren Interface des Routers gesetzt werden. Also unter DHCP-Server von LAN und DHCP-Server von WAN/WAN6.
Fruchtzwerg hat geschrieben: Ich muss gestehen, daß ich mit ip6 noch nicht so viel Erfahrung habe, wie ich gerne hätte. :( Darum wäre ich sehr dankbar, wenn jemand, der sich damit auskennt, eine Anleitung "für dummies" schreiben oder darauf verlinken würde, am besten mit Bildern, wie man das mit der Luci-Oberfläche hinbekommt, oder die entsprechenden Dateien aus /etc/config/ zusammenschreibt, und mit reichlich Kommentaren versieht, so daß man es auch als weniger geübter Netzwerker nachvollziehen kann.
... dann würde ich Dir empfehlen, zunächst die von mir bereits erwähnten Pakete in OpenWrt nachzuinstallieren und dann einfach die /etc/config/dhcp und /etc/config/network direkt zu übernehmen, wie sie hier im Thread bereits stehen .... also direkt zu kopieren oder ggf. noch zu editieren, wenn Deine physikalischen Interfaces anders heißen sollten. Von dort aus würde Dir sicher Vieles klarer, weil Du dann sehen würdest, wo die ganzen Optionen in der GUI abgebildet sind. Aber free lunch zu erwarten, dürfte bei der Komplexität des Themas nicht funktionieren (zumindest diesen Thread wirst Du leider vollständig lesen müssen).

Ich muß aber Deine Hoffnungen noch mehr dämpfen. Mit dem Setup kann man zwar geschützt durch seine eigene Firewall IPv6 in- und outgoing betreiben, aber nach einigen Tagen kann sich schonmal die IPv6-Adresse des UM-Zwangsrouters ändern, und dann müsste man entweder mit einem automatischen Skript darauf reagieren oder mit einem DynDNS für IPv6 arbeiten. Letzteres werde ich in nächster Zeit einmal ausprobieren, würde für meine Ansprüche eventuell ausreichen.
Fruchtzwerg hat geschrieben: Wichtig wären auch Dinge wie: wo kriege ich diese Netzwerk-ID her, die die FB beim Eintrag der Weiterleitung gerne hätte?
Dazu kann ich leider nichts sagen, da ich einen TC7200 bekommen habe.

Fruchtzwerg
Kabelexperte
Beiträge: 112
Registriert: 22.06.2015, 14:08

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von Fruchtzwerg » 24.06.2015, 09:22

Danke für die Antwort. :)

Es gibt zwei Probleme:

1. Für meine TP-Link ist die Version 15 noch nicht verfügbar.
2. Ich habe Geräte im Netzwerk, die definitiv nicht ip6-fähig sind.

Das erste Problem wäre wohl nur eine Frage der Zeit. Was aber mache ich mit den ip4-Geräten? Darunter ist eines, das auch von außen erreichbar sein soll, aber selber nicht das innere Netz erreichen soll. (DMZ) Ich schätze, da habe ich überhaupt keine Chance, oder?

Ulimit
Kabelneuling
Beiträge: 24
Registriert: 31.05.2015, 11:22

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von Ulimit » 24.06.2015, 10:17

Fruchtzwerg hat geschrieben: Was aber mache ich mit den ip4-Geräten? Darunter ist eines, das auch von außen erreichbar sein soll, aber selber nicht das innere Netz erreichen soll. (DMZ) Ich schätze, da habe ich überhaupt keine Chance, oder?
Hi, in diesem Thread geht es nur um "IPv6-Nutzung". Wenn Du IPv4-Services betreiben willst, müsstest Du einen eigenen Thread dafür aufmachen. Sicherlich gibt es zur IPv4-Problematik auch schon einige alte Beiträge. Meine persönliche Einschätzung ist, daß man nur mit einer privaten IP (RFC1918) von Unitymedia schlechte Karten hat.

Fruchtzwerg
Kabelexperte
Beiträge: 112
Registriert: 22.06.2015, 14:08

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von Fruchtzwerg » 24.06.2015, 10:42

Ulimit hat geschrieben:Hi, in diesem Thread geht es nur um "IPv6-Nutzung".
Darum geht es ja auch bei mir. :)

Ich habe ja IPv6 von UM bekommen, und muss jetzt eine Lösung für mein vorhandenes Netzwerk finden, oder der Vertrag widerrufen. Einige meiner/unserer Geräte sind zu IPv6 fähig, einige nicht. Zum Glück sind unter den "unfähigen" die weniger wichtigen Geräte, aber die sind eben trotzdem nicht absolut unwichtig. Die Geräte, die V6 können, könnten evtl einen Teil der Funktionen der anderen Geräte mit übernehmen, aber auch eben nur einen Teil.

Wichtig wäre jetzt erst mal, überhaupt eine Erreichbarkeit von außen für einige der IPv6-Geräte zu schaffen, und diese Erreichbarkeit für alle möglichen Endgeräte im Internet zu gewährleisten, also ohne, daß dort Zusatzprogramme oder Apps installiert werden müssen.

Wenn das schon mal nicht geht, hat sich für mich das Thema Unitymedia sowieso erledigt.

hajodele
Kabelkopfstation
Beiträge: 4821
Registriert: 10.04.2013, 14:19
Wohnort: Kabelbw-Land

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von hajodele » 24.06.2015, 10:44

Fruchtzwerg hat geschrieben:Das erste Problem wäre wohl nur eine Frage der Zeit. Was aber mache ich mit den ip4-Geräten?
Vielleicht ist so was das Gegebene: http://www.feste-ip.net/

Fruchtzwerg
Kabelexperte
Beiträge: 112
Registriert: 22.06.2015, 14:08

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von Fruchtzwerg » 24.06.2015, 10:46

Ja, danke, das hatte ich schon gesehen. Aber eine weitere Kostenstelle wollte ich nicht aufmachen.

Ich sehe gerade noch mal diesen Satz auf der Seite:
Geräte hinter Ihrem Anschluss sind von IPv4 Geräten nicht mehr erreichbar.
Wenn das stimmt, dann sind alle Mobiltelefone schon mal raus aus dem Rennen, und das hieße dann für mich "Tschüss, Unitymedia!" :traurig:

hajodele
Kabelkopfstation
Beiträge: 4821
Registriert: 10.04.2013, 14:19
Wohnort: Kabelbw-Land

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von hajodele » 24.06.2015, 11:01

Fruchtzwerg hat geschrieben:Ich sehe gerade noch mal diesen Satz auf der Seite:
Geräte hinter Ihrem Anschluss sind von IPv4 Geräten nicht mehr erreichbar.
Wenn das stimmt, dann sind alle Mobiltelefone schon mal raus aus dem Rennen, und das hieße dann für mich "Tschüss, Unitymedia!" :traurig:
Das Problem ist wieder mal, dass die Mobil-Netze aktuell nur mit IPv4 laufen. Das gleiche Problem hast du prinzipiell auch mit vielen DSL-Providern.
Dies kann man mit Tunnelbrockern umgehen, die zumindest teilweise kostenlos zu haben sind.

ich bin froh, dass ich noch eine echte IPv4 habe.
Wenn man aktuell mehr will, als nur zu surfen, muss man sich bei den Kabelprovidern aktuell noch extrem reinknien.

Fruchtzwerg
Kabelexperte
Beiträge: 112
Registriert: 22.06.2015, 14:08

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von Fruchtzwerg » 24.06.2015, 11:26

hajodele hat geschrieben:Das Problem ist wieder mal, dass die Mobil-Netze aktuell nur mit IPv4 laufen.
Und das bedeutet dann, daß ich mit einem Smartphone schon mal gar nicht auf meine Server komme. :(
Dies kann man mit Tunnelbrockern umgehen, die zumindest teilweise kostenlos zu haben sind.
Das wird zu kompliziert: ich kann nicht allen Benutzern sagen, sie sollen irgend einen Zusatzdienst benutzen oder etwas auf ihren Tabletts und Smartphones installieren, um meine Server benutzen zu können. Die werden sich sicher darüber freuen! :sauer:

Und das Problem der Online-Spiele des Nachwuchses ist damit auch noch nicht gelöst.

Zum Glück läuft mein alter Vertrag noch ein paar Wochen. Ich setze dann einfach mal das Widerrufschreiben auf. Mal sehen, was UM dazu sagt.

un1que
Übergeordneter Verstärkerpunkt
Beiträge: 685
Registriert: 01.07.2013, 17:56

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von un1que » 24.06.2015, 11:39

Da dir die IPv4 so wichtig ist, könntest du ja zu UM Business wechseln, wird dann halt nur teurer.

hajodele
Kabelkopfstation
Beiträge: 4821
Registriert: 10.04.2013, 14:19
Wohnort: Kabelbw-Land

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von hajodele » 24.06.2015, 11:46

Die einzigen möglichen Kabel-Alternativen sind:
- 3play ohne Fritzbox (nur mit Horizon)
- Business

in beiden Varianten bekommt man "nur" IPv4
Aber das wurde vielleicht schon weiter oben erwähnt.

Mein Nachwuchs ist inzwischen 17 und überagt mich deutlich. Wenn sein Steam plötzlich nicht mehr vernünftig laufen würde, bekäme ich wohl eine Kopfwäsche. :hammer:

Fruchtzwerg
Kabelexperte
Beiträge: 112
Registriert: 22.06.2015, 14:08

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von Fruchtzwerg » 24.06.2015, 12:08

Laut telefonischer Auskunft von UM gibt es im Business-Tarif aber kein TV dazu. Dazu wären dann zwei Verträge nötig. Und die kosten mich dann zusammen unverschämt viel mehr.

Die FritzBox benötige ich wegen der Anzahl der Rufnummern.

Tja, 3 Tage HD gucken war schön, aber der Internetanschluss von UM bringt mir zu viele Probleme mit sich. Jetzt ist der Widerruf raus und ich sage "tschüss, UM!" :smt006

adn77
Kabelneuling
Beiträge: 10
Registriert: 15.05.2014, 19:17

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von adn77 » 19.07.2015, 14:04

Hallo Zusammen,

bisher benutze ich OpenWRT als Firewalled Bridge für IPv6 ( http://www.unitymediakabelbwforum.de/vi ... hp?t=29597 ) aber da ich dort lokale DNS Anfragen via IPv6 nicht vernünftig abgefangen bekomme, wollte ich die Lösung von SpaceRat und ulimit ausprobobieren.

Ich habe das aktuelle Chaos Calmer rc3 installiert und die Einstellungen wie oben geschrieben eingetragen.
(Da mein DK7200 irgendwann keine IPv4 Verbindungen von Hosts übersetzt, die ihre Adresse nicht per DHCP bekommen haben, habe ich an Stelle der statischen IPv4 Konfiguration für's WAN Interface dort auch dhcp stehen.)

Leider funktionieren die Einstellungen so nicht - ich komme nicht per IPv6 nach draußen.
Wenn ich mir den Neighbor Cache und die Routen anschaue, so ist das auch nicht weiter verwunderlich:

Code: Alles auswählen

ip -6 neigh

fe80::290:a9ff:xxxx:xxxx dev br-lan lladdr 00:90:a9:xx:xx:xx STALE				# Debian Box
fe80::20e:a6ff:yyyy:yyyy dev eth0.2 lladdr 00:0e:a6:yy:yy:yy STALE				# OpenWRT Router
fe80::5a23:8cff:zzzz:zzzz dev eth0.2 lladdr 58:23:8c:zz:zz:zz router REACHABLE	# DK7200
2a02:8070:e1b5:8400:290:a9ff:xxxx:xxxx dev eth0.2  FAILED						# Debian Box public IPv6

Code: Alles auswählen

ip -6 route

default from 2a02:8070:e1b5:8400::/64 via fe80::5a23:8cff:zzzz:zzzz dev eth0.2  proto static  metric 512
2a02:8070:e1b5:8400::/56 from 2a02:8070:e1b5:8400::/64 via fe80::5a23:8cff:zzzz:zzzz dev eth0.2  proto static  metric 512
2a02:8070:e1b5:8400::/64 from 2a02:8070:e1b5:8400::/64 dev eth0.2  proto static  metric 256
2a02:8070:e1b5:8400::/64 dev eth0.2  proto static  metric 256
2a02:8070:e1b5:8400:20e:a6ff:yyyy:yyyy dev br-lan  proto static  metric 1024
fe80::/64 dev eth0  proto kernel  metric 256
fe80::/64 dev br-lan  proto kernel  metric 256
fe80::/64 dev eth0.2  proto kernel  metric 256
fe80::/64 dev wlan0  proto kernel  metric 256
Könntet ihr mal bitte euren Neighbor Cache bzw. die Routen posten!

Wie verhält sich in eurem Setup die DNS-Auflösung für lokale Geräte (z.B. SAT-Box). Mein Nexus7 scheint immer erstmal ein DNSv6 Lookup zu versuchen...

Fruchtzwerg
Kabelexperte
Beiträge: 112
Registriert: 22.06.2015, 14:08

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von Fruchtzwerg » 22.07.2015, 12:09

Fruchtzwerg hat geschrieben:Jetzt ist der Widerruf raus und ich sage "tschüss, UM!"
Tja, so kann's gehen: Widerruf zwecklos, weil der Vertrag im Ladengeschäft abgeschlossen wurde. :(

Also heißt es jetzt "Augen zu und durch!". Naja, 24 Monat sind auch schneller um, als man denkt. Bis dahin habe ich hoffentlich eine Sat-Antenne.

Fruchtzwerg
Kabelexperte
Beiträge: 112
Registriert: 22.06.2015, 14:08

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von Fruchtzwerg » 24.07.2015, 14:42

Ich versuche jetzt auch, die Konfiguration von Ulimit auf der zweiten Seite dieses Themas zu realisieren, aber bei mir klappt's noch nicht so ganz. Ich würde mich wirklich über Hilfe freuen, denn leider ist IPv6 noch Neuland für mich. :smt009 (Nein, mein Nachname beginnt nicht mit "M"! ;) )

Ich habe einen Router, auf dem OpenWRT 15.05 rc3 läuft, also die letzte verfügbare Version. Die Zusätzlichen Pakte, die sich im Zuge der Anleitung ergeben, sind installiert. Auf dem Router sind zunächst zwei VLAN errichtet, für LAN und DMZ, später sollen es evtl noch mehr werden. Die beiden Zonen sollen während der Experimentierphase noch beide von außen erreichbar sein, später soll es natürlich nur noch die DMZ sein.

Der Router ist per WiFi im Client-Modus mit der FritzBox verbunden. (Schnittstelle wwan.) Anders geht es auch nicht, sonst müsste ich Kabel durch's Wohnzimmer legen. Das ist keine gute Idee...

Meine /etc/config/network:

Code: Alles auswählen


config globals 'globals'
        option ula_prefix 'fd3b:25c9:2d1c::/48'

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'wan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '10.10.10.10'
        option metric '1'
        option gateway '10.10.10.1'
        option dns '10.10.10.1'
        option ifname 'eth0'
        option type 'bridge'
        option ip6assign '64'

config interface 'wan6'
        option ifname 'eth0'
        option _orig_ifname 'eth0'
        option _orig_bridge 'false'
        option proto 'dhcpv6'
        option peerdns '0'
        option reqprefix 'no'
        option reqaddress 'none'

config interface 'lan'
        option proto 'static'
        option ifname 'eth1.1'
        option ipaddr '10.10.1.1'
        option netmask '255.255.255.0'
        option ip6assign '64'
        option delegate '0'
        option force_link '1'

config interface 'dmz'
        option ifname 'eth1.3'
        option proto 'static'
        option ipaddr '10.10.3.1'
        option netmask '255.255.255.0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan 'eth1_1'
        option device 'switch0'
        option vlan '1'
        option ports '0t 1'

config switch_vlan 'eth1_3'
        option device 'switch0'
        option vlan '3'
        option ports '0t 3'


config interface 'wwan'
        option _orig_ifname 'wlan0'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '10.10.10.11'
        option netmask '255.255.255.0'
        option gateway '10.10.10.1'
        option ip6assign '64'
Daraus ergibt sich:

Code: Alles auswählen

root@netgear:/etc/config# ifconfig 
br-wan    Link encap:Ethernet  HWaddr 08:BD:43:B0:1C:49  
          inet addr:10.10.10.10  Bcast:10.10.10.255  Mask:255.255.255.0
          inet6 addr: fd3b:25c9:2d1c:1::1/64 Scope:Global
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth0      Link encap:Ethernet  HWaddr 08:BD:43:B0:1C:49  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:4 


eth1      Link encap:Ethernet  HWaddr 08:BD:43:B0:1C:48  
          inet6 addr: fe80::abd:43ff:feb0:1c48/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:62087 errors:0 dropped:0 overruns:0 frame:0
          TX packets:64424 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:6896974 (6.5 MiB)  TX bytes:37442070 (35.7 MiB)
          Interrupt:5 

eth1.1    Link encap:Ethernet  HWaddr 08:BD:43:B0:1C:48  
          inet addr:10.10.1.1  Bcast:10.10.1.255  Mask:255.255.255.0
          inet6 addr: fd3b:25c9:2d1c::1/64 Scope:Global
          inet6 addr: fe80::abd:43ff:feb0:1c48/64 Scope:Link
          inet6 addr: fd3b:25c9:2d1c:1::1/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3580 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3510 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:342050 (334.0 KiB)  TX bytes:1114655 (1.0 MiB)

eth1.3    Link encap:Ethernet  HWaddr 08:BD:43:B0:1C:48  
          inet addr:10.10.3.1  Bcast:10.10.3.255  Mask:255.255.255.0
          inet6 addr: fe80::abd:43ff:feb0:1c48/64 Scope:Link
          inet6 addr: fd3b:25c9:2d1c:1::1/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:976 (976.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:795 errors:0 dropped:0 overruns:0 frame:0
          TX packets:795 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:57288 (55.9 KiB)  TX bytes:57288 (55.9 KiB)

wlan0     Link encap:Ethernet  HWaddr DE:10:C0:CE:9D:A4  
          inet addr:10.10.10.11  Bcast:10.10.10.255  Mask:255.255.255.0
          inet6 addr: fe80::dc10:c0ff:fece:9da4/64 Scope:Link
          inet6 addr: fd3b:25c9:2d1c:2::1/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:967 errors:0 dropped:0 overruns:0 frame:0
          TX packets:832 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:396264 (386.9 KiB)  TX bytes:132241 (129.1 KiB)
Angeblich bekommt mein PC auch eine IP6:

Code: Alles auswählen

ifconfig 
eth0      Link encap:Ethernet  Hardware Adresse 00:19:66:99:08:cf  
          inet Adresse:10.10.1.77  Bcast:10.10.1.255  Maske:255.255.255.0
          inet6-Adresse: fd3b:25c9:2d1c:1:219:66ff:fe99:8cf/64 Gültigkeitsbereich:Global
          inet6-Adresse: fd3b:25c9:2d1c:0:219:66ff:fe99:8cf/64 Gültigkeitsbereich:Global
          inet6-Adresse: fd00::219:66ff:fe99:8cf/64 Gültigkeitsbereich:Global
          inet6-Adresse: fe80::219:66ff:fe99:8cf/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX-Pakete:99276 Fehler:0 Verloren:0 Überläufe:0 Fenster:0
          TX-Pakete:89725 Fehler:0 Verloren:0 Überläufe:0 Träger:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX-Bytes:78817223 (78.8 MB)  TX-Bytes:8840261 (8.8 MB)
Ich komme mit meinem PC nach draußen, allerdings nur über IP4:

Code: Alles auswählen

ping6 six.heise.de
connect: Network is unreachable
Ich komme leider alleine nicht weiter.

Die erste Frage, die ich habe: Ulimit, woher hast Du den ULA-Präfix, den Du verwendet hast? Ist das der Präfix, den die FritzBox angibt? Der lautet bei mir fd00::xxx:xxxx:xxxx:xxxx/64 (natürlich nicht mit "xxxx"...) Aber wenn ich den benutze in /etc/config/network, werden keine IP6 mehr verteilt.

Was muss/kann ich tun, damit es weitergeht?

Fruchtzwerg
Kabelexperte
Beiträge: 112
Registriert: 22.06.2015, 14:08

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von Fruchtzwerg » 24.07.2015, 21:27

So, ich hatte gerade einen Anfall von Masochismus und habe noch mal 2 Stunden drangehangen, leider auch erfolglos. Laut http://www.wieistmeineip.de/ipv6/ habe ich keine IPv6, es wird nur die IP4 von UM angezeigt (37.201.215.119).

Das kann ich nicht wirklich verstehen, weil ich doch dieselbe Konfiguration wie die von Ulimit benutze, die er am 02.06.2015 22:48 beschrieben hat. :kratz:


Nachtrag:

es würde mich sehr interessiert, wer von den hier Mitlesenden einen zweiten Router mit OpenWRT hinter der FritzBox von UM betreibt, und wer es geschafft hat, diesen Router so zu konfigurieren, daß die daran angeschlossenen Geräte von der FB eine IPv6 weitergeleitet bekommen, die auch ins Netz geroutet wird.

ollivong01
Kabelneuling
Beiträge: 10
Registriert: 12.07.2015, 22:28

Re: IPv6-Nutzung geschützt durch privaten Router überhaupt m

Beitrag von ollivong01 » 24.07.2015, 22:17

Ich bin ja kein Fachmann aber wenn ich auf wieistmeineip einen speedtest mache dann sehe ich die ipv6 und manchmal nicht. Wenn ich die ipv6 nicht sehe und dann im tc7200 nachschaue im lokallog sehe ich was von IP provisoring und habe nur eine v4. Das liegt wohl so denke im am diesem dslite

Antworten

Wer ist online?

Mitglieder in diesem Forum: kicker46, rv112, sch4kal, SCWfan06 und 9 Gäste