ipv6 Tunnel an ipv4 Anschluss - langsam

In vielen Netzen von Unitymedia sind Internet und Telefonie bereits verfügbar.
Forumsregeln
  • Kunden aus Hessen und Nordrhein-Westfalen können über die Rufnummer 0221 / 466 191 00 Hilfe bei allen Problemen in Anspruch nehmen.
  • Kunden aus Baden-Württemberg können über die Rufnummer 0711 / 54 888 150 Hilfe bei allen Problemen in Anspruch nehmen.
JurgenS
erfahrener Kabelkunde
Beiträge: 76
Registriert: 28.03.2010, 12:09

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von JurgenS » 09.03.2015, 12:34

SpaceRat hat geschrieben:Ihr könntet ja mal - unter Linux - folgendes ausprobieren:
...
Hallo,
nein soweit war ich gestern auch schon, die ermittelte IPv4 Pufferlänge beträgt z.B. in meinem Fall 1709. Damit gibt es also gar keine Probleme. Die MTU auf 1232 festzulegen geht auch nicht, da IPv6 eine Minimallänge von 1280 vorschreibt. Weder Fritzbox noch SixSX lassen richtigerweise kleinere Werte als 1280 zu.

Ich bin momentan auf einem ganz anderen Dampfer. Unter IPv6 wird nicht mehr fragmentiert. Die Beschränkung der Paketgröße erfolgt durch Verwerfen des Paketes und Senden einer ICMPv6 "Paket zu groß" Nachricht. Der Sender müßte dann neue, kleinere Pakete senden.
Meine Vermutung im Moment: Diese ICMP Pakete werden irgendwo geblockt. Ich konnte sie auf meiner Seite mit Wireshark nie sehen. Das würde erklären warum der ganze Ablauf nicht funktioniert.

Naja,
Jürgen
Bild

Benutzeravatar
SpaceRat
Glasfaserstrecke
Beiträge: 2467
Registriert: 08.05.2010, 01:30
Wohnort: Kreis Aachen
Kontaktdaten:

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von SpaceRat » 09.03.2015, 12:44

JurgenS hat geschrieben:nein soweit war ich gestern auch schon, die ermittelte IPv4 Pufferlänge beträgt z.B. in meinem Fall 1709.
Bei 1709 muß aber was oberfaul sein ...
JurgenS hat geschrieben:Die MTU auf 1232 festzulegen geht auch nicht, da IPv6 eine Minimallänge von 1280 vorschreibt. Weder Fritzbox noch SixSX lassen richtigerweise kleinere Werte als 1280 zu.
Stimmt, das habe ich nicht bedacht.
JurgenS hat geschrieben:Meine Vermutung im Moment: Diese ICMP Pakete werden irgendwo geblockt. Ich konnte sie auf meiner Seite mit Wireshark nie sehen. Das würde erklären warum der ganze Ablauf nicht funktioniert.
Versuch doch aus Jux mal, eine IPv6-Freigabe für den Test-Rechner zu machen und IPv6-Pings (oder auch mal temporär alles) zu erlauben. Vielleicht sind die fehlenden ICMPv6-Geschichten ja versehentlich mit in die Firewall gewandert, obwohl diese eigentlich nie geblockt werden dürften ...
Receiver/TV:
  • Vu+ Duo² 4xS2+2xC / OpenATV 6.1@Samsung 50" Plasma
  • AX Quadbox HD2400 2xS2+2xC / OpenATV 6.1@Samsung 32" TFT
  • 2xVu+ Solo² / OpenATV 6.1
  • DVBSky S2-Twin PCIe@SyncMaster T240HD (PC)
  • TechniSat SkyStar HD2@17" (2.PC)
Pay-TV: Schwarzfunk, Redlight Elite Superchic, SCT 10, HD-, Sky
Fon: VF Komfort-Classic (ISDN), 2xFritz!Fon C4+Siedle DoorCom Analog@F!B 7390
Internet: UM 1play 100 / Cisco EPC3212+Linksys WRT1900ACS / IPv4 (UM) + IPv6 (HE)
Bild

JurgenS
erfahrener Kabelkunde
Beiträge: 76
Registriert: 28.03.2010, 12:09

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von JurgenS » 09.03.2015, 13:12

SpaceRat hat geschrieben: Versuch doch aus Jux mal, eine IPv6-Freigabe für den Test-Rechner zu machen und IPv6-Pings (oder auch mal temporär alles) zu erlauben. Vielleicht sind die fehlenden ICMPv6-Geschichten ja versehentlich mit in die Firewall gewandert, obwohl diese eigentlich nie geblockt werden dürften ...
Habe ich gestern auch schon gemacht. Wie in meinem ersten Beitrag geschrieben kommen Pings von außen an meinem HeimServer problemlos an.

Kannst gern auch selber schauen:
Geht: ping6 2a01:198:200:8c0d:20c:29ff:fe6d:19dc
Geht nicht: wget http://[2a01:198:200:8c0d:20c:29ff:fe6d:19dc]/ (Timeout :wut: )

Jürgen
Bild

Benutzeravatar
SpaceRat
Glasfaserstrecke
Beiträge: 2467
Registriert: 08.05.2010, 01:30
Wohnort: Kreis Aachen
Kontaktdaten:

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von SpaceRat » 09.03.2015, 13:35

JurgenS hat geschrieben:Kannst gern auch selber schauen:
Geht: ping6 2a01:198:200:8c0d:20c:29ff:fe6d:19dc
Yepp.

Und:

Code: Alles auswählen

root@OpenWrt:~# i=1200; while ping6 -s $i -M do -nc1 2a01:198:200:8c0d:20c:29ff:fe6d:19dc >/dev/null; do i=$((i+1)); done; echo $((i-1+8))
1240
Irgendwas an der MTU is verkorkst.

JurgenS
erfahrener Kabelkunde
Beiträge: 76
Registriert: 28.03.2010, 12:09

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von JurgenS » 09.03.2015, 13:48

SpaceRat hat geschrieben: Irgendwas an der MTU is verkorkst.
Naja, das ist doch was hasselholz schon auf Seite 1 schrieb und ich auf Seite 3 bestätigte. Ping6 nur bis Pufferlänge 1232. Dein Script zählt noch 8 dazu und zeigt 1240 an.

Die MTU in Fritzbox und SixXS steht aber momentan auf 1328. Was aber auch egal zu sein scheint. Auch mit 1280 oder 1400 immer dasselbe Verhalten.

:wand: :wand: :wand:
Bild

Benutzeravatar
SpaceRat
Glasfaserstrecke
Beiträge: 2467
Registriert: 08.05.2010, 01:30
Wohnort: Kreis Aachen
Kontaktdaten:

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von SpaceRat » 09.03.2015, 13:59

JurgenS hat geschrieben:Die MTU in Fritzbox und SixXS steht aber momentan auf 1328. Was aber auch egal zu sein scheint. Auch mit 1280 oder 1400 immer dasselbe Verhalten.
:wand: :wand: :wand:
Man könnte mit der MTU für die IPv4-Verbindung rumspielen, sofern UM das nicht sofort überschreibt.
Es gibt diverse MTU-Einstellungen in der .export-Datei der Fritz!Box, an denen man mal drehen könnte.

JurgenS
erfahrener Kabelkunde
Beiträge: 76
Registriert: 28.03.2010, 12:09

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von JurgenS » 09.03.2015, 19:41

SpaceRat hat geschrieben: Man könnte mit der MTU für die IPv4-Verbindung rumspielen, sofern UM das nicht sofort überschreibt.
Es gibt diverse MTU-Einstellungen in der .export-Datei der Fritz!Box, an denen man mal drehen könnte.
Gute Idee. Ich habe dazu beide gleichartige Export-Dateien (6490 und 6360) miteinander verglichen um einen Ansatzpunkt zu finden an welchen Punkten sie sich unterscheiden. Alles was nach Firewall oder MTU oder so aussieht ist aber gleich eingestellt. Bliebe also nur blindes herumstochern...
Bild

Benutzeravatar
Andreas1969
Network Operation Center
Beiträge: 7974
Registriert: 05.03.2015, 07:50
Wohnort: Unitymedia NRW

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von Andreas1969 » 12.03.2015, 08:34

Ich vermute mal,
es wird erst mal keine Lösung geben.
Oder hat noch jemand ne Idee?
Denken gehört zu den schwersten Dingen, die man tun kann. Vielleicht ist das der Grund, warum es so Wenige tun. :kratz:
Bild
Alle sagten: Es geht nicht. Da kam einer, der das nicht wusste und tat es einfach. :D

hasselholz
Kabelneuling
Beiträge: 12
Registriert: 12.02.2015, 07:05

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von hasselholz » 12.03.2015, 22:43

vielleicht wenn alle, die davon betroffen sind mal bei UM anrufen und ein Ticket aufmachen :zwinker:

Benutzeravatar
SpaceRat
Glasfaserstrecke
Beiträge: 2467
Registriert: 08.05.2010, 01:30
Wohnort: Kreis Aachen
Kontaktdaten:

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von SpaceRat » 14.03.2015, 14:19

hasselholz hat geschrieben:vielleicht wenn alle, die davon betroffen sind mal bei UM anrufen und ein Ticket aufmachen :zwinker:
Wie willst Du erreichen, daß die ein Ticket aufmachen, wo doch eh alles die kleinen grünen Männchen, Wasseradern und der Stand des Mondes schuld sind?

Benutzeravatar
SpaceRat
Glasfaserstrecke
Beiträge: 2467
Registriert: 08.05.2010, 01:30
Wohnort: Kreis Aachen
Kontaktdaten:

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von SpaceRat » 14.03.2015, 16:40

JurgenS hat geschrieben:Gute Idee. Ich habe dazu beide gleichartige Export-Dateien (6490 und 6360) miteinander verglichen um einen Ansatzpunkt zu finden an welchen Punkten sie sich unterscheiden. Alles was nach Firewall oder MTU oder so aussieht ist aber gleich eingestellt.
Es geht ja durchaus auch um das, was nicht drin bzw. auf Einstellungen a la "autodetect" steht.

Wenn Du mir sagst "Jetzt links abbiegen." biege ich links ab, wenn Du das gleiche meiner Frau sagst, biegt sie rechts ab, es sei denn, es wurde vorher die Einstellung "Meine Seite = links" vorgenommen.

Das gleiche kann ja auch in der Firmware passiert sein:
Wenn Du der 6360 sagst "Erkenne die MTU selber" dann kommt sie wohl auf 1480, die 6490 womöglich nur auf 1280.
Oder es gibt Unterschiede zwischen den Profilen für 100 und 200 MBit/s, die man aber evtl. durch bestimmte feste Vorgaben in der Fritz!Box kompensieren kann ...

Irgendwas nach der Art ...
JurgenS hat geschrieben:Bliebe also nur blindes herumstochern...
Richtig.

Ich kann da nicht viel machen, ich habe keinen Zugriff auf einen Anschluß mit 200 MBit/s und IPv4.
Ich kann nur Vergleichswerte vom 100/10er Profil liefern und da kommt für IPv4 folgendes raus:

Code: Alles auswählen

root@Pi ~ # i=1360; while ping -s $i -M do -nc1 82.135.16.28 >/dev/null; do i=$((i+1)); done; echo $((i-1+8))
1480
Wenn beim 200er Profil auf der 6490 schon für IPv4 etwas anderes herauskommt, könnte es sinnvoll sein hier mal damit rumzuspielen, den Wert 1480 vorzugeben und den MTU-Test zu wiederholen.
Receiver/TV:
  • Vu+ Duo² 4xS2+2xC / OpenATV 6.1@Samsung 50" Plasma
  • AX Quadbox HD2400 2xS2+2xC / OpenATV 6.1@Samsung 32" TFT
  • 2xVu+ Solo² / OpenATV 6.1
  • DVBSky S2-Twin PCIe@SyncMaster T240HD (PC)
  • TechniSat SkyStar HD2@17" (2.PC)
Pay-TV: Schwarzfunk, Redlight Elite Superchic, SCT 10, HD-, Sky
Fon: VF Komfort-Classic (ISDN), 2xFritz!Fon C4+Siedle DoorCom Analog@F!B 7390
Internet: UM 1play 100 / Cisco EPC3212+Linksys WRT1900ACS / IPv4 (UM) + IPv6 (HE)
Bild

Conan179
Übergeordneter Verstärkerpunkt
Beiträge: 583
Registriert: 25.01.2015, 22:38

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von Conan179 » 14.03.2015, 23:32

Wen es von inntresse ist, hier 120mbit, DS-lite

Code: Alles auswählen

root@Raspberry:~# i=1360; while ping -s $i -M do -nc1 82.135.16.28 >/dev/null; do i=$((i+1)); done; echo $((i-1+8))
1440
BildBildBild

Benutzeravatar
SpaceRat
Glasfaserstrecke
Beiträge: 2467
Registriert: 08.05.2010, 01:30
Wohnort: Kreis Aachen
Kontaktdaten:

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von SpaceRat » 14.03.2015, 23:38

Conan179 hat geschrieben:Wen es von inntresse ist, hier 120mbit, DS-lite
1440
Ne, ist es in dem Fall nicht.

DS-lite ist ja quasi genau das Umgekehrte dessen, was hier im Thread Thema ist.

Conan179
Übergeordneter Verstärkerpunkt
Beiträge: 583
Registriert: 25.01.2015, 22:38

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von Conan179 » 14.03.2015, 23:39

tja war ein versuch wert.
BildBildBild

Fabricio75
Kabelneuling
Beiträge: 12
Registriert: 03.11.2014, 16:19

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von Fabricio75 » 15.03.2015, 10:06

IPV4 und 200er Leitung, frage mich warum da ein noch kleinerer und vor allem krummer Wert rauskommt:

Code: Alles auswählen

root@Raspberry:~# i=1360; while ping -s $i -M do -nc1 82.135.16.28 >/dev/null; do i=$((i+1)); done; echo $((i-1+8))
1367
Zuletzt geändert von Fabricio75 am 15.03.2015, 10:18, insgesamt 2-mal geändert.
Bild

Benutzeravatar
SpaceRat
Glasfaserstrecke
Beiträge: 2467
Registriert: 08.05.2010, 01:30
Wohnort: Kreis Aachen
Kontaktdaten:

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von SpaceRat » 15.03.2015, 10:11

Fabricio75 hat geschrieben:IPV4 und 200er Leitung, frage mich warum da ein noch kleinerer und vor allem krummer Wert rauskommt:

Code: Alles auswählen

root@Raspberry:~# i=1360; while ping -s $i -M do -nc1 82.135.16.28 >/dev/null; do i=$((i+1)); done; echo $((i-1+8))
1367
Krumm ist der Wert, weil schon der Startwert zu hoch ist, d.h. die MTU liegt noch unter 1360 ...

Mach mal

Code: Alles auswählen

i=1240; while ping -s $i -M do -nc1 82.135.16.28 >/dev/null; do i=$((i+1)); done; echo $((i-1+8))
Und damit wäre mein nächster Schritt:
1. pro-forma-Ermittlung der MTU ... so niedrig kann die aber eigentlich nicht wirklich sein ...
2. In der .export nachgucken, wo die MTU der Internet-Verbindung (IPv4) vorgegeben wird und dort 1480 einsetzen

Fabricio75
Kabelneuling
Beiträge: 12
Registriert: 03.11.2014, 16:19

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von Fabricio75 » 15.03.2015, 11:54

Ich glaube wir müssen nochmal von vorn anfangen da der Test vermutlich aufgrund des fehlenden "echten" Linux nicht korrekt funktioniert. Ich habe jetzt mal wie folgt getestet und bin bis 1472 (soweit ich weiß muss man noch 28 Bytes addieren) und käme somit auf eine max. MTU von 1500. Sobald ich mit 1473 teste kommt die Meldung, dass das Paket fragmentiert werden müsste:

Code: Alles auswählen

ping -f -l 1472 82.135.16.28

Ping wird ausgeführt für 82.135.16.28 mit 1472 Bytes Daten:
Antwort von 82.135.16.28: Bytes=1472 Zeit=26ms TTL=244
Antwort von 82.135.16.28: Bytes=1472 Zeit=29ms TTL=244
Antwort von 82.135.16.28: Bytes=1472 Zeit=40ms TTL=244
Antwort von 82.135.16.28: Bytes=1472 Zeit=29ms TTL=244

Ping-Statistik für 82.135.16.28:
    Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
    (0% Verlust),
Ca. Zeitangaben in Millisek.:
    Minimum = 26ms, Maximum = 40ms, Mittelwert = 31ms
Dann habe ich mir die Export angeschaut.

Im Abschnitt ar7cfg:

Code: Alles auswählen

mtu_cutback_mode = mtumode_auto;
mtu_cutback = 1500;


und im Abschnitt IPV6 (den SIXXS Tunnel habe ich derzeit nicht aktiviert):

Code: Alles auswählen

use_fixed_mtu = yes;
fixed_mtu = 1500
Im IPV6 Abschnitt variiert der Wert entsprechend sobald ich ihn übers Webinterface ändere und wieder exportiere, im Abschnitt ar7cfg bleibt es immer auf auto und 1500 stehen.

Hilft das weiter?

Ich denke einen geänderten MTU Wert für IPV4 (Abschnitt ar7cfg) wird die Box nicht übernehmen, solange mtumode_auto drin steht, ich weiß aber nicht wie der Wert für manuell lautet.
Bild

Fabricio75
Kabelneuling
Beiträge: 12
Registriert: 03.11.2014, 16:19

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von Fabricio75 » 15.03.2015, 13:06

Habe jetzt mal die max MTU per IPV6 (SIXXS Tunnel aktiviert) ermittelt. Die Minimum MTU bei SIXXS ist ja mit 1280 angegeben, allerdings funktioniert der IPV6 ping, ich habe heise.de genommen, erst ab 1232, sobald ich höher gehe kommt eine Zeitüberschreitung.

Per IPV4 ping auf 82.135.16.28 bin ich mit einer MTU von 1500 erfolgreich.

PS: ich kann die MTU für ipv4 in der Fritzbox eh nicht anpassen, weil ich die geändert Export nicht mehr einlesen kann. Übers Webinterface kann ich den kleinsten Wert 1280 wählen.
Bild

Benutzeravatar
Andreas1969
Network Operation Center
Beiträge: 7974
Registriert: 05.03.2015, 07:50
Wohnort: Unitymedia NRW

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von Andreas1969 » 15.03.2015, 13:11

So, habe jetzt mal ausgelesen:
Fritz 6360 mit 100/5 IPV4 Anschluß mit funktionierenden SIXXS-Tunnel und
Fritz 6490 mit 200/10 IPV4 Anschluß mit nicht funktionierenden SIXXS-Tunnel
Konnte dies tun, da ich 2 Anschlüsse bei UM an 2 Standorten mit den beiden Fritz-Boxen habe.
Die MTU usw. unterscheiden sich jedenfalls nicht.
In der Export-Config ist mir jedoch ein Unterschied in der SIXXS Einstellung aufgefallen:

Fritz 6360:
ip6_static_cfg {
prefix = ::;
prefixlen = 56;
wan_use_firstprefix = yes;
wan_prefix = ::;
wan_ifid_automatic = yes;
wan_ifid = ::;
wan_dns1 = ::;
wan_dns2 = ::;
}
he {
update_server = "ipv4.tunnelbroker.net";
tunnel {
popaddr = 0.0.0.0;
local = ::;
remote = ::;
prefix = ::;
prefixlen = 0;
}
}
firewall {
enabled = yes;
exposed_host = no;
ping6_allowed = no;
rules = "TCP 8089", "TCP 443", "TCP 21";
}
aftr = ::;
}

Fritz 6490:
ip6_static_cfg {
prefix = ::;
prefixlen = 56;
wan_use_firstprefix = yes;
wan_prefix = ::;
wan_ifid_automatic = yes;
wan_ifid = ::;
wan_dns1 = ::;
wan_dns2 = ::;
}
he {
update_server = "ipv4.tunnelbroker.net";
tunnel {
popaddr = 0.0.0.0;
local = ::;
remote = ::;
prefix = ::;
prefixlen = 0;
}
}
firewall {
enabled = yes;
exposed_host = no;
ping6_allowed = no;
rules = "TCP 443", "TCP 21";
}
aftr = ::;
manual_aftrfqdn = "";
use_gw_as_pcpserver = no;
pcpserver_supports_rfc7220 = no;
}

In der 6490 steht hinter aftr = ::; noch folgender Eintrag:
manual_aftrfqdn = "";
use_gw_as_pcpserver = no;
pcpserver_supports_rfc7220 = no;

In der 6360 gibt es diesen zusätzlichen Eintrag nicht.

Vielleicht ist dies ja der Ansatz.
Kann das ev. mal jemand gegenchecken ?
Denken gehört zu den schwersten Dingen, die man tun kann. Vielleicht ist das der Grund, warum es so Wenige tun. :kratz:
Bild
Alle sagten: Es geht nicht. Da kam einer, der das nicht wusste und tat es einfach. :D

Fabricio75
Kabelneuling
Beiträge: 12
Registriert: 03.11.2014, 16:19

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von Fabricio75 » 15.03.2015, 13:15

Andreas1969 hat geschrieben:In der 6490 steht hinter aftr = ::; noch folgender Eintrag:
manual_aftrfqdn = "";
use_gw_as_pcpserver = no;
pcpserver_supports_rfc7220 = no;

Vielleicht ist dies ja der Ansatz.
Kann das ev. mal jemand gegenchecken ?
Kann ich bei meiner 6490 bestätigen. Habe den Eintrag ebenfalls wie du geschrieben hast.
Bild

Benutzeravatar
Andreas1969
Network Operation Center
Beiträge: 7974
Registriert: 05.03.2015, 07:50
Wohnort: Unitymedia NRW

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von Andreas1969 » 15.03.2015, 13:19

Der Eintrag scheint irgend etwas mit der Vorbereitung für das Port Control Protocol für DSlight Anschlüsse zu tun zu haben.
Denken gehört zu den schwersten Dingen, die man tun kann. Vielleicht ist das der Grund, warum es so Wenige tun. :kratz:
Bild
Alle sagten: Es geht nicht. Da kam einer, der das nicht wusste und tat es einfach. :D

Joerg
Übergeordneter Verstärkerpunkt
Beiträge: 806
Registriert: 22.09.2007, 19:24
Wohnort: NRW

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von Joerg » 15.03.2015, 17:23

Fabricio75 hat geschrieben:IPV4 und 200er Leitung, frage mich warum da ein noch kleinerer und vor allem krummer Wert rauskommt:

Code: Alles auswählen

root@Raspberry:~# i=1360; while ping -s $i -M do -nc1 82.135.16.28 >/dev/null; do i=$((i+1)); done; echo $((i-1+8))
1367
Wild guess: Du verwendest Windows (+Cygwin oder so); in dem Fall geht bereits der erste "ping" schief, weil die Commandline-Parameter nicht passen. Probier's dann doch mal mit

Code: Alles auswählen

i=1360; while ping -l $i -f -n 1  82.135.16.28; do i=$((i+1)); done; echo $((i-1+8))
Bei 120/6 mit IPv4 kommt da übrigens auch 1480 raus.

Gruß,

Jörg

Benutzeravatar
SpaceRat
Glasfaserstrecke
Beiträge: 2467
Registriert: 08.05.2010, 01:30
Wohnort: Kreis Aachen
Kontaktdaten:

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von SpaceRat » 15.03.2015, 17:31

Fabricio75 hat geschrieben:Ich glaube wir müssen nochmal von vorn anfangen da der Test vermutlich aufgrund des fehlenden "echten" Linux nicht korrekt funktioniert.
Raspbian ist ein ganz normales Debian.
Es baut nur jemand Anderes ...

Fabricio75 hat geschrieben:Ich habe jetzt mal wie folgt getestet und bin bis 1472 (soweit ich weiß muss man noch 28 Bytes addieren) und käme somit auf eine max. MTU von 1500. Sobald ich mit 1473 teste kommt die Meldung, dass das Paket fragmentiert werden müsste:
Plus 8 für das IP-Paket, nochmals plus 20 für den Ethernet-Frame.

Fabricio75 hat geschrieben:Ich denke einen geänderten MTU Wert für IPV4 (Abschnitt ar7cfg) wird die Box nicht übernehmen, solange mtumode_auto drin steht, ich weiß aber nicht wie der Wert für manuell lautet.
z.B.

Code: Alles auswählen

mtu_cutback_mode = yes;
mtu_cutback = 1480;



Ich habe übrigens noch einen zweiten Treffer für die MTU ins Rennen zu werfen:

Code: Alles auswählen

        dslifaces {
                ...
                name = "internet";
                ...
                mtu = 0;
                etherencapcfg {
Receiver/TV:
  • Vu+ Duo² 4xS2+2xC / OpenATV 6.1@Samsung 50" Plasma
  • AX Quadbox HD2400 2xS2+2xC / OpenATV 6.1@Samsung 32" TFT
  • 2xVu+ Solo² / OpenATV 6.1
  • DVBSky S2-Twin PCIe@SyncMaster T240HD (PC)
  • TechniSat SkyStar HD2@17" (2.PC)
Pay-TV: Schwarzfunk, Redlight Elite Superchic, SCT 10, HD-, Sky
Fon: VF Komfort-Classic (ISDN), 2xFritz!Fon C4+Siedle DoorCom Analog@F!B 7390
Internet: UM 1play 100 / Cisco EPC3212+Linksys WRT1900ACS / IPv4 (UM) + IPv6 (HE)
Bild

Fabricio75
Kabelneuling
Beiträge: 12
Registriert: 03.11.2014, 16:19

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von Fabricio75 » 16.03.2015, 14:18

Danke zunächst mal für eurer Erläuterungen.

Also ich fasse nochmal zusammen (bei 200er Leitung mit 6490):

1. IPV4 MTU ist bei 1472 bzw. 1500 (inkl.)

2. IPV6 MTU mit SIXXS Tunnel aktiv liegt bei max. 1232, also viel zu niedrig. Das Minimum bei SIXXS ist mit 1280 angegeben. Frage ist woher kommt das. Mit der 6360 und der 100er Leitung hat es wunderbar funktioniert.

3. Ich kann die Änderungen in der Export nicht hochladen, egal ob ich es mit Notepad++ oder dem FBEditor mache.
Bild

Benutzeravatar
Andreas1969
Network Operation Center
Beiträge: 7974
Registriert: 05.03.2015, 07:50
Wohnort: Unitymedia NRW

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von Andreas1969 » 19.03.2015, 06:19

Und wie weiter ?

Keine Ideen mehr?
Denken gehört zu den schwersten Dingen, die man tun kann. Vielleicht ist das der Grund, warum es so Wenige tun. :kratz:
Bild
Alle sagten: Es geht nicht. Da kam einer, der das nicht wusste und tat es einfach. :D

Antworten

Wer ist online?

Mitglieder in diesem Forum: UHeinz13 und 3 Gäste