ipv6 Tunnel an ipv4 Anschluss - langsam

In vielen Netzen von Unitymedia sind Internet und Telefonie bereits verfügbar.
Forumsregeln
  • Kunden aus Hessen und Nordrhein-Westfalen können über die Rufnummer 0221 / 466 191 00 Hilfe bei allen Problemen in Anspruch nehmen.
  • Kunden aus Baden-Württemberg können über die Rufnummer 0711 / 54 888 150 Hilfe bei allen Problemen in Anspruch nehmen.
GoaSkin
Glasfaserstrecke
Beiträge: 1200
Registriert: 12.12.2009, 16:25

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von GoaSkin » 14.02.2015, 01:17

Ich habe meine Zweifel, ob die Fritzboxen für 6-to-4 nicht sowieso heimlich die Pakete erst einmal zu Hurricane Electric schicken. Das sieht mir hier nicht so aus, als ist Hurricane Electric der Erste, der sich anbietet, sondern dass die Pakete gezielt wohin gehen, was garnicht auf dem Weg liegt. :

Traceroute auf google.com von einem IPv4-Privatkundenanschluss mit 6-to-4:

Code: Alles auswählen

 1  fritz.box (2002:affe:d00f:0:1234:cafe:cal7:1111)  0.990 ms  1.386 ms  1.313 ms
 2  2002:dada:dada::1 (2002:dada:dada::1)  11.868 ms  12.086 ms  11.652 ms
 3  10gigabitethernet6.switch2.fra1.he.net (2001:470:0:150::1)  11.228 ms  10.964 ms  15.122 ms
 4  de-cix20.net.google.com (2001:7f8::3b41:0:2)  14.864 ms  14.601 ms  14.330 ms
 5  2001:4860::1:0:4ca2 (2001:4860::1:0:4ca2)  14.482 ms  14.173 ms *
 6  * 2001:4860:0:1::2cf (2001:4860:0:1::2cf)  11.053 ms  11.824 ms
 7  2a00:1450:4001:80c::7 (2a00:1450:4001:80c::7)  14.686 ms  12.907 ms  13.696 ms
Und mit DS-Lite:

Code: Alles auswählen

 1  fritz.box  1.028 ms  0.747 ms  0.925 ms
 2  ph-7111a-ubr10k-03-bu1.fra.unity-media.net  17.579 ms  15.519 ms  12.034 ms
 3  de-fra04a-ra1-ae10-1030.fra.unity-media.net  35.915 ms  13.360 ms  11.652 ms
 4  2001:730:2d00::5474:8066  10.055 ms  12.080 ms  10.650 ms
 5  7111a-mx960-01.fra.unity-media.net  9.545 ms  10.677 ms  18.355 ms
 6  7111a-mx960-02.fra.unity-media.net  12.332 ms  31.011 ms  24.290 ms
 7  2001:4860:1:1:0:5159::  15.705 ms  19.011 ms  9.961 ms
 8  2001:4860::1:0:70c3  18.343 ms  17.380 ms  11.675 ms
 9  2001:4860:0:1::6d9  11.596 ms  12.665 ms  18.468 ms
10  2a00:1450:4001:805::3  11.725 ms  9.697 ms *
Bei uns in der Firma (Business Anschluss mit CISCO) ist he.net nicht im Spiel.
Es gibt drei Fleischsorten: Beef, Chicken und Veggie. Von welchem Tier die kommen? Von garkeinem, sondern aus der Packung.

hasselholz
Kabelneuling
Beiträge: 12
Registriert: 12.02.2015, 07:05

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von hasselholz » 15.02.2015, 19:32

Ich hab noch mal hin und her probiert und komme nicht weiter. Ich behaupte mal, dass Namensauflösung und Adressvergabe OK sind. PINGs gehen (bis 1280 MTU Größe zumindest) auch problemlos durch. Ein Traceroute auf einem Windows Client sieht so aus:

Routenverfolgung zu ipv6.l.google.com [2a00:1450:4001:803::1008] über maximal 30 Hops:

1 * * * Zeitüberschreitung der Anforderung.
2 50 ms 31 ms 22 ms gw-7149.cgn-01.de.sixxs.net [2001:4dd0:ff00:1bec::1]
3 25 ms 22 ms 32 ms 2001:4dd0:1234:3::42
4 22 ms 19 ms 18 ms core-eup2-ge1-22.netcologne.de [2001:4dd0:1234:3:dc40::a]
5 27 ms 17 ms 18 ms core-eup2-vl503.netcologne.de [2001:4dd0:a2b:37:dc40::c]
6 35 ms 25 ms 31 ms 2001:4dd0:a2b:a8:30::b
7 * * * Zeitüberschreitung der Anforderung.
8 27 ms 28 ms 28 ms 2001:4860::1:0:87ab
9 60 ms 28 ms 26 ms 2001:4860::8:0:51a0
10 29 ms 36 ms 39 ms 2001:4860::8:0:5039
11 35 ms 27 ms 32 ms 2001:4860::1:0:70c3
12 40 ms 48 ms 34 ms 2001:4860:0:1::6d5
13 30 ms 29 ms 33 ms fra07s30-in-x08.1e100.net [2a00:1450:4001:803::1008]
Ablaufverfolgung beendet

Der Aufruf von Seiten im Browser, die IPV6 only sind schlägt aber fehl. Seiten, die Dualstack sind (z.B. google.de, mobile.de oder facebook.com) sind extrem langsam. Reine IPV4 Seiten laufen mit guter Geschwindigkeit.

Ich habe den Verdacht, dass die Fritzbox die für den IPv6 Verkehr gesetzte MTU von 1280 ignoriert. Hat jemand noch ne Idee, wie ich dem Problem auf den Grund gehen könnte?

hasselholz
Kabelneuling
Beiträge: 12
Registriert: 12.02.2015, 07:05

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von hasselholz » 22.02.2015, 20:44

nachdem alles probieren in der letzten Woche nix half, hab ich nun heute ein Ticket bei Unitymedia aufgemacht. Der erste Mitarbeiter an der Hotline sagte erst, es sei normal, wenn IPv6 langsamer ist :confused:, dann später meinte er, das läge daran, dass die Gegenstelle kein IPv6 könne :kratz: (aha, ipv6.google.com kann also kein ipv6) ... Als ich dann darauf hinwies, dass das ja wohl nicht sein könne, war lange Zeit Stille und dann war auf einmal das Gespräch weg ...

Zweiter Anruf - diesmal meinte der freundliche Mitarbeiter, dass er mir nicht helfen könne, da das "System gerade spinnt" und versprach mir einen Rückruf innerhalb des nächsten Tages. Da bin ich nun mal gespannt und werde berichten, wie es weiter geht.

hasselholz
Kabelneuling
Beiträge: 12
Registriert: 12.02.2015, 07:05

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von hasselholz » 25.02.2015, 00:01

2 Tage und kein Rückruf von Unitymedia. Ich habe nun ein Online Störungsticket eröffnet. Mal sehen, ob das jemand liest und antwortet.

Benutzeravatar
rambus
Übergabepunkt
Beiträge: 293
Registriert: 26.06.2008, 21:51

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von rambus » 25.02.2015, 01:41

Kann mir Jemand sagen, ob diese Werte "gut" sind?

Test mit IPv4 DNS Eintrag
Okay (0.827s) verwende ipv4

Test mit IPv6 DNS Eintrag
Okay (0.797s) verwende ipv6 6to4

Test mit Dual Stack DNS Eintrag
Okay (0.786s) verwende ipv4

Test mit Dual Stack und grosse Pakete
Okay (0.693s) verwende ipv4

Test IPv4 ohne DNS
Okay (0.452s) verwende ipv4

Test IPv6 ohne DNS
Okay (0.460s) verwende ipv6 6to4

Test grosse IPv6 Pakete
Okay (1.141s) verwende ipv6 6to4

Test ob der DNS server des ISP IPv6 unterstützt
Okay (0.865s) verwende ipv4

IPv4-Dienstleister finden
Okay (0.889s) verwende ipv4 ASN 20825

IPv6-Dienstleister finden
Okay (0.823s) verwende ipv6 6to4

rambus
Bild
400 Fly *HD-Recorder* C+ Modul* Fritzbox 6490 * FritzBox 7490* FritzBox 7390*
LG BP 620 3D * Toshiba 47M7463DG * Panasonic 5.1 mit Canton Sytem * Apple TV 3 * AMAZON Fire-Stick *

hasselholz
Kabelneuling
Beiträge: 12
Registriert: 12.02.2015, 07:05

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von hasselholz » 25.02.2015, 22:56

ich habe bei IPv6 Werte zwischen 10-20 sec. für große Pakete - und das bei einer 200Mbit Verbindung. IPv4 Werte sind ähnlich bei mir.

Der Unitymedia Support hat mir übrigens heute schriftlich geantwortet. Leider mit einer standardisierten Antwort - die meine Frage überhaupt nicht beantwortet. Ich hatte mein Problem mit einem 6to4 Tunnel bei fester IPV4 Adresse geschildert. Als Antwort erhalten habe ich eine Aussage, dass Unitymedia jetzt IPv6 mit DS-Lite Technik anbietet und man darüber problemlos IPv4 Tunnel (als 4to6) fahren könne. Also genau umgekehrt, wie ich es angefragt hatte. Jetzt werde ich wohl noch ein weiteres Mal da anrufen müssen in der Hoffnung, dass mich dort jemand versteht.

Benutzeravatar
SpaceRat
Glasfaserstrecke
Beiträge: 2467
Registriert: 08.05.2010, 01:30
Wohnort: Kreis Aachen
Kontaktdaten:

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von SpaceRat » 26.02.2015, 00:23

hasselholz hat geschrieben:in der Hoffnung, dass mich dort jemand versteht.
Bild

Fabricio75
Kabelneuling
Beiträge: 12
Registriert: 03.11.2014, 16:19

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von Fabricio75 » 27.02.2015, 14:36

hasselholz hat geschrieben:Hallo zusammen,

ich habe seit einigen Tagen den 2play200 Tarif mit der Fritzbox 6490 (klassischer ipv4 Anschluss, kein DS-Lite). Ich wollte mich nun aus beruflichen Gründen einmal näher mit dem Thema IPV6 auseinandersetzen und habe daher die verschiedenen ipv6 Tunneloptionen der Fritzbox ausprobiert. Probiert habe ich

- 6to4
- Sixxss Tunnel (habe mich bei Sieh's ordnungsgemäß angemeldet und einen Tunnel via NetCologne geschaltet bekommen)
- 6in4 (via Tunnelbroker.net)

Das Einrichten und Aufbau der Tunnel funktionierte in allen Fällen problemlos, die Fritzbox spielt DHCPv6 und verteilt auch brav DHCP und DNS Konfiguration an meine Clients. Was allerdings auffällt, ist dass das Aufrufen von Internetseiten, die im Netz sowohl per ipv4 als auch ip6 erreichbar sind, unfassbar langsam geworden ist (z.B. mobile.de, Facebook.com, google.com). Reine ipv4 Seiten sind weiterhin OK. Tests mit ping6 zeigen eigentlich gute Millisekunden Werte und auch ein nslookup von A und AAAA Adressen ist meiner Meinung nach fehlerfrei.

Ein IPV6 Test via testipv6.com sagt mir, dass ich MTU Probleme hätte. Die MTU habe ich immer auf 1280 belassen (testweise auch mal in Schritten bis 1480 hochgedreht, was aber nichts brachte).

Nun die Frage: Ist eine ipv6 Tunnel über ein ipv4 Netz immer so langsam (und ich sollte das ganze besser vergessen) oder gibt es noch weitere Fehlerquellen?

Danke für Hinweise und Ratschläge
Ich habe genau das gleiche Problem. Kann teilweise bestimmte Seiten wie Google entweder total langsam oder gar nicht erreichen wenn ich den Sixxs Tunnel eingeschaltet habe. Sobald ich die IPV6 Option in der 6490 deaktiviere läuftt alles wie geschmiert. Aufgrund dessen, dass vor der Umstellung (3Play 100 und Fritzbox 6360) der Tunnel ohne Probleme lief und ich nach der Umstellung auf 2 Play 200 und Fritzbox 6490 sowohl manuell eingerichtet habe als auch die Config von der 6360 importiert habe kann es eigentlich nur was mit der Anschlussumstellung auf 200 oder mit der Fritzbox 6490 zu tun haben.
Bild

Fabricio75
Kabelneuling
Beiträge: 12
Registriert: 03.11.2014, 16:19

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von Fabricio75 » 01.03.2015, 09:32

Hallo zusammen,

würde sich bitte jemand der einen 200er Anschluss mit Fritzbox 6490, IPV4 und einem Sixxs Tunnel problemlos betreibt bitte die Mühe machen und von folgenden Einstellungen Screenshots posten (natürlich ohne jegliche Adressen, Zugangsdaten etc.):

- Heimnetz > Netzwerkeinstellungen > Bereich "Weitere IPv6-Router im Heimnetzwerk"
- Heimnetz > Netzwerkeinstellungen > IPV6 Adressen
- Internet > Zugangsart > IPV6
- Teredo Filter aktiv/inativ

Ich möchte dieses Problem gern irgendwie lösen und mir fehlen jegliche Ansätze. Alles was ich bisher dazu gefunden habe half mir nicht, zumal genau die Einstellungen mit dem 100er Anschluss und der 6360 problemlos funktioniert haben. Das Problem ist absolut reproduzierbar indem ich Google oder Facebook aufrufe sobald der Sixxs Tunnel aktiv ist. Mit der normalen 6to4 Fritzbox Einstellung ohne Zugangsdaten besteht das Problem nicht.

Vielen Dank im Voraus.
Bild

Benutzeravatar
Andreas1969
Network Operation Center
Beiträge: 7997
Registriert: 05.03.2015, 07:50
Wohnort: Unitymedia NRW

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von Andreas1969 » 05.03.2015, 10:14

Habe genau das gleiche Problem mit dem Sixxs-Tunnel.
Läuft auf der 6490 mit 200er Tarif nicht. Seiten sind extrem langsam oder nicht mehr erreichbar, desshalb musste ich ihn wieder deaktivieren.
Habe noch 2 weitere Tunnel auf einer 6360 (100er Unitymedia) und einer
7490 (16k Telekom) am laufen. Dort läuft es seit 1 Jahr Störungsfrei.
Vermute, daß es ein Bug in der FW 6.20 der 6490 ist.
Auf der 6360 läuft die FW 6.04 und auf der 7490 die FW 6.25, bei beiden
keine Probleme.
Wäre an einer schnellen Lösung sehr interessiert.
Denken gehört zu den schwersten Dingen, die man tun kann. Vielleicht ist das der Grund, warum es so Wenige tun. :kratz:
Bild
Alle sagten: Es geht nicht. Da kam einer, der das nicht wusste und tat es einfach. :D

Benutzeravatar
SpaceRat
Glasfaserstrecke
Beiträge: 2467
Registriert: 08.05.2010, 01:30
Wohnort: Kreis Aachen
Kontaktdaten:

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von SpaceRat » 05.03.2015, 10:25

Das ist eine echt tolle Wurst ...

Habe nämlich gerade einem Bekannten zu diesem Upgrade auf 200/10 geraten, da er damit unterm Strich ja besser wegkommt als bei 100/10 (Also 100/5+erhöhter Upload).
Und bei genau diesem Bekannten läuft auch so ein SixXS-Tunnel ...

Ich erlaube mir jetzt einfach mal die Prognose, daß Unfähigmedia dieses Problem auch herzlich egal sein wird, solange die eigenen IPv4-only- und DS-lite-Profile laufen. Selbst die Sicherheitslücken in der 6360-Firmware damals waren Unfähigmedia ja kein rasches Update wert, da wird so ein "irrelevantes" Problem mit Sicherheit nicht behoben sobald AVM die Lösung liefert sondern erst "irgendwann" ...
Receiver/TV:
  • Vu+ Duo² 4xS2+2xC / OpenATV 6.1@Samsung 50" Plasma
  • AX Quadbox HD2400 2xS2+2xC / OpenATV 6.1@Samsung 32" TFT
  • 2xVu+ Solo² / OpenATV 6.1
  • DVBSky S2-Twin PCIe@SyncMaster T240HD (PC)
  • TechniSat SkyStar HD2@17" (2.PC)
Pay-TV: Schwarzfunk, Redlight Elite Superchic, SCT 10, HD-, Sky
Fon: VF Komfort-Classic (ISDN), 2xFritz!Fon C4+Siedle DoorCom Analog@F!B 7390
Internet: UM 1play 100 / Cisco EPC3212+Linksys WRT1900ACS / IPv4 (UM) + IPv6 (HE)
Bild

Benutzeravatar
Andreas1969
Network Operation Center
Beiträge: 7997
Registriert: 05.03.2015, 07:50
Wohnort: Unitymedia NRW

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von Andreas1969 » 05.03.2015, 10:47

Nein, kommt er nicht.
Der alte Tarif (40€ für 100/5 + 10€ für 10er Upload + 5€ für Tel. Komfort) = 55€
ist 5 € günstiger, als der neue 200/10 Tarif (55€ für 200/10 + 5€ Tel. Komfort = 60€)

Also sollte er alles so lassen und spart sogar dabei und Sixxs läuft auf der 6360 !!!
Denken gehört zu den schwersten Dingen, die man tun kann. Vielleicht ist das der Grund, warum es so Wenige tun. :kratz:
Bild
Alle sagten: Es geht nicht. Da kam einer, der das nicht wusste und tat es einfach. :D

Benutzeravatar
SpaceRat
Glasfaserstrecke
Beiträge: 2467
Registriert: 08.05.2010, 01:30
Wohnort: Kreis Aachen
Kontaktdaten:

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von SpaceRat » 05.03.2015, 10:56

Andreas1969 hat geschrieben:Nein, kommt er nicht.
Der alte Tarif (40€ für 100/5 + 10€ für 10er Upload + 5€ für Tel. Komfort) = 55€
ist 5 € günstiger, als der neue 200/10 Tarif (55€ für 200/10 + 5€ Tel. Komfort = 60€)
Nachdem Unfähigmedia die Preise schon wieder angehoben hat ...
Man kann ja irgendwie nie alt gegen neu vergleichen, weil neu ständig auch anders ist.

Beim Tarif- und Kündigungshopping wird man aber i.d.R. auch mit Neukundenkonditionen gelockt.
Andreas1969 hat geschrieben:Also sollte er alles so lassen und spart sogar dabei und Sixxs läuft auf der 6360 !!!
Unter den gegebenen Umständen sicher besser.
Receiver/TV:
  • Vu+ Duo² 4xS2+2xC / OpenATV 6.1@Samsung 50" Plasma
  • AX Quadbox HD2400 2xS2+2xC / OpenATV 6.1@Samsung 32" TFT
  • 2xVu+ Solo² / OpenATV 6.1
  • DVBSky S2-Twin PCIe@SyncMaster T240HD (PC)
  • TechniSat SkyStar HD2@17" (2.PC)
Pay-TV: Schwarzfunk, Redlight Elite Superchic, SCT 10, HD-, Sky
Fon: VF Komfort-Classic (ISDN), 2xFritz!Fon C4+Siedle DoorCom Analog@F!B 7390
Internet: UM 1play 100 / Cisco EPC3212+Linksys WRT1900ACS / IPv4 (UM) + IPv6 (HE)
Bild

BadBunny
Kabelneuling
Beiträge: 10
Registriert: 09.05.2012, 20:44

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von BadBunny » 05.03.2015, 17:50

Schließe mich mal der Diskussion an.
Habe das gleiche Phänomen mit 6to4.
Sobald aktiviert, egal ob 6to4 oder SixXS, ist der Anschluss quasi unbenutzbar. Egal ob google, heise etc. Solange IPv6 verwendet wird kann man sich einen Kaffee kochen.
Deaktiviere ich die IPv6 Untertützung ist der Anschluss Einwandfrei.

Mit der 6360 gabs hier keinerlei Probleme.

Schon jemand eine Idee woran es liegen könnte?

christian-b
Kabelneuling
Beiträge: 21
Registriert: 11.06.2008, 16:45

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von christian-b » 05.03.2015, 20:41

Habe das gleiche Problem - scheint m.E. von der MTU her zu kommen, die nicht richtig gesetzt wird oder durch die Fritte, die nicht fragmentiert.
Heisst wohl auf nächstes OS warten :-/

BadBunny
Kabelneuling
Beiträge: 10
Registriert: 09.05.2012, 20:44

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von BadBunny » 06.03.2015, 07:10

christian-b hat geschrieben:Heisst wohl auf nächstes OS warten :-/
Was bei Unitymedia zum Glück nicht lange dauert. :wand: :wand: :wand:

Benutzeravatar
Andreas1969
Network Operation Center
Beiträge: 7997
Registriert: 05.03.2015, 07:50
Wohnort: Unitymedia NRW

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von Andreas1969 » 06.03.2015, 15:41

Ich schätze mal so in 2 Jahren.
Denken gehört zu den schwersten Dingen, die man tun kann. Vielleicht ist das der Grund, warum es so Wenige tun. :kratz:
Bild
Alle sagten: Es geht nicht. Da kam einer, der das nicht wusste und tat es einfach. :D

hasselholz
Kabelneuling
Beiträge: 12
Registriert: 12.02.2015, 07:05

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von hasselholz » 06.03.2015, 19:34

na da bin ich ja froh, dass ich nicht der einzige bin. Ich hab schon gedacht es liegt an mir :wand: Ich hab auch den Verdacht, dass bei der Fritzbox 6490 was mit der MTU daneben läuft. Der Support (ich habs nochmal versucht) konnte natürlich nicht helfen, hat mich auch gar nicht verstanden was ich wollte. Und als ich dann so böse Worte wie MTU, ICMPv6 und PMTU Discovery in den Mund nahm, wurde es ziemlich ruhig am anderen Ende :mussweg:

Ich hab IPv6 erstmal wieder zu den Akten gelegt. Schade, so wird das nie was mit dem neuen Standard ...

JurgenS
erfahrener Kabelkunde
Beiträge: 76
Registriert: 28.03.2010, 12:09

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von JurgenS » 09.03.2015, 11:39

Hallo,
gibt es inzwischen eine Lösung? Ich habe jetzt auch die Fritzbox 6490 und den 200/10'er Tarif.

Meine Symptome sind exakt wie von "hasselholz" am 12.2. auf Seite 1 beschrieben.
Adresszuteilung, Routing und eingehender wie ausgehender Ping etc. funktionieren tadellos. Ping mit einer Pufferlänge bis 1232 funktioniert auch. Ab einer Pufferlänge von 1233 geht bei Ping gar nichts mehr.

Falls einer von Euch etwas herausgefunden hat oder noch herausfinden sollte dann bitte kurz hier melden.

Danke
Jürgen
Bild

Benutzeravatar
SpaceRat
Glasfaserstrecke
Beiträge: 2467
Registriert: 08.05.2010, 01:30
Wohnort: Kreis Aachen
Kontaktdaten:

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von SpaceRat » 09.03.2015, 12:03

Ihr könntet ja mal - unter Linux - folgendes ausprobieren:

Code: Alles auswählen

i=1360; while ping -s $i -M do -nc1 82.135.16.28 >/dev/null; do i=$((i+1)); done; echo $((i-1+8))
Von dem Wert, der da rauskommt. wären für einen 6in4-Tunnel incl. SixXS-Tunnel 20 Bytes abzuziehen.

Möglicherweise ist ja die IPv4-MTU bereits reduziert und jede gängige MTU für den 6in4-Tunnel damit zu groß?
Notfalls wäre die MTU für den Tunnel dann halt auf 1232 Bytes anzupassen, wobei mich eine MTU von 1252 für die IPv4-Verbindung schon erstaunen würde ...
Receiver/TV:
  • Vu+ Duo² 4xS2+2xC / OpenATV 6.1@Samsung 50" Plasma
  • AX Quadbox HD2400 2xS2+2xC / OpenATV 6.1@Samsung 32" TFT
  • 2xVu+ Solo² / OpenATV 6.1
  • DVBSky S2-Twin PCIe@SyncMaster T240HD (PC)
  • TechniSat SkyStar HD2@17" (2.PC)
Pay-TV: Schwarzfunk, Redlight Elite Superchic, SCT 10, HD-, Sky
Fon: VF Komfort-Classic (ISDN), 2xFritz!Fon C4+Siedle DoorCom Analog@F!B 7390
Internet: UM 1play 100 / Cisco EPC3212+Linksys WRT1900ACS / IPv4 (UM) + IPv6 (HE)
Bild

JurgenS
erfahrener Kabelkunde
Beiträge: 76
Registriert: 28.03.2010, 12:09

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von JurgenS » 09.03.2015, 12:34

SpaceRat hat geschrieben:Ihr könntet ja mal - unter Linux - folgendes ausprobieren:
...
Hallo,
nein soweit war ich gestern auch schon, die ermittelte IPv4 Pufferlänge beträgt z.B. in meinem Fall 1709. Damit gibt es also gar keine Probleme. Die MTU auf 1232 festzulegen geht auch nicht, da IPv6 eine Minimallänge von 1280 vorschreibt. Weder Fritzbox noch SixSX lassen richtigerweise kleinere Werte als 1280 zu.

Ich bin momentan auf einem ganz anderen Dampfer. Unter IPv6 wird nicht mehr fragmentiert. Die Beschränkung der Paketgröße erfolgt durch Verwerfen des Paketes und Senden einer ICMPv6 "Paket zu groß" Nachricht. Der Sender müßte dann neue, kleinere Pakete senden.
Meine Vermutung im Moment: Diese ICMP Pakete werden irgendwo geblockt. Ich konnte sie auf meiner Seite mit Wireshark nie sehen. Das würde erklären warum der ganze Ablauf nicht funktioniert.

Naja,
Jürgen
Bild

Benutzeravatar
SpaceRat
Glasfaserstrecke
Beiträge: 2467
Registriert: 08.05.2010, 01:30
Wohnort: Kreis Aachen
Kontaktdaten:

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von SpaceRat » 09.03.2015, 12:44

JurgenS hat geschrieben:nein soweit war ich gestern auch schon, die ermittelte IPv4 Pufferlänge beträgt z.B. in meinem Fall 1709.
Bei 1709 muß aber was oberfaul sein ...
JurgenS hat geschrieben:Die MTU auf 1232 festzulegen geht auch nicht, da IPv6 eine Minimallänge von 1280 vorschreibt. Weder Fritzbox noch SixSX lassen richtigerweise kleinere Werte als 1280 zu.
Stimmt, das habe ich nicht bedacht.
JurgenS hat geschrieben:Meine Vermutung im Moment: Diese ICMP Pakete werden irgendwo geblockt. Ich konnte sie auf meiner Seite mit Wireshark nie sehen. Das würde erklären warum der ganze Ablauf nicht funktioniert.
Versuch doch aus Jux mal, eine IPv6-Freigabe für den Test-Rechner zu machen und IPv6-Pings (oder auch mal temporär alles) zu erlauben. Vielleicht sind die fehlenden ICMPv6-Geschichten ja versehentlich mit in die Firewall gewandert, obwohl diese eigentlich nie geblockt werden dürften ...
Receiver/TV:
  • Vu+ Duo² 4xS2+2xC / OpenATV 6.1@Samsung 50" Plasma
  • AX Quadbox HD2400 2xS2+2xC / OpenATV 6.1@Samsung 32" TFT
  • 2xVu+ Solo² / OpenATV 6.1
  • DVBSky S2-Twin PCIe@SyncMaster T240HD (PC)
  • TechniSat SkyStar HD2@17" (2.PC)
Pay-TV: Schwarzfunk, Redlight Elite Superchic, SCT 10, HD-, Sky
Fon: VF Komfort-Classic (ISDN), 2xFritz!Fon C4+Siedle DoorCom Analog@F!B 7390
Internet: UM 1play 100 / Cisco EPC3212+Linksys WRT1900ACS / IPv4 (UM) + IPv6 (HE)
Bild

JurgenS
erfahrener Kabelkunde
Beiträge: 76
Registriert: 28.03.2010, 12:09

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von JurgenS » 09.03.2015, 13:12

SpaceRat hat geschrieben: Versuch doch aus Jux mal, eine IPv6-Freigabe für den Test-Rechner zu machen und IPv6-Pings (oder auch mal temporär alles) zu erlauben. Vielleicht sind die fehlenden ICMPv6-Geschichten ja versehentlich mit in die Firewall gewandert, obwohl diese eigentlich nie geblockt werden dürften ...
Habe ich gestern auch schon gemacht. Wie in meinem ersten Beitrag geschrieben kommen Pings von außen an meinem HeimServer problemlos an.

Kannst gern auch selber schauen:
Geht: ping6 2a01:198:200:8c0d:20c:29ff:fe6d:19dc
Geht nicht: wget http://[2a01:198:200:8c0d:20c:29ff:fe6d:19dc]/ (Timeout :wut: )

Jürgen
Bild

Benutzeravatar
SpaceRat
Glasfaserstrecke
Beiträge: 2467
Registriert: 08.05.2010, 01:30
Wohnort: Kreis Aachen
Kontaktdaten:

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von SpaceRat » 09.03.2015, 13:35

JurgenS hat geschrieben:Kannst gern auch selber schauen:
Geht: ping6 2a01:198:200:8c0d:20c:29ff:fe6d:19dc
Yepp.

Und:

Code: Alles auswählen

root@OpenWrt:~# i=1200; while ping6 -s $i -M do -nc1 2a01:198:200:8c0d:20c:29ff:fe6d:19dc >/dev/null; do i=$((i+1)); done; echo $((i-1+8))
1240
Irgendwas an der MTU is verkorkst.

JurgenS
erfahrener Kabelkunde
Beiträge: 76
Registriert: 28.03.2010, 12:09

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitrag von JurgenS » 09.03.2015, 13:48

SpaceRat hat geschrieben: Irgendwas an der MTU is verkorkst.
Naja, das ist doch was hasselholz schon auf Seite 1 schrieb und ich auf Seite 3 bestätigte. Ping6 nur bis Pufferlänge 1232. Dein Script zählt noch 8 dazu und zeigt 1240 an.

Die MTU in Fritzbox und SixXS steht aber momentan auf 1328. Was aber auch egal zu sein scheint. Auch mit 1280 oder 1400 immer dasselbe Verhalten.

:wand: :wand: :wand:
Bild

Antworten

Wer ist online?

Mitglieder in diesem Forum: Benqer, MartinP_Do und 5 Gäste