• Kunden aus Hessen und Nordrhein-Westfalen können über die Rufnummer 0221 / 466 191 00 Hilfe bei allen Problemen in Anspruch nehmen.
    Kunden aus Baden-Württemberg können über die Rufnummer 0711 / 54 888 150 Hilfe bei allen Problemen in Anspruch nehmen.

TC4400 Hardware Hacks

Diskutiere TC4400 Hardware Hacks im Internet und Telefon über das TV-Kabelnetz Forum im Bereich Internet und Telefon bei Unitymedia; Hier mal ein Thread um alles rund ums Hardware-Hacking für das TC4400 zusammenzufassen.

noctarius

Beiträge
142
Reaktionen
0
Hier mal ein Thread um alles rund ums Hardware-Hacking für das TC4400 zusammenzufassen.
 

noctarius

Beiträge
142
Reaktionen
0
Und ich hab gerade RG1 bestückt, was schwer ging, da das Rastermaß kleiner als 2,54mm ist.. Da ich nichts anderes da hatte, musste ich also mit einem Skalpel zuschneiden.. nur bei "BBS" ist er 2,54mm.

Wie dem auch sei: RG1 schweigt bei mir. :kratz:
Hast mal gemessen, ob da überhaupt was anliegt? Vielleicht Pin-Reihenfolge anders? Und was ist mit RG_1 und CM? ;)
 

sch4kal

Beiträge
882
Reaktionen
7
RG_1 ist der UART des Bootloaders, gibt allerdings nicht viel zu sehen.

Hier der Beitrag von y0r
Ich habe gute und schlechte Nachrichten! ;)
Die gute: Ich habe das serielle Interface gefunden.
Die schlechte: getty wird wohl nach dem Kernelboot deaktiviert.
Standardmäßig ist als Geschwindigkeit 115200 aktiv. Natürlich habe ich auch andere ausprobiert nachdem keine Meldungen mehr erschienen, was aber nichts half.
GND ist Pin 2, RX, 3 und TX 4 von RG1. (von rechts gelesen)
Was CM ist weiß ich nicht. RG2 könnte vielleicht noch interessant sein. Da dort jedoch kein Stecker aufgelötet war, habe ich es dann gelassen.

Andreas, vielleicht willst du...? ;)

Fotos: https://imgur.com/a/7kBAt

PS: Ohne zu fluchen lässt sich das Ding nicht öffnen. Furchtbar! Das Siegel lässt sich jedoch wunderbar mit einem Fön und Pinzette/Teppichmesser entfernen und wieder anbringen.
 

noctarius

Beiträge
142
Reaktionen
0
RG_1 ist der UART des Bootloaders, gibt allerdings nicht viel zu sehen.
Naja geht so. Hat da schon wer geschaut wegen Commands um ein anderes Firmware Image aufzuspielen? Hat der einen Custom Bootloader? Ist es ein UBoot Derivat? Läuft das nicht in einem Hypervisor, dann ist auf RG_1 vielleicht mehr als nur der reine Bootloader :)

Disclaimer: Alles nur Vermutungen meinerseits, hab meine TC4400 ja noch nicht! :D
 

sch4kal

Beiträge
882
Reaktionen
7
RG_1 ist der UART des Bootloaders, gibt allerdings nicht viel zu sehen.
Naja geht so. Hat da schon wer geschaut wegen Commands um ein anderes Firmware Image aufzuspielen? Hat der einen Custom Bootloader? Ist es ein UBoot Derivat? Läuft das nicht in einem Hypervisor, dann ist auf RG_1 vielleicht mehr als nur der reine Bootloader :)

Disclaimer: Alles nur Vermutungen meinerseits, hab meine TC4400 ja noch nicht! :D
Siehe oben
 
der-tim

der-tim

Beiträge
141
Reaktionen
0
Gemessen hatte ich vorher, Spannung lief, hab das gerade noch mal geprüft, und ja, ist auch mit der Steckerleiste noch so.
Mit der Verkabelung habe ich auch bereits gespielt, ohne Erfolg.

RG_1 ist noch nicht bestückt, CM ist bisher nur freigelegt (also das Lötzinn, das ab Werk dran ist, ist entfernt).

Generell ist das extrem Mühselig erst mal das Lötzinn rauszukriegen. Mit Sauger und 30W Ersa Lötkolben hab ich für die zwei Ports gefühlt ewig gebraucht. Deswegen habe ich RG_1 bis jetzt auch in Ruhe gelassen..
 
Andreas1969

Andreas1969

Beiträge
16.175
Reaktionen
80
Ich bin ja immer noch der Meinung, dass das Einlöten der USB Buchse zum Erfolg führt.
Wenn ich das in der FW richtig deute, flasht das TC4400 die FW vom Stick automatisch.
 

noctarius

Beiträge
142
Reaktionen
0
Falls es bis dahin keiner gemacht hat, ich denke ich hab noch eine passende rumliegen und würde die dann einlöten, wenn mein Modem da ist :)

Andernfalls mal Hacker-Treff bei Conrad in DUS ;-)
 
der-tim

der-tim

Beiträge
141
Reaktionen
0
@noctarius: das könnte man tatsächlich mal machen, aber beim Conrad? :D
Bei mir hörts an diesem Punkt ehrlich gesagt auf, ich glaube halt, dass mein Board nackter ist, als der Vergleich:

Als Beispiel an RG_1 der bei mir ja auch nichts ausspuckt:
y0r: https://i.imgur.com/YjGk2GL.jpg
meins: https://i.imgur.com/hNiC6EQ.jpg
 

noctarius

Beiträge
142
Reaktionen
0
Bei Conrad nur, weil ich da eh was abholen muss ;-)

Ist doch beiden Boards nichts drauf? Nur bei y0r war vermutlich mal was eingelötet oder vorgesehen (zu dem Zeitpunkt), daher keine blanken Lötpunkte.
 
der-tim

der-tim

Beiträge
141
Reaktionen
0
Wie gesagt, ich bin ab dem Punkt auch etwas ratlos :/ Es macht mir bloß den Eindruck.

Vielleicht kann ich mich später noch mal aufraffen und setze mich an RG_1 und CM, vermutlich werde ich dann aber faul sein und die Kabel direkt von oben aufsetzen.
 

noctarius

Beiträge
142
Reaktionen
0
Meistens fehlt bei sowas nur die Buchse. Ich hatte erst ganz wenige Geräte wo sämtliche Teile dahinter fehlten. Einfach schon, weil die eventuell irgendwann eine neue Zertifizierung brauchst. Mit der fehlenden Buchse hast du relativ viele Leute schon abgehangen (gerade bei SMT). Ich hoffe das mein Modem morgen kommt, dann kann ich mal schauen :)
 

y0r

Beiträge
259
Reaktionen
1
Meistens fehlt bei sowas nur die Buchse. Ich hatte erst ganz wenige Geräte wo sämtliche Teile dahinter fehlten. Einfach schon, weil die eventuell irgendwann eine neue Zertifizierung brauchst. Mit der fehlenden Buchse hast du relativ viele Leute schon abgehangen (gerade bei SMT). Ich hoffe das mein Modem morgen kommt, dann kann ich mal schauen :)
Möchte deine Euphorie nicht bremsen aber schau dir mal die Pads hinter der Einbaustelle neben den RJ45 Buchsen an.
 

noctarius

Beiträge
142
Reaktionen
0
Mähhh du könntest Recht haben ... wer tut sowas? oO
 
0rko

0rko

Beiträge
94
Reaktionen
1
Ich glaube ihr habt die falschen Pins im Blick.
 

Anhänge

noctarius

Beiträge
142
Reaktionen
0
Interessant, dass da bei die ein Micro-USB Port aufgelötet ist. Ich hätte jetzt auch die freien Pads zum Gehäuse hin versucht, aber stimmt USB hat ja nur 4 (bzw 5) Kontakte. Ist dann vermutlich ein weiterer Ethernet Port oder so. Den SMD Micro-USB löten wird pfui ;-)

Hast du mal versucht, was passiert wenn du den USB Anschluss an den PC steckst?
 
0rko

0rko

Beiträge
94
Reaktionen
1
Das habe ich nicht versucht. Er dient als Host und nicht als Client. Der Port dient dazu, den USB Speicherstick (Inhalt: Linux-Kernel, Init-Scripts, Firmware-Files (CM, RG)) anzuschließen. Also einfach nur das normale Firmware-File auf den USB Speicherstick ablegen hilft nicht.

An den korrekten Linux-Kernel komme ich nicht ran. :( Dann könnte man sich ganz einfach einen Boot-Stick für das Firmware-Update erstellen.
 

noctarius

Beiträge
142
Reaktionen
0
Wie ich feststellen muss ist das Problem auch fast eher eine passende Buchse zu finden :(
 

y0r

Beiträge
259
Reaktionen
1
Bekommst du den nicht aus dem IMG/BIN File extrahiert? AFAIK ist es nur signiert aber nicht verschlüsselt?!
 

noctarius

Beiträge
142
Reaktionen
0
Selbst wenn du so eine Buchse nicht findest, könntest du auch die Drähtchen anlöten und eine x beliebige Buchse anbringen und diese ans Gehäuse montieren. Dann müsstest bei zukünftigen Updates nicht einmal mehr die Kiste öffnen.
Jo kann man, dann würde ich aber eher direkt ein USB-Kabel anlöten :) (sowas hier https://www.voelkner.de/products/968487/BKL-Electronic-USB-A-Kupplung-2.0-mit-offenem-Kabelende-Kupplung-gerade-USB-A-Kupplung-2.0-Inhalt.html)
 
0rko

0rko

Beiträge
94
Reaktionen
1
Wie ich feststellen muss ist das Problem auch fast eher eine passende Buchse zu finden :(
Das kommt dem Bauteil am nächsten:

https://de.aliexpress.com/item/1000pcs-lot-Connector-Mini-USB-Plug-B-Type-SMT-Male-Connector-Port-90-Degree-Mini-USB/32340065871.html

Die Kontakte dann um 90grad biegen und die 'Masse-Ohren' mit der Zange kürzen.
Bekommst du den nicht aus dem IMG/BIN File extrahiert? AFAIK ist es nur signiert aber nicht verschlüsselt?!
Nein, der passt nicht.

Ich glaube ein READ/WRITE über den SPI-Flash-Baustein könnte da einfacher sein.
 
Thema:

TC4400 Hardware Hacks

TC4400 Hardware Hacks - Ähnliche Themen

  • Technicolor TC4400 - 1 Mbit/s Downloadgeschwindigkeit statt 400

    Technicolor TC4400 - 1 Mbit/s Downloadgeschwindigkeit statt 400: Hallo, Aufgrund hoher und instabiler Latenzzeiten (20 bis 100 ms) habe ich den ConnectBox durch TC4400 heute ersetzt. Das TC4400 habe ich über...
  • TC4400 DS-Lite Firmware Bug wie möglich?

    TC4400 DS-Lite Firmware Bug wie möglich?: Hallo, ich habe hier mehrfach von einem Bug in der Firmware des TC4400 gelesen, dass DS-Lite beeinträchtigt, aber keine Beschreibung dazu finden...
  • vodafone Kabel mit TC4400 aktivieren

    vodafone Kabel mit TC4400 aktivieren: Hallo, ich hab' mir ein technicolor TC4400 besorgt und bekomme das bei Vodafone nicht aktiviert. Die Aktivierungsseite lädt, ich kann...
  • Offline - lt. Techniker angeblich TC4400 kaputt

    Offline - lt. Techniker angeblich TC4400 kaputt: Hallo Community, schön bei Euch zu sein! Ich hoffe ihr könnt mir helfen! Ich muss leider kurz ausholen mit meiner Geschichte... Ich betreibe...
  • Provisionierung TC4400

    Provisionierung TC4400: Hallo Heute ist mein TC4400 angekommen und da wollte ich es natürlich gleich provisionieren lassen. Also schnell die UM angerufen. Auskunft dort...
  • Provisionierung TC4400 - Ähnliche Themen

  • Technicolor TC4400 - 1 Mbit/s Downloadgeschwindigkeit statt 400

    Technicolor TC4400 - 1 Mbit/s Downloadgeschwindigkeit statt 400: Hallo, Aufgrund hoher und instabiler Latenzzeiten (20 bis 100 ms) habe ich den ConnectBox durch TC4400 heute ersetzt. Das TC4400 habe ich über...
  • TC4400 DS-Lite Firmware Bug wie möglich?

    TC4400 DS-Lite Firmware Bug wie möglich?: Hallo, ich habe hier mehrfach von einem Bug in der Firmware des TC4400 gelesen, dass DS-Lite beeinträchtigt, aber keine Beschreibung dazu finden...
  • vodafone Kabel mit TC4400 aktivieren

    vodafone Kabel mit TC4400 aktivieren: Hallo, ich hab' mir ein technicolor TC4400 besorgt und bekomme das bei Vodafone nicht aktiviert. Die Aktivierungsseite lädt, ich kann...
  • Offline - lt. Techniker angeblich TC4400 kaputt

    Offline - lt. Techniker angeblich TC4400 kaputt: Hallo Community, schön bei Euch zu sein! Ich hoffe ihr könnt mir helfen! Ich muss leider kurz ausholen mit meiner Geschichte... Ich betreibe...
  • Provisionierung TC4400

    Provisionierung TC4400: Hallo Heute ist mein TC4400 angekommen und da wollte ich es natürlich gleich provisionieren lassen. Also schnell die UM angerufen. Auskunft dort...