- Anzeige -

TC7200: mDNS/Bonjour/AirPlay geht nicht von WiFi zu Ethernet

Alles über DOCSIS 3.0

TC7200: mDNS/Bonjour/AirPlay geht nicht von WiFi zu Ethernet

Beitragvon jomo » 26.10.2014, 18:36

Hallo!

Ich habe das Technicolor TC7200. Daran angeschlossen (per Ethernet) ein RaspberryPi und ein Laptop im WiFi.
Ich versuche jetzt, Musik vom Laptop via AirPlay and das RasPi zu streamen.
Leider wird mir das RasPi allerdings nur dann im AirPlay Menü angezeigt, wenn das Laptop ebenfalls im Ethernet ist.

Ich habe mich mal schlau gemacht:
- AirPlay benutzt zum Erkennen der AirPlay Geräte Bonjour.
- Bonjour wiederum basiert auf mDNS bzw DNS-SD.
- AirPlay verwendet für AirPlay das Protokoll RAOP
- AirPlay Geräte werden unter der domain _raop._tcp. eingetragen

Wenn das Laptop im Ethernet sieht das ganze so aus:
Code: Alles auswählen
$ dns-sd -B _raop._tcp

Browsing for _raop._tcp.
DATE: ---Sun 26 Oct 2014---
17:17:36.916  ...STARTING...
Timestamp     A/R    Flags  if Domain               Service Type         Instance Name
17:17:36.917  Add        2   6 local.               _raop._tcp.          0A2C1CC242BA@Raspi

Bild

Sobald ich im Wlan bin, ist da nix zu sehen.
Sowohl das Laptop als auch das RasPi sind im selben Subnet und haben die selbe Broadcast IP.
Laptop:
Code: Alles auswählen
en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
   ether 58:b0:35:62:7a:ab
   inet6 fe80::5ab0:35ff:fe62:7aab%en1 prefixlen 64 scopeid 0x6
   inet6 private:7aab prefixlen 64 dynamic
   inet6 private:b36 prefixlen 64 autoconf temporary
   inet 192.168.0.15 netmask 0xffffff00 broadcast 192.168.0.255
   nd6 options=1<PERFORMNUD>
   media: autoselect
   status: active

RasPi:
Code: Alles auswählen
eth0      Link encap:Ethernet  HWaddr b8:27:eb:5c:86:20
          inet addr:192.168.0.99  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: private:8620/64 Scope:Global
          inet6 addr: fe80::ba27:ebff:fe5c:8620/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1



Ich kann das RasPi auch vom Laptop aus erreichen und anders herum, nur mDNS scheint da nicht zu funktionieren.

Aus Wikipedia:
The mDNS Ethernet frame is a multicast UDP packet to:

MAC address 01:00:5E:00:00:FB (for IPv4) or 33:33:00:00:00:FB (for IPv6)
IPv4 address 224.0.0.251 or IPv6 address FF02::FB
UDP port 5353


Hat hier jemand eine Idee, warum mDNS nicht zwischen Ethernet und WiFi zu funktionieren scheint?
Das Problem ist wohl nicht unbekannt, allerdings war das Problem wohl sonst immer, dass Ethernet und WiFi nicht im selben subnet waren.
Ich suche mich hier schon dumm und dämlich, aber kann einfach nichts finden.

Ich habe auch schon Unitymedia gefragt, aber da kam nur:
Wir sind Ihr ISP und verantwortlich dafür, dass unsere Kd die gebuchte Geschwindigkeit per LAN erhalten. Es tut uns wirklich leid, aber deine Frage überschreitet deutlich unsere Support Grenze.



Danke schonmal für Hilfreiche Vorschläge!
jomo
Kabelneuling
 
Beiträge: 11
Registriert: 26.10.2014, 17:28

Re: TC7200: mDNS/Bonjour/AirPlay geht nicht von WiFi zu Ethe

Beitragvon magruk » 27.10.2014, 10:34

Ich würde (testweise) einen anderen WlAN-Access Point/-Router hinter dem TC7200 anschließen (d.h. diesen nur als Internet Gateway verwenden) und prüfen, ob es damit geht.
UM Anschluss: 200M/20M Triple Play, Telefon Plus
Hardware: AVM Fritz!Box 6490 Cable, Samsung Horizon, AVM Fritz!Fon C4, Apple APX, MikroTik RB751G, Synology DS114, Samsung UE55J6250, Apple TV4

Meine Beiträge sind aus persönlichem Interesse verfasst und geben ausschließlich eigene Meinung wieder. Zitate außerhalb dieses Forums nur mit meiner Genehmigung.
Benutzeravatar
magruk
Kabelexperte
 
Beiträge: 155
Registriert: 07.02.2010, 11:44
Wohnort: Wuppertal, NRW, Germany

Re: TC7200: mDNS/Bonjour/AirPlay geht nicht von WiFi zu Ethe

Beitragvon tq1199 » 27.10.2014, 11:07

jomo hat geschrieben:Sobald ich im Wlan bin, ist da nix zu sehen.
Sowohl das Laptop als auch das RasPi sind im selben Subnet und haben die selbe Broadcast IP.


Schau mal z. B. auf deinem RasPi mit:
Code: Alles auswählen
sudo tcpdump -vvveni any net 224.0.0.0/8 or port 5353 or igmp

, was Du mit und ohne Kabelverbindung beim Laptop, erkennen kannst bzw. angezeigt wird.
Office Internet & Phone 50, AVM FRITZ!Box 6360 Cable (kbw) - FRITZ!OS 06.52 - , an Arris-CMTS, zusätzlich eine feste (statische, nicht per DHCP) IPv4-Adresse für meinen Server, am Bridge-Anschluss (kein Bridge-Modus, FB6360-cable wird ohne feste IPv4-Adresse als Router verwendet.)
Konfigurationsdatei der FritzBox: b2b-staticip1_50000_5000_ipv4_sip_wifi-on.bin
NTP_Provider_Interface_Spec_Unitymedia

AVM - IPv6 technical note
tq1199
Glasfaserstrecke
 
Beiträge: 1265
Registriert: 07.02.2014, 10:05

Re: TC7200: mDNS/Bonjour/AirPlay geht nicht von WiFi zu Ethe

Beitragvon jomo » 27.10.2014, 11:44

magruk hat geschrieben:Ich würde (testweise) einen anderen WlAN-Access Point/-Router hinter dem TC7200 anschließen (d.h. diesen nur als Internet Gateway verwenden) und prüfen, ob es damit geht.


Ist sogar momentan der Fall. Der Wlan AP ist per Ethernet an den Router angeschlossen. Wenn ich mich damit verbinde geht es ohne Probleme, aber der Empfang ist im Wohnzimmer (wo das RasPi steht) leider schrott.
jomo
Kabelneuling
 
Beiträge: 11
Registriert: 26.10.2014, 17:28

Re: TC7200: mDNS/Bonjour/AirPlay geht nicht von WiFi zu Ethe

Beitragvon jomo » 28.10.2014, 11:50

tq1199 hat geschrieben:
Code: Alles auswählen
sudo tcpdump -vvveni any net 224.0.0.0/8 or port 5353 or igmp



Bin noch nicht dazu gekommen, aber danke schonmal. Werde ich bald testen.
jomo
Kabelneuling
 
Beiträge: 11
Registriert: 26.10.2014, 17:28

Re: TC7200: mDNS/Bonjour/AirPlay geht nicht von WiFi zu Ethe

Beitragvon Ödeldödel » 23.12.2014, 16:28

Hi,

das selbe Problem habe ich aktuell auch.Ohne es hier groß zu erläutern,aber das Problem liegt an UM und deren Tc Endgeräten.

Was hilft, kündigen und zu einem weitaus fortschrittlicheren und kompetenten Anbieter zu wechseln...
Ödeldödel
Kabelneuling
 
Beiträge: 8
Registriert: 23.12.2014, 16:24

Re: TC7200: mDNS/Bonjour/AirPlay geht nicht von WiFi zu Ethe

Beitragvon Dinniz » 23.12.2014, 23:51

Ödeldödel hat geschrieben:Hi,

das selbe Problem habe ich aktuell auch.Ohne es hier groß zu erläutern,aber das Problem liegt an UM und deren Tc Endgeräten.

Was hilft, kündigen und zu einem weitaus fortschrittlicheren und kompetenten Anbieter zu wechseln...

Kommt von dir heute auch noch irgendwas brauchbares oder willst du nur Frust ablassen?
destroying ne3/4 since 2002
Benutzeravatar
Dinniz
Carrier
 
Beiträge: 10368
Registriert: 21.01.2008, 23:43
Wohnort: NRW

Re: TC7200: mDNS/Bonjour/AirPlay geht nicht von WiFi zu Ethe

Beitragvon daskraken » 15.02.2015, 16:29

Bei mir hat es "geholfen", die WMM-Option unter Wireless > Advanced zu deaktivieren, um Airplay zwischen LAN und WiFi wieder ans Laufen zu bekommen. Leider war mein Macbook Pro anschließend nicht mehr bereit, sich per 802.11n zu connecten, da WMM laut Spezifikation dafür erforderlich ist. Da ich nicht mit 802.11b/g Vorlieb nehmen wollte, habe ich in den sauren Apfel gebissen und einen weiteren Router hinter den TC7200 gehangen, der quasi mein LAN-Routing macht - der TC7200 macht nur noch das WAN-Routing. In der Hoffnung, dass jemand irgendwann einen Hack findet, den Bridge-Modus des TC-7200 doch noch nachhaltig zu aktivieren ... :(
daskraken
Kabelneuling
 
Beiträge: 1
Registriert: 15.02.2015, 16:23

Re: TC7200: mDNS/Bonjour/AirPlay geht nicht von WiFi zu Ethe

Beitragvon kaisen » 07.03.2015, 15:39

daskraken hat geschrieben:Bei mir hat es "geholfen", die WMM-Option unter Wireless > Advanced zu deaktivieren, um Airplay zwischen LAN und WiFi wieder ans Laufen zu bekommen. Leider war mein Macbook Pro anschließend nicht mehr bereit, sich per 802.11n zu connecten, da WMM laut Spezifikation dafür erforderlich ist. Da ich nicht mit 802.11b/g Vorlieb nehmen wollte, habe ich in den sauren Apfel gebissen und einen weiteren Router hinter den TC7200 gehangen, der quasi mein LAN-Routing macht - der TC7200 macht nur noch das WAN-Routing. In der Hoffnung, dass jemand irgendwann einen Hack findet, den Bridge-Modus des TC-7200 doch noch nachhaltig zu aktivieren ... :(


Wie hast du das hinbekommen? Ich habe gefühlt alles versucht um meinen alten D-Link Dir-600 irgendwie an das TC 7200 zu bekommen um Airplay etc. wieder konstant nutzen zu können. Das geht scheinbar immer nur sporadisch.
Wäre um jeden Tipp dankbar.
kaisen
Kabelneuling
 
Beiträge: 6
Registriert: 29.08.2011, 21:24

Re: TC7200: mDNS/Bonjour/AirPlay geht nicht von WiFi zu Ethe

Beitragvon jomo » 14.03.2015, 03:07

daskraken hat geschrieben:Bei mir hat es "geholfen", die WMM-Option unter Wireless > Advanced zu deaktivieren


DANKE! :super: :lovingeyes: :super:
Die Lösung: WMM ausschalten.

kaisen hat geschrieben:Wie hast du das hinbekommen?

Die Einstellung findet sich auf dem TC 7200 hier: http://192.168.0.1/wireless/advanced.asp

Sowohl im LAN als auch im WLAN werden Geräte im jeweils anderen Netz gefunden und können auch verwendet werden.
jomo
Kabelneuling
 
Beiträge: 11
Registriert: 26.10.2014, 17:28

Nächste

Zurück zu DOCSIS 3.0 - bis zu 400 Mbit/s

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste