- Anzeige -

Verzögerter Verbindungsaufbau (DNS Problem) mit Ubee Box

In diesem Forum geht es um alle Störungen im Kabelnetz von Unitymedia, egal ob analoges TV und Radio, digitales TV und Radio, Internet oder Telefonie.
Wichtig:
  • Kunden aus Hessen und Nordrhein-Westfalen können über die Rufnummer 0221 / 466 191 00 Hilfe bei allen Problemen in Anspruch nehmen.
  • Kunden aus Baden-Württemberg können über die Rufnummer 0711 / 54 888 150 Hilfe bei allen Problemen in Anspruch nehmen.

Verzögerter Verbindungsaufbau (DNS Problem) mit Ubee Box

Beitragvon mrandt » 02.11.2015, 18:46

Hallo,

ich habe seit dem Wechsel auf neue Modem-Hardware (Ubee Box EVW3226) Probleme mit einem erheblich verzögertem Verbindungsaufbau, insbesondere bei Android-Geräten.

Ursprünglich hatte ich Android in Verdacht, es hat sich aber (auch mit freundlicher Unterstützung durch Techniker von Google) herausgestellt, dass es tatsächlich am Router liegt.

Ursache ist ein Fehler in der Firmware der Ubee Box. Ich habe Unitymedia detaillierte Informationen zum Fehler übermittelt (inklusive meiner Traces) und wiederholt um eine Behebung gebeten, bis jetzt aber ohne Erfolg.

Liest hier jemand mit, der ebenfalls betroffen ist? Vielleicht hilft es, wenn mehrere Kunden eine Behebung anmahnen :-)

== Symptome ==

Die betroffenen Geräte benötigen eine gefühlte Ewigkeit um eine Verbindung zu beliebigen Internetservern über meinen Unitymedia Kabelanschluss herzustellen. Betroffen sind alle Dienste, z.B. das Aufrufen einer Internetseite im Browser oder der Datenabruf von einem WebService durch eine App - jedesmal entsteht eine Pause von mehreren Sekunden.

Beispiel: Ich gebe im Chrome Browser auf meinem Telefon eine Internetadresse ein, während ich zu Hause mit dem WLAN verbunden bin. Jetzt passiert 15 - 30 Sekunden lang gar nichts. Dann wird die Seite plötzlich geladen.

Die Datenübertragung selbst ist relativ schnell, die Vergzögerung entsteht bei der DNS Namensauflösung.

Eine Deaktivierung von IPv6 auf dem Endgerät behebt das Problem vorübergehend, das ist m.E. aber keine gangbare Lösung; außerdem setzt dies bei Android root-Rechte voraus.

== Ursache ==

Ich habe per Netzwerksniffer tcpdump eine Aufzeichnung des Netzwerkverkehrs zwischen Endgerät und Router vorgenommen, die Kommunikation mit Wireshark analysiert und das Problem gefunden. Die Traces liegen Unitymedia auch vor, allerdings habe ich trotz mehrmaliger Nachfrage keine Kommentare dazu oder gar eine Lösung bekommen.

Das der Fehler existiert und die Ubee Box "Schuld" ist, kann ich aber eindeutig belegen. Es passiert (reproduzierbar) folgendes:

1. Der Router (Ubee Box) teilt dem Endgerät (Smartphone) per IMCPv6 Router Advertisment mit, welchen Router und DNS Server dieses verwenden soll (entsprechend RFC-6106).

2. Dabei wird als DNS Server explizit die IPv6 Adresse des Routers (Ubee Box) vorgegeben.

3. Leider - und darin liegt die fehlerhafte Implementierung - reagiert der Router später auf entsprechende DNS Anfragen per IPv6 Protokoll an diese Adresse ÜBERHAUPT NICHT.

4. Nach 30 Sekunden Timeout führt dies logischerweise zu einem "Destination unreachable (Port unreachable)" Fehler. Android fällt dann auf IPv4 zurück - was der Router korrekt beherrscht. Der Verbindungsaufbau klappt dann problemlos.

5. Beim nächsten Versuch (nach etwas Wartezeit oder Sperren des Bildschirms) versucht Android die DNS Auflösung wieder per IPv6 entsprechend der übermittelten Konfiguration (siehe 1. und 2.) und das "Spiel" beginnt von vorn.


Für mich (und vermutlich viele andere Benutzer mit dem o.g. Kabelmodem / Router und modernen Endgeräten) ist die Situation untragbar. Die Verzögerung beim Aufbau von IP-Verbindungen macht den Internetzugang vom Endgerät aus faktisch unbenutzbar.

Ursächlich dafür ist - wie oben dargestellt und anhand der Traces belegbar - die Firmware des Routers, die sich nicht konform zu geltenden Internet- und Netzwerkprotokollen und -standards verhält.

Solange es einen Router Zwang gibt, kann ich das Problem nicht selber lösen sondern bin auf ein Firmware Update von Unitymedia angewiesen.

Alternativ könnte ich natürlich - gegen zusätzliche Grundgebühr - eine AVM FritzBox bekommen, deren IPv6 Stack mutmaßlich besser implementiert wäre. Ich bin aber nicht bereit die Mehrkosten zu zahlen, zumal ich die übrigen Funktionen der FritzBox gar nicht brauche.


Ich gehe davon aus, dass es zu den Vertragspflichten von Unitymedia gehört, mir als Kunde eine Hardware bereitzustellen, die mit gängigen Standards und Protokollen kompatibel ist. Fehler in der Hardware, die zu derart schwerwiegenden Störungen führen, müssten folglich auch behoben werden. Ich wäre auch schon zufrieden, wenn man mir (ohne Mehrkosten) eine andere, funktionierende Hardware anböte.

Schlimmstenfalls muss ich diese Leistungsstörung mit Unitymedia auf dem Rechtsweg oder mit Unterstützung der Fachpresse ausfechten :-(

Wenn ihr ebenfalls betroffen seid, meldet euch bitte.

Danke und beste Grüße
Malte
mrandt
Kabelneuling
 
Beiträge: 6
Registriert: 01.06.2015, 16:06

Zurück zu Störungen im Kabelnetz von Unitymedia

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 14 Gäste