- Anzeige -

KabelBW-Modem + FritzBox: Ports werden nicht geöffnet

In vielen Netzen von Unitymedia sind Internet und Telefonie bereits verfügbar.
Wichtig:
  • Kunden aus Hessen und Nordrhein-Westfalen können über die Rufnummer 0221 / 466 191 00 Hilfe bei allen Problemen in Anspruch nehmen.
  • Kunden aus Baden-Württemberg können über die Rufnummer 0711 / 54 888 150 Hilfe bei allen Problemen in Anspruch nehmen.

Re: KabelBW-Modem + FritzBox: Ports werden nicht geöffnet

Beitragvon Momro » 10.03.2015, 08:58

Hm, aber warum kann ich mich von intern mit dem Port verbinden und von extern nicht? Sollte das Port Forwarding nicht machen, dass es wie ein interner Zugriff "aussieht"?

Rückgabewerte:
Code: Alles auswählen
pi@pi-kodi:~$ ls -la /etc/network/if-up.d/secure-rmc
-rwxr-xr-x 1 root root 2687 Sep  8  2013 /etc/network/if-up.d/secure-rmc
pi@pi-kodi:~$ sudo chmod 644 /etc/network/if-up.d/secure-rmc
pi@pi-kodi:~$ ls -la /etc/network/if-up.d/secure-rmc
-rw-r--r-- 1 root root 2687 Sep  8  2013 /etc/network/if-up.d/secure-rmc


In
Code: Alles auswählen
sudo nano /etc/network/if-up.d/secure-rmc
hab ich gar kein 'exit 0' gefunden. Ein 'exit'-Statement scheint es nur in get_subnet() und in der letzten if-Schleife zu geben, beide sind aber 'exit 0'.

Ist ja alles sehr verworren. Ich kenne mich ja eigentlich mit Firewalls aus, aber nur auf GUI-Ebene und nicht mit den internen Mechanismen von Linux. Da wüsste ich gar nicht, wo ich anfangen sollte. Um nochmal auf meinen Anfang zurückzukommen: Warum sollte es von intern funktionieren, von extern aber nicht? Scheint mir eigentlich erstmal das gleiche zu sein ...
Momro
Kabelneuling
 
Beiträge: 10
Registriert: 27.02.2015, 11:07

Re: KabelBW-Modem + FritzBox: Ports werden nicht geöffnet

Beitragvon tq1199 » 10.03.2015, 09:23

Momro hat geschrieben:... hab ich gar kein 'exit 0' gefunden.


Ja, und deshalb hatte ich (in meinem Beitrag) ja auch "evtl." geschrieben:
... vor einem evtl. "exit 0",


Momro hat geschrieben:Um nochmal auf meinen Anfang zurückzukommen: Warum sollte es von intern funktionieren, von extern aber nicht? Scheint mir eigentlich erstmal das gleiche zu sein ...

Ist es aber nicht:
Code: Alles auswählen
468606 52274650 ACCEPT     all  --  wlan1  *       192.168.0.0/24       0.0.0.0/0           
    1640   385168 DROP       all  --  wlan1  *       0.0.0.0/0            0.0.0.0/0

Du hast eine ACCEPT-Regel, die Alles was aus dem Subnet 192.168.0.0/24 über das input-Interface wlan1 kommt, durchlässt und danach hast Du einen DROP-Regel die Alles (source-net 0.0.0.0/0) was über das input-Interface wlan1 kommt, blockt. Der counter der DROP-Regel (1640 385168) zeigt, dass durch diese Regel auch geblockt wird. Das hat mit der Portweiterleitung nichts zu tun, denn dein Pi weiß trotz Portweiterleitung, wann die Anfragen aus dem Subnet 192.168.0.0/24 kommen und wann das nicht der Fall ist.

EDIT:

BTW: Versuch mal (temporär) im Terminal/Konsole deines Pi, Folgendes:
Code: Alles auswählen
sudo iptables -F && sudo iptables -X

und greife danach von außen auf deinen Pi zu.
Office Internet & Phone 50, AVM FRITZ!Box 6360 Cable (kbw) - FRITZ!OS 06.52 - , an Arris-CMTS, zusätzlich eine feste (statische, nicht per DHCP) IPv4-Adresse für meinen Server, am Bridge-Anschluss (kein Bridge-Modus, FB6360-cable wird ohne feste IPv4-Adresse als Router verwendet.)
Konfigurationsdatei der FritzBox: b2b-staticip1_50000_5000_ipv4_sip_wifi-on.bin
NTP_Provider_Interface_Spec_Unitymedia

AVM - IPv6 technical note
tq1199
Glasfaserstrecke
 
Beiträge: 1265
Registriert: 07.02.2014, 10:05

Re: KabelBW-Modem + FritzBox: Ports werden nicht geöffnet

Beitragvon Momro » 10.03.2015, 10:40

Jetzt geht's :-D Vielen, vielen Dank!

Da weiß ich ja jetzt, worüber ich mich etwas mehr informieren muss :-)

Soll ich da jetzt wieder was einstellen bzgl. DROP-Regeln, oder passt das so? - Weil du geschrieben hattest, ich solle die Chains temporär löschen ...
Momro
Kabelneuling
 
Beiträge: 10
Registriert: 27.02.2015, 11:07

Re: KabelBW-Modem + FritzBox: Ports werden nicht geöffnet

Beitragvon tq1199 » 10.03.2015, 10:55

Momro hat geschrieben: - Weil du geschrieben hattest, ich solle die Chains temporär löschen ...


Ich habe "temporär" geschrieben, weil Du so und jetzt, den durch die standard-Konfiguration deines OS beabsichtigten Schutz nicht (mehr) hast. ... und btw., das was Du jetzt manuell gemacht hast (d. h. "sudo iptables -F && sudo iptables -X") ist nur bis zum nächsten reboot deines Pi wirksam.
Zuletzt geändert von tq1199 am 10.03.2015, 10:57, insgesamt 2-mal geändert.
Office Internet & Phone 50, AVM FRITZ!Box 6360 Cable (kbw) - FRITZ!OS 06.52 - , an Arris-CMTS, zusätzlich eine feste (statische, nicht per DHCP) IPv4-Adresse für meinen Server, am Bridge-Anschluss (kein Bridge-Modus, FB6360-cable wird ohne feste IPv4-Adresse als Router verwendet.)
Konfigurationsdatei der FritzBox: b2b-staticip1_50000_5000_ipv4_sip_wifi-on.bin
NTP_Provider_Interface_Spec_Unitymedia

AVM - IPv6 technical note
tq1199
Glasfaserstrecke
 
Beiträge: 1265
Registriert: 07.02.2014, 10:05

Re: KabelBW-Modem + FritzBox: Ports werden nicht geöffnet

Beitragvon Momro » 10.03.2015, 10:56

Verstehe, verstehe. Ja, dann lese ich mich, wie gesagt, mal ein und schaue, dass ich das wieder richtig in den Griff bekomme. Vielen Dank nochmal!
Momro
Kabelneuling
 
Beiträge: 10
Registriert: 27.02.2015, 11:07

Vorherige

Zurück zu Internet und Telefon über das TV-Kabelnetz

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 39 Gäste