- Anzeige -

ipv6 Tunnel an ipv4 Anschluss - langsam

In vielen Netzen von Unitymedia sind Internet und Telefonie bereits verfügbar.
Wichtig:
  • Kunden aus Hessen und Nordrhein-Westfalen können über die Rufnummer 0221 / 466 191 00 Hilfe bei allen Problemen in Anspruch nehmen.
  • Kunden aus Baden-Württemberg können über die Rufnummer 0711 / 54 888 150 Hilfe bei allen Problemen in Anspruch nehmen.

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitragvon JurgenS » 09.03.2015, 13:34

SpaceRat hat geschrieben:Ihr könntet ja mal - unter Linux - folgendes ausprobieren:
...


Hallo,
nein soweit war ich gestern auch schon, die ermittelte IPv4 Pufferlänge beträgt z.B. in meinem Fall 1709. Damit gibt es also gar keine Probleme. Die MTU auf 1232 festzulegen geht auch nicht, da IPv6 eine Minimallänge von 1280 vorschreibt. Weder Fritzbox noch SixSX lassen richtigerweise kleinere Werte als 1280 zu.

Ich bin momentan auf einem ganz anderen Dampfer. Unter IPv6 wird nicht mehr fragmentiert. Die Beschränkung der Paketgröße erfolgt durch Verwerfen des Paketes und Senden einer ICMPv6 "Paket zu groß" Nachricht. Der Sender müßte dann neue, kleinere Pakete senden.
Meine Vermutung im Moment: Diese ICMP Pakete werden irgendwo geblockt. Ich konnte sie auf meiner Seite mit Wireshark nie sehen. Das würde erklären warum der ganze Ablauf nicht funktioniert.

Naja,
Jürgen
Bild
JurgenS
erfahrener Kabelkunde
 
Beiträge: 73
Registriert: 28.03.2010, 12:09

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitragvon SpaceRat » 09.03.2015, 13:44

JurgenS hat geschrieben:nein soweit war ich gestern auch schon, die ermittelte IPv4 Pufferlänge beträgt z.B. in meinem Fall 1709.

Bei 1709 muß aber was oberfaul sein ...

JurgenS hat geschrieben:Die MTU auf 1232 festzulegen geht auch nicht, da IPv6 eine Minimallänge von 1280 vorschreibt. Weder Fritzbox noch SixSX lassen richtigerweise kleinere Werte als 1280 zu.

Stimmt, das habe ich nicht bedacht.

JurgenS hat geschrieben:Meine Vermutung im Moment: Diese ICMP Pakete werden irgendwo geblockt. Ich konnte sie auf meiner Seite mit Wireshark nie sehen. Das würde erklären warum der ganze Ablauf nicht funktioniert.

Versuch doch aus Jux mal, eine IPv6-Freigabe für den Test-Rechner zu machen und IPv6-Pings (oder auch mal temporär alles) zu erlauben. Vielleicht sind die fehlenden ICMPv6-Geschichten ja versehentlich mit in die Firewall gewandert, obwohl diese eigentlich nie geblockt werden dürften ...
Receiver/TV:
  • Vu+ Duo² 4xS2 / OpenATV 5.3@Samsung 50" Plasma
  • AX Quadbox HD2400 2xS2 / OpenATV 6.0@Samsung 32" TFT
  • 2xVu+ Solo² / OpenATV 6.0
  • DVBSky S2-Twin PCIe@SyncMaster T240HD (PC)
  • TechniSat SkyStar HD2@17" (2.PC)
Pay-TV: Schwarzfunk, Redlight Elite Mega HD, Brazzers, XXL, HD-, Sky
Fon: VF Komfort-Classic (ISDN), Siemens S79H+S1+Telekom Modula+Siedle DoorCom Analog@F!B 7390
Internet: UM 1play 100 / Cisco EPC3212+Linksys WRT1900ACS / IPv4 (UM) + IPv6 (HE)
Bild
Benutzeravatar
SpaceRat
Kabelkopfstation
 
Beiträge: 2619
Registriert: 08.05.2010, 01:30
Wohnort: Kreis Aachen

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitragvon JurgenS » 09.03.2015, 14:12

SpaceRat hat geschrieben:Versuch doch aus Jux mal, eine IPv6-Freigabe für den Test-Rechner zu machen und IPv6-Pings (oder auch mal temporär alles) zu erlauben. Vielleicht sind die fehlenden ICMPv6-Geschichten ja versehentlich mit in die Firewall gewandert, obwohl diese eigentlich nie geblockt werden dürften ...


Habe ich gestern auch schon gemacht. Wie in meinem ersten Beitrag geschrieben kommen Pings von außen an meinem HeimServer problemlos an.

Kannst gern auch selber schauen:
Geht: ping6 2a01:198:200:8c0d:20c:29ff:fe6d:19dc
Geht nicht: wget http://[2a01:198:200:8c0d:20c:29ff:fe6d:19dc]/ (Timeout :wut: )

Jürgen
Bild
JurgenS
erfahrener Kabelkunde
 
Beiträge: 73
Registriert: 28.03.2010, 12:09

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitragvon SpaceRat » 09.03.2015, 14:35

JurgenS hat geschrieben:Kannst gern auch selber schauen:
Geht: ping6 2a01:198:200:8c0d:20c:29ff:fe6d:19dc

Yepp.

Und:
Code: Alles auswählen
root@OpenWrt:~# i=1200; while ping6 -s $i -M do -nc1 2a01:198:200:8c0d:20c:29ff:fe6d:19dc >/dev/null; do i=$((i+1)); done; echo $((i-1+8))
1240


Irgendwas an der MTU is verkorkst.
Benutzeravatar
SpaceRat
Kabelkopfstation
 
Beiträge: 2619
Registriert: 08.05.2010, 01:30
Wohnort: Kreis Aachen

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitragvon JurgenS » 09.03.2015, 14:48

SpaceRat hat geschrieben:
Code: Alles auswählen
1240

Irgendwas an der MTU is verkorkst.

Naja, das ist doch was hasselholz schon auf Seite 1 schrieb und ich auf Seite 3 bestätigte. Ping6 nur bis Pufferlänge 1232. Dein Script zählt noch 8 dazu und zeigt 1240 an.

Die MTU in Fritzbox und SixXS steht aber momentan auf 1328. Was aber auch egal zu sein scheint. Auch mit 1280 oder 1400 immer dasselbe Verhalten.

:wand: :wand: :wand:
Bild
JurgenS
erfahrener Kabelkunde
 
Beiträge: 73
Registriert: 28.03.2010, 12:09

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitragvon SpaceRat » 09.03.2015, 14:59

JurgenS hat geschrieben:Die MTU in Fritzbox und SixXS steht aber momentan auf 1328. Was aber auch egal zu sein scheint. Auch mit 1280 oder 1400 immer dasselbe Verhalten.
:wand: :wand: :wand:

Man könnte mit der MTU für die IPv4-Verbindung rumspielen, sofern UM das nicht sofort überschreibt.
Es gibt diverse MTU-Einstellungen in der .export-Datei der Fritz!Box, an denen man mal drehen könnte.
Benutzeravatar
SpaceRat
Kabelkopfstation
 
Beiträge: 2619
Registriert: 08.05.2010, 01:30
Wohnort: Kreis Aachen

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitragvon JurgenS » 09.03.2015, 20:41

SpaceRat hat geschrieben:Man könnte mit der MTU für die IPv4-Verbindung rumspielen, sofern UM das nicht sofort überschreibt.
Es gibt diverse MTU-Einstellungen in der .export-Datei der Fritz!Box, an denen man mal drehen könnte.

Gute Idee. Ich habe dazu beide gleichartige Export-Dateien (6490 und 6360) miteinander verglichen um einen Ansatzpunkt zu finden an welchen Punkten sie sich unterscheiden. Alles was nach Firewall oder MTU oder so aussieht ist aber gleich eingestellt. Bliebe also nur blindes herumstochern...
Bild
JurgenS
erfahrener Kabelkunde
 
Beiträge: 73
Registriert: 28.03.2010, 12:09

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitragvon Andreas1969 » 12.03.2015, 09:34

Ich vermute mal,
es wird erst mal keine Lösung geben.
Oder hat noch jemand ne Idee?
Andreas1969
Glasfaserstrecke
 
Beiträge: 1894
Registriert: 05.03.2015, 08:50
Wohnort: Unitymedia NRW

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitragvon hasselholz » 12.03.2015, 23:43

vielleicht wenn alle, die davon betroffen sind mal bei UM anrufen und ein Ticket aufmachen :zwinker:
hasselholz
Kabelneuling
 
Beiträge: 12
Registriert: 12.02.2015, 08:05

Re: ipv6 Tunnel an ipv4 Anschluss - langsam

Beitragvon SpaceRat » 14.03.2015, 15:19

hasselholz hat geschrieben:vielleicht wenn alle, die davon betroffen sind mal bei UM anrufen und ein Ticket aufmachen :zwinker:

Wie willst Du erreichen, daß die ein Ticket aufmachen, wo doch eh alles die kleinen grünen Männchen, Wasseradern und der Stand des Mondes schuld sind?
Benutzeravatar
SpaceRat
Kabelkopfstation
 
Beiträge: 2619
Registriert: 08.05.2010, 01:30
Wohnort: Kreis Aachen

VorherigeNächste

Zurück zu Internet und Telefon über das TV-Kabelnetz

Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 49 Gäste

cron