- Anzeige -

VPN-Client-Verbindung zum Arbeitgeber

In vielen Netzen von Unitymedia sind Internet und Telefonie bereits verfügbar.
Wichtig:
  • Kunden aus Hessen und Nordrhein-Westfalen können über die Rufnummer 0221 / 466 191 00 Hilfe bei allen Problemen in Anspruch nehmen.
  • Kunden aus Baden-Württemberg können über die Rufnummer 0711 / 54 888 150 Hilfe bei allen Problemen in Anspruch nehmen.

Re: VPN-Client-Verbindung zum Arbeitgeber

Beitragvon Moses » 30.10.2007, 14:09

Ja, ne das stimmt. Der Vertrag beginnt erst mit der Installation des Modems. :)

Auf das Modem kann man übrigens zugreifen, einfach mal in den Browser als Adresse http://192.168.100.1 eintippen und als Username/Passwort: admin/motorola
Aber einstellen kann man da halt nichts in der Richtung und auch am Rest sollte man nicht unbedingt rumspielen...
Moses
Moderator
 
Beiträge: 7262
Registriert: 06.03.2007, 16:49
Wohnort: Bonn

Re: VPN-Client-Verbindung zum Arbeitgeber

Beitragvon frcasyl » 30.10.2007, 14:32

ah, okay, wenn das kabelmodem irgendwann mal wieder gehen sollte, werde ich das probieren.

was das widerrufsrecht angeht, steht das leider nirgends schriftlich, dass es erst mit installation des modem beginnt.

dagegen steht schriftlich (schwarz auf weiß) in der auftragsbestätigung von UM:

"Bei telefonischem Vertragsabschluss ..." - was ich ja gemacht haben - "können Sie den Vertrag innerhalb von zwei Wochen ab Zugang dieses Schreibens ohne Angabe von Gründen in Textform gegenüber der Unitymedia .... widerrufen".

Tja, und das wäre halt heute gewesen.

aber ich vertraue jetzt auf die mail von denen - hoffe, dass ich nicht zu blauäugig bin
frcasyl
Kabelneuling
 
Beiträge: 11
Registriert: 29.10.2007, 13:49

Re: VPN-Client-Verbindung zum Arbeitgeber

Beitragvon frcasyl » 30.10.2007, 14:41

@moses: danke, das mit dem zugriff auf das kabelmodem klappt sogar, wenn das modem an sich out-of-order bin

hab mal einfach alle bildschirme durchgeblättert. hast recht, viel kann man nicht ändern und bezüglich irgendwelcher protokolle oder ports habe ich da leider auch nix gefunden. aber zumindest konnte ich wieder irgendwas überprüfen. damit habe ich in dem forum bisher zig-mehr lösungsansätze bekommen, als von irgendeiner der UM-Hotlines.
frcasyl
Kabelneuling
 
Beiträge: 11
Registriert: 29.10.2007, 13:49

Re: VPN-Client-Verbindung zum Arbeitgeber

Beitragvon frcasyl » 31.10.2007, 16:08

hallo,

nach nun unzähligen anrufen bei diversen nummern von UM reicht es mir nun.

seit montag bin bzw. war ich kunde bei dieser unfähigen firma. das kabelmodem hat ganze 8 stunden gearbeitet (wenn auch mit den beschriebenen problemen, weshalb ich ja überhaupt erst einen eintrag in dieses forum gesetzt habe), seit dem geht aber nun gar nix mehr (siehe weiter oben). nach über 36 stunden und weiteren unzähligen anrufen bei UM, hat sich tatsächlich jemand herabgelassen und mich wegen der störung zurückgerufen und wollte einen termin für freitag nachmittag zur behebung vereinbaren.

das ist nicht nur ein witz, dass ist eine bodenlose unverschämtheit. die wollen echt keine neukunden, denen geht es echt zu gut. von 5 tagen als neukunde hätte ich dann ganze 8 stunden 3play 6000 nutzen können (oder auch nicht, wenn ich meine arbeitgebergeschichte hier so anschaue).

und keiner - egal von welcher hotline-stelle - ist auch nur daran interessiert, mich als neukunden zu halten.

somit werde ich nach absetzen dieses postings meine schriftliche kündigung im kundenservice (LOL) - center in bochum vorbeibringen.

so stümperhaft und wirklich unfähig ist nicht einmal der große telekomunikationsriese.

so, genug dampf abgelassen.

zum schluß wollte ich aber nochmal allen hier ganz herzlichen dank sagen, für die zahlreichen hilfen und tips, die ihr mir hier gegeben habt.

ich wünsche euch allen, dass ihr wirkich nie nie nie nie irgendwelche probleme mit euren UM-anschlüssen bekommt und somit in den fängen der UM-mühle gefangen seid.

in diesem sinne

tschüüüüß
frcasyl
Kabelneuling
 
Beiträge: 11
Registriert: 29.10.2007, 13:49

Re: VPN-Client-Verbindung zum Arbeitgeber

Beitragvon blutfink » 18.12.2007, 11:49

Hallo,

ich kann das VPN-/IPSec-Problem bei Unitymedia bestätigen. Siehe auch diese Diskussion im Heise-Forum:

http://www.heise.de/foren/go.shtml?read ... um_id=7303

Vielleicht tut sich ja was, wenn genügend Leute bei der Hotline anrufen. Die tun jedesmal so, als hätten sie noch nie davon gehört.

Gruß
blutfink
Kabelneuling
 
Beiträge: 1
Registriert: 18.12.2007, 11:42

Re: VPN-Client-Verbindung zum Arbeitgeber

Beitragvon giezet » 25.09.2008, 22:35

Ich grabe mal diesen alten Thread wieder aus. Möchte mal meine Erfahrungen hier teilen:

Habe hier 1play2000, am Kabelmodem hängt eine Soekris net5501 mit OpenBSD 4.3. Logischerweise fungiert sie nicht nur als VPN-Endpunkt (wenn's denn mal mit Unitymedia gehen würde), sondern auch als Router. Innerhalb der letzten zwei Monate habe ich - bis auf eine kurze Ausnahme - vergeblich versucht, ein IPsec-Tunnel zum Arbeitgeber aufzubauen. Die gleiche Box, mit gleicher Konfiguration und Software an einem anderen Internetprovider baute den Tunnel ohne wenn und aber auf.

Vor ca. 3-4 Wochen habe ich dann mal aus Langeweile noch einmal versucht, einen Tunnel aufzubauen - und plötzlich ging es! Ich war erleichtert und froh, doch die Freude währte nur wenige Tage. 4-5 Tage später funktionierte schon wieder NICHTS mehr. Wohlgemerkt, an der Software und Konfiguration wurde nicht ein Bit geändert.

Ich habe mich mal hingesetzt, und das Ganze ordentlich unter die Lupe genommen. Habe mir mal beide Tunnelendpunkte vorgenommen und mittels tcpdump die verschickten und empfangenen Pakete angeschaut. Es folgen jetzt zwei tcpdump-Auszüge, die dies demonstrieren:

Meine Soekris schickt Folgendes durch das Kabelmodem:

Code: Alles auswählen
22:05:14.205157 esp x.x.x.x > y.y.y.y spi 0xB0AD3687 seq 744 len 196 (ttl 64, id 46015, len 216)
22:05:15.205395 esp x.x.x.x > y.y.y.y spi 0xB0AD3687 seq 745 len 196 (ttl 64, id 51478, len 216)
22:05:19.206734 esp x.x.x.x > y.y.y.y spi 0xB0AD3687 seq 746 len 196 (ttl 64, id 63037, len 216)
22:05:20.216041 esp x.x.x.x > y.y.y.y spi 0xB0AD3687 seq 747 len 196 (ttl 64, id 42776, len 216)
22:05:21.207021 esp x.x.x.x > y.y.y.y spi 0xB0AD3687 seq 748 len 196 (ttl 64, id 35166, len 216)

Dies entspricht 5 icmp-echo-Paketen die über den Tunnel geschickt werden.

Am Tunnelendpunkt jedoch kommt Folgendes an:

Code: Alles auswählen
22:05:14.228068 esp x.x.x.x > y.y.y.y spi 0xB0AD3687 seq 744 len 196 [tos 0x3 (EC)] (ttl 55, id 46015, len 216)
22:05:15.231171 esp x.x.x.x > y.y.y.y spi 0xB0AD3687 seq 745 len 196 [tos 0x3 (EC)] (ttl 55, id 51478, len 216)
22:05:19.229810 esp x.x.x.x > y.y.y.y spi 0xB0AD3687 seq 746 len 196 [tos 0x3 (EC)] (ttl 55, id 63037, len 216)
22:05:20.239777 esp x.x.x.x > y.y.y.y spi 0xB0AD3687 seq 747 len 196 [tos 0x3 (EC)] (ttl 55, id 42776, len 216)
22:05:21.229816 esp x.x.x.x > y.y.y.y spi 0xB0AD3687 seq 748 len 196 [tos 0x3 (EC)] (ttl 55, id 35166, len 216)

Es ist ersichtlich, dass das Paket unterwegs verändert wurde. Das ankommende ESP-Paket wird verworfen, da wahrscheinlich die Prüfsumme des Pakets nicht mehr übereinstimmt. Also so etwas ist mir noch nie unter die Augen gekommen. In der kurzen Zeit, in der der Tunnel funktionierte, hatten die pakete das ToS-Bit NICHT gesetzt, die gesendete Version entsprach in 100% der, die auch tatsächlich am anderen Tunnelendpunkt ankam.

Ich habe keine Ahnung, wo diese Änderung auftritt. Der ToS-Code 0x3 bedeutet "Experienced Congestion", was normalerweise darauf hindeutet, dass der Router (nicht mein Router, sondern irgendwo auf dem Weg zum Tunnelendpunkt) eine auf gut Deutsch "Verstopfung" erfahren hat - hier tritt also ECN (Explicit Congestion Notification) in Kraft. Ist dieses Flag gesetzt, wird das ESP-Paket verworfen. Wohlgemerkt, der Aufbau des Tunnels (IKE Phase 1 und 2) klappt wie am Schnürchen, SAs werden korrekt aufgebaut.

Wird etwa damit bezweckt, VPN-Betrieb generell zu unterdrücken? Ich empfinde jedenfalls, dass dies nicht meinen Erwartungen an einen vernünftigen Internetanschluss entspricht. Der Vertrag ist sowieso schon gekündigt und ein Wechsel zu Netcologne steht an.

Trotzdem, wenn sich jemand findet, der vielleicht wüßte was hier läuft, dann wäre ich für Hilfe bzw. Inspirationen sehr dankbar. Eine Möglichkeit bietet sich noch, am 1. November kommt OpenBSD 4.4 raus, und die dortige Firewall wurde um die Möglichkeit erweitert, ToS-Flags von ankommenden Paketen "wegzuschrubben". Bin mal gespannt, was mich dann erwartet. Wenn der Tunnel läuft, wird es wenigstens eine "Notlösung" bis April, denn so lange klebt mir UM noch an der Backe.

Schade eigentlich, denn ich war immer von der Überlegenheit der Kabeltechnologie gegenüber DSL überzeugt. Man kann sich aber selbst die eigene Suppe versalzen, so wie es scheint.
giezet
fehlerhafte E-Mail-Adresse!
 
Beiträge: 2
Registriert: 25.09.2008, 16:11

Re: VPN-Client-Verbindung zum Arbeitgeber

Beitragvon Moses » 25.09.2008, 23:23

Also mein VPN Tunnel in die Uni funktioniert immer noch wie am Schnürchen. Der läuft über Cisco Server & Client (welcher ziemlich miserabel ist, geht aber leider nicht anders).
Moses
Moderator
 
Beiträge: 7262
Registriert: 06.03.2007, 16:49
Wohnort: Bonn

Re: VPN-Client-Verbindung zum Arbeitgeber

Beitragvon giezet » 25.09.2008, 23:27

Es ist möglich, dass der VPN-Konzentrator Deiner Uni womöglich die ECN-Flags ignoriert (oder explizit dazu durch entspr. Konfiguration gezwungen wurde). Das könnte abhängig sein von der verwendeten IPsec-Implementation. Ich habe hier auch einen Cisco-Client der sich zur FH Köln verbindet - wohlgemerkt nur der Tunnelaufbau, der Rest ist wie in meinem letzten Beitrag.
giezet
fehlerhafte E-Mail-Adresse!
 
Beiträge: 2
Registriert: 25.09.2008, 16:11

Re: VPN-Client-Verbindung zum Arbeitgeber

Beitragvon piotr » 25.09.2008, 23:43

@giezet:
Dein Log zeigt leider nicht, wo es moeglicherweise im UM-Netz passiert.
Denn dazu fehlt ein traceroute zwischen den oeffentlichen IPs der beiden VPN-Endpunkte.

Es zeigt aber, dass ECN-Bits gesetzt wurden.

Anmerkungen zum TOS-Feld im IP-Header:

Das TOS-Feld gibt es seit Dez 1998(!) nicht mehr.
Seit Dez 1998 ersetzt DSCP die ersten 6 Bits und zusaetzlich seit Sept 2001 ECN die letzten beiden Bit des ehem. TOS-Feldes. Zwischen Dez 1998 und Sept 2001 waren die ECN-Bits als reserviert gekennzeichnet.

Kann Deine OpenBSD-Kiste NAT-T (NAT-Traversal)?
NAT-T kapselt ESP-Pakete in UDP ein und versendet diese dann auf dem UDP-Port 4500 (anstelle eines reinen ESP-Paketes).

Mit dem Einsatz von NAT-T koennen Probleme mit ESP-Paketen behoben werden.
piotr
Glasfaserstrecke
 
Beiträge: 2209
Registriert: 13.08.2008, 18:26

Re: VPN-Client-Verbindung zum Arbeitgeber

Beitragvon Dinniz » 26.09.2008, 08:14

Früher gab es damal probleme auf einem routingpunkt bei UM soweit ich weiss.
Hatte mal einen Kunden mit dem gleichen Problem - ist allerdings schon bald nen Jahr her.
destroying ne3/4 since 2002
Benutzeravatar
Dinniz
Carrier
 
Beiträge: 10368
Registriert: 21.01.2008, 23:43
Wohnort: NRW

VorherigeNächste

Zurück zu Internet und Telefon über das TV-Kabelnetz

Wer ist online?

Mitglieder in diesem Forum: Baidu [Spider], MSNbot Media und 59 Gäste