- Anzeige -

MTU Wert zu niedrig?

In vielen Netzen von Unitymedia sind Internet und Telefonie bereits verfügbar.
Wichtig:
  • Kunden aus Hessen und Nordrhein-Westfalen können über die Rufnummer 0221 / 466 191 00 Hilfe bei allen Problemen in Anspruch nehmen.
  • Kunden aus Baden-Württemberg können über die Rufnummer 0711 / 54 888 150 Hilfe bei allen Problemen in Anspruch nehmen.

Re: MTU Wert zu niedrig?

Beitragvon piotr » 29.06.2011, 22:56

TcpNoDelay ist der Wert fuer das Ein-/Ausschalten vom Nagle Algorithmus.
TcpAckFrequency 1 sagt, dass jedes erhaltene TCP-Paket sofort bestaetigt (TCP-ACK) wird.

Geh mal in die Eingabeaufforderung mit erhoehten Rechten:
Start -> ins Suchfenster cmd eintippern und mit gleichzeitigem Halten der zwei Tasten Strg+Shift und dazu dann Enter druecken oeffnen.
Jetzt muesste die Benutzerkontensteuerung vom Vista/Win7 eine Bestaetigung verlangen.
Danach oeffnet sich die Eingabeaufforderung. Wenn der Pfad mit C:\Windows\System32 anfaengt, ist es die Version mit erweiterten Rechten, die Du jetzt brauchst. Wenn der Pfad dagegen mit C:\Users anfaengt, dann ist es die normale Version.

Dann mal hier posten was der folgende Befehl ausgibt:
Code: Alles auswählen
netsh interface tcp show global
piotr
Glasfaserstrecke
 
Beiträge: 2209
Registriert: 13.08.2008, 18:26

Re: MTU Wert zu niedrig?

Beitragvon Hellifax » 30.06.2011, 00:53

piotr hat geschrieben:TcpNoDelay ist der Wert fuer das Ein-/Ausschalten vom Nagle Algorithmus.
TcpAckFrequency 1 sagt, dass jedes erhaltene TCP-Paket sofort bestaetigt (TCP-ACK) wird.

Geh mal in die Eingabeaufforderung mit erhoehten Rechten:
Start -> ins Suchfenster cmd eintippern und mit gleichzeitigem Halten der zwei Tasten Strg+Shift und dazu dann Enter druecken oeffnen.
Jetzt muesste die Benutzerkontensteuerung vom Vista/Win7 eine Bestaetigung verlangen.
Danach oeffnet sich die Eingabeaufforderung. Wenn der Pfad mit C:\Windows\System32 anfaengt, ist es die Version mit erweiterten Rechten, die Du jetzt brauchst. Wenn der Pfad dagegen mit C:\Users anfaengt, dann ist es die normale Version.

Dann mal hier posten was der folgende Befehl ausgibt:
Code: Alles auswählen
netsh interface tcp show global




Ok hier das Ergebnis:

Globale Tcp Parameter

Empfangsseite----->enabled
Chimney - Abladestatus---------->automatic
NetDMA-Status------>enabled
Direkter Cachezugriff---------->disabled
Autom.Abstimmungsgrad Empfangsfenster------>normal
Add-on Überlastungssteuerungsanbieter--->none
ECN-Funktion---------->disabled
RFC 1323 - Zeitstempel---------->disabled
------------------------------------------------------------------------------
Da ich wirklich nicht weiss was das jetzt im allgemeinen heißt...hoffe ich das Du Mir da weiterhelfen kannst,
vieleicht kann man anhand der Parameter erkenen,was nicht in ordnung zu scheinen scheint. :kratz:
Hellifax
erfahrener Kabelkunde
 
Beiträge: 97
Registriert: 02.08.2009, 14:54

Re: MTU Wert zu niedrig?

Beitragvon piotr » 30.06.2011, 05:46

Probiere mal -wieder in der Eingabeaufforderung mit erhoehten Rechten-:

Code: Alles auswählen
netsh int tcp set global autotuninglevel=restricted

oder falls das restricted wenig hilft anstelle des restricted auch diese Werte highlyrestricted bzw. disabled

Es aendert die Einstellung Autom.Abstimmungsgrad Empfangsfenster------>normal
Zurueck zur aktuellen Einstellung geht es mit dem Wert normal.
piotr
Glasfaserstrecke
 
Beiträge: 2209
Registriert: 13.08.2008, 18:26

Re: MTU Wert zu niedrig?

Beitragvon Hellifax » 30.06.2011, 18:00

habe es gemacht..kam dann die bestätigung mit OK.
Aber was hat das jetzt gebracht?

Edit:So habe Netalyzr ausgeführ und nun folgendes Ergebniss: Messungen des Netzpuffers (?): Uplink 1500 ms, Der Downlink ist gut.
ABER!!!!!

Leider immer noch:Bei einem solchen Pufferwert ist die Performance von Echtzeitanwendungen wie etwa Spielen oder Audio-Chats möglicherweise recht schlecht, wenn Sie gleichzeitig große Uploads ausführen.

Der Downlink ist gut diese Meldung hatte ich bisher noch nicht bekommen...vieleicht ein kleiner fortschritt :D




Geringfügige Abweichungen

Bestimmte TCP-Protokolle werden im abgehenden Datenverkehr gesperrt.
Die Paketpufferung im Netzwerk ist möglicherweise zu hoch.
Nicht alle DNS Anfragetypen wurden korrekt bearbeitet
Zuletzt geändert von Hellifax am 30.06.2011, 18:19, insgesamt 1-mal geändert.
Hellifax
erfahrener Kabelkunde
 
Beiträge: 97
Registriert: 02.08.2009, 14:54

Re: MTU Wert zu niedrig?

Beitragvon piotr » 30.06.2011, 18:19

Die Werte sind ok, sie entsprechen Deiner Ausgabe nach den Werkseinstellung von Windows 7.

Der Wert fuer autotuninglevel bestimmt wie gross die TCP-Fenstergroesse und damit der notwendige Buffer werden darf.
Manche Router, v.a. aeltere Modelle, kommen hier mit den Werkseinstellungen von Vista/Win7 nicht klar.
Da hilft es dann manchmal dieses Verhalten etwas zu nach unten zu beeinflussen (mit restricted bzw. der staerkeren Stufe highlyrestricted) oder gar auf die konservativste Einstellung max 65535 Byte zu setzen (Wert disabled).

Deshalb auch die Frage wie es vor einer Aenderung aussieht damit Du es wieder auf den urspruenglichen Wert setzen kannst.

Das Setzen dieser Einstellung wirkt sofort, ohne Reboot.
Zuletzt geändert von piotr am 30.06.2011, 18:22, insgesamt 1-mal geändert.
piotr
Glasfaserstrecke
 
Beiträge: 2209
Registriert: 13.08.2008, 18:26

Re: MTU Wert zu niedrig?

Beitragvon Hellifax » 30.06.2011, 18:21

Werde ich das in Online Games jetzt deutlicher merken das sich was geändert hat..oder
wie schlägt sich das aus?
Hellifax
erfahrener Kabelkunde
 
Beiträge: 97
Registriert: 02.08.2009, 14:54

Re: MTU Wert zu niedrig?

Beitragvon piotr » 30.06.2011, 18:23

Die Einstellungen TCPNoDelay und TcpAckFrequency definitiv bei allen auf TCP basierten Spielen (z.B. WOW).
Die Einstellungsmoeglichkeiten beim autotuninglevel moeglicherweise auch, muss aber nicht zwingend sein.
piotr
Glasfaserstrecke
 
Beiträge: 2209
Registriert: 13.08.2008, 18:26

Re: MTU Wert zu niedrig?

Beitragvon Hellifax » 30.06.2011, 19:57

Habe gerade mal Myhtos angespielt und mir ist nichts aufgefallen alles so wie vorher.
Ka wie es mit den anderen Games ist...müßt ich dann erst noch drauf tun.....aber ich gebe die Hoffnung solangsam auf.
Hellifax
erfahrener Kabelkunde
 
Beiträge: 97
Registriert: 02.08.2009, 14:54

Re: MTU Wert zu niedrig?

Beitragvon Hellifax » 30.06.2011, 20:15

Hellifax hat geschrieben:Habe gerade mal Myhtos angespielt und mir ist nichts aufgefallen alles so wie vorher.
Ka wie es mit den anderen Games ist...müßt ich dann erst noch drauf tun.....aber ich gebe die Hoffnung solangsam auf.



Edit:Habe jetzt 30 min Forsaken World gespielt...hatte die ganze zeit einen Ping von 250-300 ms laut der ImGame anzeige...und am Laggen ohne Ende... :wut:
Hellifax
erfahrener Kabelkunde
 
Beiträge: 97
Registriert: 02.08.2009, 14:54

Re: MTU Wert zu niedrig?

Beitragvon piotr » 30.06.2011, 20:32

Du kannst noch den Wert aus der Liste Add-on Überlastungssteuerungsanbieter--->none mal mit einem anderen Wert versuchen.

Code: Alles auswählen
netsh interface tcp set global congestionprovider=ctcp


Zurueck gehts hier mit dem Wert none
piotr
Glasfaserstrecke
 
Beiträge: 2209
Registriert: 13.08.2008, 18:26

VorherigeNächste

Zurück zu Internet und Telefon über das TV-Kabelnetz

Wer ist online?

Mitglieder in diesem Forum: MSNbot Media, Yahoo [Bot] und 57 Gäste