- Anzeige -

Lags bei Vollspeed-Download

In vielen Netzen von Unitymedia sind Internet und Telefonie bereits verfügbar.
Wichtig:
  • Kunden aus Hessen und Nordrhein-Westfalen können über die Rufnummer 0221 / 466 191 00 Hilfe bei allen Problemen in Anspruch nehmen.
  • Kunden aus Baden-Württemberg können über die Rufnummer 0711 / 54 888 150 Hilfe bei allen Problemen in Anspruch nehmen.

Lags bei Vollspeed-Download

Beitragvon bomba » 13.08.2010, 23:39

Moin Moin :)

Ich hoff ich bin hier richtig und poste nicht doppelt. Gesucht hab ich aber gefunden hab ich nichts ;)

Also ich hab folgende Problematik:

Sobald ich über 5,5-6,0mb/s komme im Download, laufen alle anderen Online-Anwendungen quasi in einen TimeOut.

Zb: Ich bin auf opensuse, zieh mir die aktuelle DVD, 4,6GB ~8mb/s, geht nichts andere mehr. Kann nicht mehr surfen, pings haben auf einmal astronomische Werte von 0,5-1sec (und mehr) etc pp.

Die Probleme hab ich aber nur beim Downloaden. Wenn ich Uploade ist das alles kein Problem. Ich kann mit ca 600kb/s Uploaden und alles andere läuft noch rund.

Ich habe halt das standard Cisco-Modem, dann den DIR-600 (ich vermute fast da die Quelle) und dann halt meinen Rechner. (ist egal welches Betriebsystem ich nutze).

Den DIR600 hab ich gerade auf Version 2.03 geupdatet und hat nichts gebracht.

Ich konnte bis dato (komme zur Zeit schlecht an die Verkablung dran) das Modem selber nicht an den PC so anschließen.

Aber vllt. kann mir wer sagen: jo is der Router, oder nö das is dies oder jenes oder oder oder :)

*edit*

Achja QOS ist ausprobiert. Mit QOS hab ich etwas weniger lags, aber verliere gute 3mb/s. Ohne QOS hab ich vollspeed aber das oben genannte Problem.

Lieb Grüße und besten Dank.
Bild
bomba
Kabelneuling
 
Beiträge: 3
Registriert: 13.08.2010, 23:31

Re: Lags bei Vollspeed-Download

Beitragvon Dringi » 14.08.2010, 11:29

Kann ich so nachvollziehen, wenn ich mit 2Play20.000 mit 2,5 MByte/sek gezogen habe, bzw. mit 2Play32.000 mit 4,0 MByte/sek ziehe, was ja beides ca. 99%ige bis 100%ige Geschwindigkeit bedeutet, dann ist mit Surven selber nichts mehr. Selbst ICQ verliert manchmal die Connection. Aber - und das wundert mich etwas bei Dir - wenn ich etwas Luft nach oben habe (300 oder 400 KB/Sek reichen schon), dann geht auch wieder Surfen und ICQ bleibt online.

BTW: Schon mal probiert bei Volllast mit dem UM-Anschluss zu telefonieren? Selbst da bekomme ich Probleme.
Bild Bild
Dringi
Glasfaserstrecke
 
Beiträge: 1229
Registriert: 16.01.2010, 22:04

Re: Lags bei Vollspeed-Download

Beitragvon Matrix110 » 14.08.2010, 11:47

Da benötigt jemand Traffic Shaping :P

Kannst ja mal testweise cFos Speed installieren auf Windows:
http://www.cfos.de/download/download.htm

Sollte es dann problemlos funktionieren, müsste man sich halt nach einem Router mit Traffic Shaping umschauen oder Linux alternativen suchen.
Benutzeravatar
Matrix110
Glasfaserstrecke
 
Beiträge: 2345
Registriert: 20.12.2008, 16:18

Re: Lags bei Vollspeed-Download

Beitragvon bomba » 14.08.2010, 13:58

Hossa,

so hab den DIR-600 mal fix auf DDRWT geflashed, der kann Traffic-Shaping. Gleiche Problem, ich komm nur noch auf 44mbit. Aber kein gelagge mehr.

Hmpf!

Nervig/ärgerlich ist es scho, weil zahl ja für 64 dann will ich die auch nutzen.

Grüße
Bild
bomba
Kabelneuling
 
Beiträge: 3
Registriert: 13.08.2010, 23:31

Re: Lags bei Vollspeed-Download

Beitragvon Matrix110 » 14.08.2010, 23:10

Hat DD-WRT mittlerweile richtiges Traffic Shaping und nicht nur noch TCP Vegas? (was leider nicht wirklich gut funktioniert)

Früher mit 2MBit hatte ich solche probleme, wie du sie beschreibst auch. (also bei Fullspeed UL/DL ging so ca. garnix)
Seit ich jedoch cFos Speed nutze bzw. das Tomato Traffic Shaping (welches sehr sehr schön konfigurierbar ist mit Gruppen etc.) läuft alles wunderbar.
Mit 20MBit bzw. 32MBit hab ich das Traffic Shaping vom Router allerdings ausgeschaltet, da dessen CPU da sehr stark belastet wird und regele das ganze mit der eh vorhandenen cFos Lizenz :)
Benutzeravatar
Matrix110
Glasfaserstrecke
 
Beiträge: 2345
Registriert: 20.12.2008, 16:18

Re: Lags bei Vollspeed-Download

Beitragvon addicted » 15.08.2010, 13:56

bomba hat geschrieben:... opensuse, zieh mir die aktuelle DVD, 4,6GB ~8mb/s, ... pings haben auf einmal astronomische Werte von 0,5-1sec (und mehr)
...
Achja QOS ist ausprobiert. Mit QOS hab ich etwas weniger lags, aber verliere gute 3mb/s. Ohne QOS hab ich vollspeed aber das oben genannte Problem.

Die Lags kommen zustande, weil auf CMTS-Seite die Pakete für dich zwischengelagert werden, wenn Deine Leitung schon "voll" ist. Diese Lager sind abartig groß, so dass einzelne Pakete durchaus eine oder zwei Sekunden insgesamt unterwegs sind. Normalerweise ist TCP in der Lage Congestion ("volle Leitung") festzustellen, aber das dauert eine Weile und muss für jede Verbindung neu gemacht werden. Je mehr Verbindungen offen sind, desto weniger gut funktioniert das. Viele TCP/IP Tuner Programme verändern zusätzlich diese Eigenschaften des TCP Protokolls, so dass "mehr Speed" erreicht wird, was bei einer vollen Leitung deutlich zu Lasten der Latenz geht.

Traffic Shaping verlagert die Paketwarteschlange vom CMTS auf den Router beim Kunden. Das hat mehrere Folgen:
1) Der Router muss sich auf einmal viel mehr Status merken
2) Der Router muss etwas deutlicher auf jedes Paket schauen, um festzustellen, welches er wann weiterleiten soll

Dafür brauchen Router sowohl Speicher alsauch Rechenleistung. In den üblichen WAN-Routern für Endkunden sind beide Ressourcen knapp, da sie meistens nicht für Geschwindigkeiten jenseits 50MBit/s ausgelegt sind. Deshalb geht die Übertragungsgeschwindigkeit (meistens deutlich) runter, wenn man Shaping/Prioritisierung aktiviert.

Das kann man tun:
1) Geilere Hardware verwenden. Ich bin auf die Leistung der FB 6360 gespannt, verwende aber einen selbstgebauten x86 Linux Router.
2) Downloads von vorneherein nicht mit Top-Speed machen, z.B. lassen sich FTP-Clients oft auf eine maximale Downloadgeschwindigkeit einstellen.
3) Damit leben.
addicted
Glasfaserstrecke
 
Beiträge: 2042
Registriert: 15.03.2010, 03:35
Wohnort: Paderborn

Re: Lags bei Vollspeed-Download

Beitragvon bomba » 15.08.2010, 17:19

Hi,

ja ich dachte mir scho das es an der Leistung hapert!

Naja hab hier noch ne Sun stehen, vllt wird das Dingen mein Router.

Hab mir nun erstemal den Linksys von meinem Bro besorgt, der sollte mitt der Woche ankommen.

Dann installier ich mir eh mal OpenWRT und Tomato. Wenn alles nicht hilft kommt der SunRouter.

Und ob DDwrt richtiges Shaping kann weiß ich nich wo seh ichn das?

Grüßle
Bild
bomba
Kabelneuling
 
Beiträge: 3
Registriert: 13.08.2010, 23:31


Zurück zu Internet und Telefon über das TV-Kabelnetz

Wer ist online?

Mitglieder in diesem Forum: MartinDJR und 53 Gäste